Outlook 2000 over a VPN connection and MTU settings

We currently run Exchange server 5.5 over a Windows NT4.0 Server box, we use Sonicwall Pro as a firewall and the VPN client that comes with it for our VPN activities.

Anytime anyone connects to the network via VPN they can perform any operation that they want, browse the network, Internal web based applications, etc. They cannot however use Outlook 2000 to check their e-mail. You can see the e-mail server and you can even ping it and get a reply. If you open Outlook it sits there for a few minutes and then ask if you want to work offline.

I have done a substantial amount of research into the subject and it appears the Outlook over VPN is a problem for a lot of people. Apparently the main culprit is the ip packet size. The VPN’s addition of ipsec makes the packets to large for Exchange and Outlook to handle.

A possible fix I would assume is to go into Exchange Server or NT4.0 on the box all this sits on and lower the MTU value of NT or Exchange. My question is there any way to do this. I thought maybe TweekUI, but I can’t seem to find one for NT 4.0 server.

Also any thoughts or comments that I may be totally off base and there is another solution, I’m more than willing to entertain suggestions.

Thank You

Charles
crusade1Asked:
Who is Participating?
 
rmorphisConnect With a Mentor Commented:
Here's the link to the reg keys to change the MTU size...

http://support.microsoft.com/default.aspx?scid=kb;EN-US;q120642

to determine what MTU size to use, establish a VPN session and try to ping the mail server with ping -f -n <number of pings> -l <size> <destination ip> ex: ping -f -n 1 -l 1472 198.170.120.1. The problem may be between your clients and VPN server or even clients and their ISP. gonna take some experimenting.

Good Luck!
0
 
KenBunceCommented:
I have found with my VPN clients that creating host files seem to eliminate alot of the timeout issues related to name resolution. How are your Outlook 2K clients configured?
0
 
crusade1Author Commented:
Ken

Not sure what you mean by host files, but the Outlook 2K clients are configured to use the Exchange Server X400 protocol exclusively.

The same clients that have Outlook over VPN timeout issues have absolutly no problem when they come into the office and connect to the Exchange Server normally.

The crappy thing about this whole set-up is that it does occasionally work. I think sometimes traffic is low enough where packet overhead is a non-issue
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
crusade1Author Commented:
Basically there is no concrete answer to this, but you sir have done the best by far in helping me.

Thank You
0
 
crusade1Author Commented:
To anyone who may read this in the future I had to did deeper to actually fix the problem:

Believe it or not it had to do with a RAS server entry in the Registry. VPN opens a PPTP connection with NT and RAS handles all PPTP connections regardless of the source. You need to make 2 small additions to the registry, very quick, very easy, which you can then set the MTU to say 1404 which should stop all packet fragmentation and let you use your e-mail correctly

There is an article on www.microsoft.com in the knowledge base the Q article # is Q183229 it will explain how to make the additions to the registry.
0
 
HansJCommented:
Hi,
Solved that problem by;
Edit in the IP address of the mailserver in the;
c:\winnt\system32\drivers\etc\hosts
e.g.
192.168.1.1  NameOfMailserver

This has to do with different routers possibility to work with WINS/DNS.


cheers,
Hans
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.