Cd-Rom not recognized

I tried everything I know still not recognized.
Win 2K Pro. TeacCD 224E CD-Rom for notebook
Teac says its a generic microsoft driver and they wont put one down for download.
Since the cd-rom doesn't work I can't look for the driver in my disk.
I erased the inf file and copied from another computer the file. Nothing.
Uninstalled and installed several times.
Since this Cdrom was used with win 95-98 tried installing the only generic there is available
but nothing
Who is Participating?
rburrConnect With a Mentor Commented:
I had the same problem w/ Win2k.  I came across your posting when searching for the solution.

See MS kb article 314060 (;en-us;314060) which instructs you to delete particular registry values from HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}

The article is for WinXP, but it worked for Win2k.  I had to remove the entire key (in safe mode,) but it got my CDROMs back.
First off when was last time you knew the CD worked? When you boot your system does the BIOS detect it? If not then there is a problem with the drive or the connection or the BIOS has been changed not to detect it.

This is from the TEAC site

"NOTE:  If your Notebook PC came with a pre-installed TEAC CDROM drive, please contact your system's manufacturer for support issues regarding drive installation and operation."

Also according to the Windows Hardware Compatiblity List this model is not being shown as being compatible with Win2000.

The Crazy One
Just so you know you are not alone
"Posted by lion King on February 22, 2002 at 10:46:18:

This CD used to work fine, and there is no
driver for it, OS provide the support.

It is not assigned a driver on Win2k, but I can see it
on device manager, it also says there is registry corruption, [code 19], I followed the instruction but nothing happens.

uninstall and reinstall won't solve the problem. I suspect the IDE controller was screwed...

Is there a way to solve the problem instead of re-install win2k? Thanks. "
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Troubleshooting: TEAC CD-224E-Bxx CD-ROM Drive User's Guide
"All TEAC Drives are certified by Microsoft, which means, if you connect the Drive on your PC and Start your System, the Drive is recognized by Windows automatically. It´s not necessary to install a special Driver for this Drive. If you want to install a Recorder or Rewritable, you must also install a Recordingsoftware like Nero Burning Rom, Win on CD or Adaptec Easy CD Creator.

If you can´t see the CD-Recorder in the Device-Manager/CD-Rom, in the most cases the reasons are:

Master/Slave Configuration
A Pin on IDE-Connector is distorted or broken.
The Busmasterdriver is not correctly installed or the Driver is very old. "
So far all I have been able to find is drivers for DOS
Also see if this file is in the Winnt\Drivers Cache if not then If you have access to a machine that has a working CD drive and you have a zip drive then take your Win2000 CD and tranfer the file which is in the i386 folder to the zip disk. The drivers are in this file. If you can't tranfer the cab file then at least see if you can open it up with an unzipping utility and grab these files, at least these are the ones my system is using.


and maybe

You also might find these files in your C:\WINNT\system32\dllcache folder
doxaAuthor Commented:
I pressed the wrong button and gave by mistake the answer to msbessor
but didn't fix anything.
I just wanted to ask him about the registry IDE idea

Thank you for your research but I have tried all that.
Been using the CD-ROm since upgrading to 2K since October last year
lost it after a hacker intrussion.

JamCIMITConnect With a Mentor Commented:

I was having a similar problem on a new W2K Pro Installation.

My new CDRW installed fine but disapeared after loading both Roxio and updating Windows Media Player.  I tried everything listed by MS and Roxio, but I was still getting a Registry Code 19 error from the drive!! I was just about to give up and reformat when I came across this little gem from Nero...

This is their description...

"If the CD drives are not visable anymore after installing a software supporting CD recorders, there might be a problem with the CD drivers. The Nero Registry Checker is checking the installation of the drivers and correct them, if necessary."

I ran this utility, rebooted and zazoom my CD was BACK!! :)

I don't even use Nero but Three Cheers to them for squashing a known bug that MS and Roxio haven't been able to address!!

I have since reinstalled Roxio and updated MS Media Player Without their Stupid Adaptec CD Burner add-on and all is still working.  Much better than reformatting after having my CDR dead in the water for 2 weeks!!

I sure hope this works as well for you!

Well done Jamie.

I have been tearing my hair out trying to remedy this problem and it is without doubt caused (in my case at least) by Roxio + Win2K!

This gem from Nero sorted the problem quickly and easily and it begs the question 'What are Roxio and MS playing at?' My system is a brand new build which worked perfectly well under win98 but developed this problem following an install of win2k and Roxio. A download of the latest service pack from MS and new firmware drivers proved useless.

Hoorah for Nero!

---- CLEAN UP ----

No comment has been added lately (143 days), so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area for this question:

RECOMMENDATION: [ Split points between rburr and JamCIMIT ]

Please leave any comments here within the next seven days.


Rajiv Makhijani
EE Cleanup Volunteer
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.