• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 151
  • Last Modified:

Win 98 Login Script (Home Directory) on 2K Server

We have a 2K Server running w/ a mixed mode of clients, we would like the login script to create the home directories and map the client to that directory ... i thought the command was \\servername\folder\%USERNAME% .. however, that does not work ... any help would be greatly appreciated ...
0
gmaynard
Asked:
gmaynard
1 Solution
 
jmiller47Commented:
Im not sure what you mean by 'The command'

There are 2 things you need to do:

Define the Home directory and drive letter in Active Directory Computers and Users. This will probably by \\servername\share\%username%

Then in the user's logon batch file will be (If Y is to be their home directory):
NET USE Y: /HOME


I hope this helps
0
 
deforeCommented:
You can't do a MAPROOT with a win98 machine. You can not map past the share like you can with novell and win2k clients. There is a program called kix32 that will let you do this.

See here

http://support.microsoft.com/default.aspx?scid=kb;EN-US;q175732
0
 
s0mvnguyCommented:
Win98 was not designed for the workgroup environment, so the Net command is not there.  You can try this third party software (which been working great for me): http://www.kixtart.org/

Hope this help.
m.
0
Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

 
jmiller47Commented:
NET is available for Windows 98, but i believe the comment about not mapping past the share is correct.

What we had to do was to share each user's home directory. Then the user's settings would be set to \\servername\%username%

I hope this helps
0
 
jmiller47Commented:
BTW - The reason that we went with creating a share for each user's and not implementing Kixstart was that it seemed to be a lot more work to implement Kixstart than just sharing the folders that we needed. Just my opinion...
0
 
gmaynardAuthor Commented:
at the moment im inclined to go w/ the jmiller47 route if u can tell me why i still cannot get the %username% to work w/in 98 ... i have the users folder shared (w/ correct permissions) and type the command net use h: \\servername\%username% telling me that the syntax is incorrect ... are u SURE u can do this? ... i know im set up correctly ... type the command in your self and see if you dont get the same error ... let me know ... thanks
0
 
jmiller47Commented:
Windows 98 doesnt allow %username% variables.

Therefore, you must  define the home directory as \\servername\%username% in the user's account (Active Directory Users and Computers) and use the following command in your logon scripts:

NET USE H /HOME

Try that with one user and see if it fixes your problem.
0
 
jmiller47Commented:
I apologize. that last line was supposed to be:

NET USE H: /HOME

Has your question been answered? We haven't heard from you in a long time. Have you abandoned this question?
0
 
netwiz562Commented:
---- CLEAN UP ----

gmaynard,
No comment has been added lately (367 days), so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area for this question:

RECOMMENDATION: [ Award points to jmiller47 ]

Please leave any comments here within the next seven days.

¡PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

------------------------------
Rajiv Makhijani
EE Cleanup Volunteer
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now