• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 249
  • Last Modified:

Compiling Apache, mod_perl and others

Trying to compile Apache, and it's driving me nutz.  I can either compile Apache with all my modules EXCEPT mod_perl, or I can have mod_perl.  Anyone know what I am going wrong here?

./configure \
--prefix=/path/to/apache/v1.3.24 \
--enable-module=rewrite \
--enable-shared=rewrite \
--enable-module=proxy \
--enable-shared=proxy \
--activate-module=src/modules/perl/libperl.a \
--enable-shared=perl \
--enable-suexec \
--suexec-caller=apache \
--suexec-userdir=docs \
--suexec-uidmin=10000 \
--suexec-gidmin=10000

According to the docs --activate-module=src/modules/perl/libperl.a should get mod_perl loaded, but its not showing up when I do an httpd -l.  If I do a "perl Makefile.pl" in mod_perl it builds Apache, I run make, but it doesnt install my other modules!
0
thetool721
Asked:
thetool721
  • 3
  • 2
1 Solution
 
samriCommented:
What is your OS Platform?

I used to have that problem before.  Decided to forget mod_perl, and download a precompile binaries (RPM) that has mod_perl built-in.

http://perl.apache.org/distributions.html
0
 
thetool721Author Commented:
Doh, forgot to include the important information

OS: RedHat Linux 7.1

I finally got it compiled, but I had to manually compile mod_perl.so in the perl source using apxs.  Every other method they offered didn't seem to give me what I needed!
0
 
samriCommented:
It's great to hear that you finally got it tackled.

At this point, you can get you pts refunded by placing a "0" pts qts in community Support topic area.

However, the solution is valid, and should be good for future reference.

I bet the EE Moderator should be able to assist.

cheers.
0
 
thetool721Author Commented:
My final solution was as follows:

Configured/Compiled Apache v1.3.24 using the following command

/configure \
--prefix=/path/to/apache/v1.3.24 \
--enable-module=rewrite \
--enable-shared=rewrite \
--enable-module=proxy \
--enable-shared=proxy \
--enable-suexec \
--suexec-caller=apache \
--suexec-userdir=docs \
--suexec-uidmin=10000 \
--suexec-gidmin=10000

make
make install

By compiling Apache and enabling mod_rewrite and mod_proxy as shared, it enabled DSO on my Apache installation.  If you don't need these, you'll have to tell APache to enable it.  Since I am compiling mod_perl as a DSO, this is required.

Then went to mod_perl src directory, into APACI directory and ran:

./configure \
--with-apxs=/path/to/apache/v1.3.24/bin/apxs

make
make install

That was it.  Make sure the SO file is in libexec and you should be ready to go.
0
 
thetool721Author Commented:
samri,

I am going to accept one of your comments as answers.  This way the knowledge stays in the system without having to pull any crazy stunts ;-)

Thanks for the assistance!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now