Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

MSCMS: Login doesn't log in

Posted on 2002-06-06
6
Medium Priority
?
203 Views
Last Modified: 2013-12-25
Hi,

I've got a problem when logging in to use the web editor. I have set up four channels, one for each host header and set up the SCA to map the channels to the host headers.

The sites are open for reading for all users. Editing requires login with NT authentication. When I login using Autosession.ManualLogin to enable the user to go to edit mode things go weird.

The login sequence goes well but when I return to the site I'm still not logged in! The AUTH_TOKEN doesn't appear to have been set.

BUT - If I do the above when logged on locally on the server it works just fine.

Can anybody help me out?

Best regards,

Anders

0
Comment
Question by:aha
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
6 Comments
 

Expert Comment

by:quirkyquirky
ID: 7299247
0
 

Expert Comment

by:ComTech
ID: 7300544
This person has been suspended for multiple violations of the Member Agreement, and will reject the proposed answer, and return your question to the Active Questions List.  The Moderator Group is deleting all 388 locked questions.

These were posted by three persons:

quirkyquirky
EliteKiller
liloXwin
 
Thank you,
ComTech
CS Admin @ EE
0
 

Expert Comment

by:Wydget
ID: 7304315
Not 100% sure on this, but you should check the IIS security settings for the NR directory, or any directories you are using as an entry point into your cms sites.  If they are set to allow anonomous access, CMS will not authenticate.  This may only be when using windows authentication though, and not the autosession.manuallogin method.

To force CMS to authenticate without changing the IIS settings for your NR directory, have your site entry point as a redirect page in another directory that has anon access disabled.
0
 

Author Comment

by:aha
ID: 7304443
Thanks all,

But I've found a solution thanks to a news group. The problem (or bug as I'd preffer to call it) occurred because I had underscores "_" in my host header names. When I removed the underscores it worked perfectly.

Regards,

Anders
0
 
LVL 1

Accepted Solution

by:
Computer101 earned 0 total points
ID: 11102903
PAQed, with points refunded (200)

Computer101
E-E Admin
0

Featured Post

Tech or Treat!

Submit an article about your scariest tech experience—and the solution—and you’ll be automatically entered to win one of 4 fantastic tech gadgets.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Because your company can’t afford for you to make SEO mistakes, you’ll want to ensure you’re taking the right steps each and every time you post a new piece of content. This list of optimization do’s and don’ts can help you become an SEO wizard.
Does your audience prefer people in photos or no people? How can you best highlight what you’re selling? What are your competitors doing, and what can you do that is different and unique from them?  Continue reading to learn how to make your images …
The viewer will learn how to look for a specific file type in a local or remote server directory using PHP.
Learn how to create flexible layouts using relative units in CSS.  New relative units added in CSS3 include vw(viewports width), vh(viewports height), vmin(minimum of viewports height and width), and vmax (maximum of viewports height and width).
Suggested Courses

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question