[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now

x
?
Solved

Exploring mapped network drives is way too slow

Posted on 2002-06-07
12
Medium Priority
?
757 Views
Last Modified: 2007-11-27
I have a network with about twenty-five nodes.  All the machines are Windows 98 boxes except two which have Windows 2000. When exploring network drives on the two Windows 2000 boxes, windows explorer stops responding for a couple of minuets and then begins responding agian until another file or directory is accessed then explorer stops responding again for a few minutes.  This makes for very slow browsing and is very annoying.  Does anyone know if this is a Windows 2000 problem or network.  Oh, by the way the network is NT4, BackOffice Server.  This doesn't occur on the 98 boxes.  Any Ideas?
0
Comment
Question by:lrfish
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
  • 3
  • +1
12 Comments
 
LVL 8

Expert Comment

by:steinmto
ID: 7063898
Try disabling the computer browser service on the windows 2000 computers.  This can be done in start->control panel->administrative tools->services.
Go to the computer browser service and open it.  Change the startup type to disabled and reboot.

Also can you go to a command prompt on the windows 2000 computers and type "browstat status" and post the results.

Thanks,
Tom
0
 
LVL 7

Expert Comment

by:jatcan
ID: 7064740
Delete this following key:

Hive: HKEY_LOCAL_MACHINE
Key: Software\Microsoft\Windows\CurrentVersion\Explorer
\RemoteComputer\NameSpace
SubKey: {D6277990-4C6A-11CF-8D87-00AA0060F5BF}

Right-click the subkey {D6277990-4C6A-11CF-8D87-00AA0060F5BF} and click delete. (Do this on ALL Win2k and WinXP machines on the network - or you won't notice any increase in speed.)

You may wish to save this key before deleting it..this will speed up your network browsing by about oh I don't know 100% or so..and if you don't have huge amounts of files you may want to turn off indexing, I set my to manual with NO noticeable performance loss

click start button\run\type in "services.msc", locate indexing service, dblclick it, stop the service and use drop down menu to set it to manual. Reboot after all this.

Cheers.
0
 
LVL 7

Expert Comment

by:jatcan
ID: 7064743
If you disable the computer browser service then you won't be ABLE to browse the network through Network Places, only by direct command  IE:

\\server\share

Cheers.
0
Ask an Anonymous Question!

Don't feel intimidated by what you don't know. Ask your question anonymously. It's easy! Learn more and upgrade.

 
LVL 8

Expert Comment

by:steinmto
ID: 7064767
If you diable the browser service on the windows 2000 computers the will still be able to browse the network because another computer will hold the browse list.  
0
 
LVL 7

Expert Comment

by:jatcan
ID: 7066630
OH, I couldn't browse my network when I dsabled the computer browser service...? When I re-enabled it I could browse the network...must've been some type of glitch I guess...I got win2kserver and four workstations(two win2kPro and two win98se), small I know, but a complete network all the same.
0
 
LVL 8

Expert Comment

by:steinmto
ID: 7066759
I disabled it on a network with one 40 nt workstations and two 2000 servers.  They were having browsing problems and I ended up calling microsoft and they told me to disable the computer browser service on all of the workstations.

Tom
0
 
LVL 7

Expert Comment

by:jatcan
ID: 7066899
Coolio..I'll remember that one...
0
 

Author Comment

by:lrfish
ID: 7066908
I've done all your ideas and it is still not working correctly.
0
 

Accepted Solution

by:
sl0w earned 300 total points
ID: 7069899
Windows 2000 has terrible performance on networks without local DNS servers.  I'm betting that in a mostly win98 network you don't have one.  Setup your domain controller or any member server with DNS (only a forward lookup zone is necessary) and then you will see your browse times go down.  The reason your Win98 boxes don't see the lag is because they use Netbios for resolution.  
0
 
LVL 7

Expert Comment

by:jatcan
ID: 7070088
Which SPak on the NT4 server?
0
 

Author Comment

by:lrfish
ID: 7072815
SP4
0
 

Author Comment

by:lrfish
ID: 7072836
It's still not working right but, Sl0W, I think you got me headed in the right direction.
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
Working from home is a dream for many people who aren’t happy about getting up early, going to the office, and spending long hours at work. There are lots of benefits of remote work for employees.
In response to a need for security and privacy, and to continue fostering an environment members can turn to for support, solutions, and education, Experts Exchange has created anonymous question capabilities. This new feature is available to our Pr…
We’ve all felt that sense of false security before—locking down external access to a database or component and feeling like we’ve done all we need to do to secure company data. But that feeling is fleeting. Attacks these days can happen in many w…

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question