skybox

Hi!
I want to use a skybox in a d3d based application, but i can't disable the clipping... so i have to use a small skybox, and the
result is quite ugly: the user can really see that the sky is a box!!!
please help!!!
(i'm using dx8)
ralph78Asked:
Who is Participating?
 
fl0ydConnect With a Mentor Commented:
Could you give a bit more information on how the skybox appears to the user. I'm not sure how to take your "the user can really see that the sky is a box".

Nevertheless, have you considered using a skydome instead -- it certainly doesn't exhibit those sharp edges like the box does.

regards,
.f
0
 
ralph78Author Commented:
well, the skybox is nice, but to be rendered properly, i should scale it with a great value (it should be an infinite). but if i do so, the box isn't rendered anymore cause of the default clipping. and i still don't know how to disable it.
thanks,
Ralph
0
 
fl0ydCommented:
There are two possibilities for you: Either you turn on/off clipping partially with a call to

IDirect3DDevice8::SetClipStatus

specifying particular planes or you turn off clipping altogether using

IDirect3DDevice8::SetRenderState( D3DRS_CLIPPING, FALSE );

Did that work for you? Hope you are progressing :)
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
ralph78Author Commented:
i already use
IDirect3DDevice8::SetRenderState( D3DRS_CLIPPING, FALSE );
but it still hide my box if it is to far away...
0
 
fl0ydCommented:
That's strange -- on my system the IDirect3DDevice8::SetRenderState( D3DRS_CLIPPING, FALSE ) works just as expected. Have you checked the return value using the SUCCEEDED/FAILED-macros to see whether it is really disabled? You can also use
DWORD dwRet = 0;
IDirect3DDevice8::GetRenderState( D3DRS_CLIPPING, &dwRet );
before drawing your skybox, to see if clipping might have been enabled at some other point in your application.
0
 
griesshCommented:
Dear ralph78

I think you forgot this question. I will ask Community Support to close it unless you finalize it within 7 days. You can always request to keep this question open. But remember, experts can only help you if you provide feedback to their questions.
Unless there is objection or further activity,  I will suggest to accept

     "fl0yd"

comment(s) as an answer.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!
======
Werner
0
 
MindphaserCommented:
Force accepted

** Mindphaser - Community Support Moderator **
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.