Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 351
  • Last Modified:

VPN client getting through Mandrake SNF

Hi,

I’m running a Linux Mandrake Firewall (SNF).
Could someone help me out getting a VPN client through that firewall?
The installation is standard, only thing I configured on the firewall is the Web proxy, the log generators and giving machines access.

I know the Firewall uses NAT. And that’s why the VPN clients don’t get through.
But I know that you could do it by updating the IPchains to version the latest version.
All other internet protocols are no problem, they are using the proxy.

Let me know if you need more info.

You help is much appreciated
cheerio
0
TokeMUp
Asked:
TokeMUp
1 Solution
 
ahoffmannCommented:
Could you please provide more detailed information about your VPN client:
  - is it on firewall host itself
  - if not, is it a NATted IP
  - which VPN client is it
  - does it use IPsec
  - which other ports (than 50) are necessary
0
 
TokeMUpAuthor Commented:
ahoffmann,

- VPN is used on a client PC (Windows 2000)
- It's using NAT, as far as I know.
- VPN client is Contivity from Nortel.
- It's using IPsec
- Ports: 500 550 I think

Also I've read that I need to upgrade IPchains to version 1.3.10.

Also thats not working out. They made it very user frindly NO RPM. Jest a bunch of files.

Thanks for your help
0
 
ahoffmannCommented:
try if you can switch to iptables (instead of ipchains).

Anyway the rules should look like:

ipchains -A forward -p 50  -d client-ip -j ACCEPT
ipchains -A forward -p 51  -d client-ip -j ACCEPT
ipchains -A forward -p udp -d client-ip --dport 500 -j ACCEPT

rest should be done by your NAT rule.
If something fails, use tcpdump to see which packets want to cross your firewall.
0
 
m4rcCommented:
what version of SNF are you using?  I am using 7.2, and i can make outgoing VPN connections using checkpoint's SecureClient vpn.

SNF uses bastille linux to create its firewall scripts.  much of this can be tweaked in /etc/bastille-firewall.conf .  the config file is well documented with comments.  you'll prolly need to play w/ the lines like
UDP_PUBLIC_SERVICES=

to allow connections out/in.  i think the best way to troubleshoot it is to make sure you are logging all dropped packets, and just tail -f /var/log/messages, and try the vpn.  see which packets are blocked, then allow them and repeat until it all works.

also, i have a network SNF didnt expect, ie, i have my own internal dns server, so i couldnt tweak the bastille rules to do everything i wanted.  i ended up using ipchains-save to save my current rules to a file, edit them by hand, and use these lines in my rc.local to start the fw

echo "rc.local: activating custom firewall rules in /root/current_ipchains_rules"
if [ -f /root/current_ipchains_rules ];then
        /sbin/ipchains-restore < /root/current_ipchains_rules
        echo "rc.local: ipchains restore done."
fi

0
 
CleanupPingCommented:
TokeMUp:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now