Solved

ipchains help

Posted on 2002-06-12
3
299 Views
Last Modified: 2013-12-16
I recently configured sendmail and qpopper(pop3 server) on my Red Hat 7.2 machine.  Both those services seem to work correctly.  I only have trouble when I try to send email from that machine with the firewall up.  Receiving mail with the firewall up works fine though.  When the firewall is down though, both work correctly.  It is an ipchains firewall.

I would like to temporarily allow all traffic through the affected ports.  I have tried to do this using the following rules, but I have not succeeded.  Like I said, sending email while the firewall is up is not working.

As far a I know, this should allow the traffic that I need to go through.  Is there something I am missing that is not letting my attempts to send email from this box go through??

If these rules are correct, then there must be some other rule blocking my outgoing email traffic.  If that is the case, I don't know where to start in order to find the rule that is blocking my outbound email.  Any help would be greatly appreciated.(I'm pulling my hair out on this one!)  Thanks.


#PORT 53
ipchains -A output -s 0/0    -d 0/0 53 -p tcp -j ACCEPT
ipchains -A input  -s 0/0 53 -d 0/0    -p tcp -j ACCEPT
ipchains -A input  -s 0/0 53 -d 0/0    -p udp -j ACCEPT
ipchains -A output -s 0/0    -d 0/0 53 -p udp -j ACCEPT

#PORT 110
ipchains -A output -s 0/0 110 -d 0/0     -p tcp -j ACCEPT
ipchains -A input  -s 0/0     -d 0/0 110 -p tcp -j ACCEPT

#PORT 25
ipchains -A output -s 0/0 25 -d 0/0    -p tcp -j ACCEPT
ipchains -A input  -s 0/0    -d 0/0 25 -p tcp -j ACCEPT
0
Comment
Question by:barthalamu
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 2

Expert Comment

by:wqclatre
ID: 7072425
try to add
ipchains -A input -p tcp ! -y -s 0/0 25 1024:65535 -j ACCEPT

to allow reply from the reciving mailservers.
0
 
LVL 2

Accepted Solution

by:
wqclatre earned 250 total points
ID: 7072426
sorry missed one thing.

ipchains -A input -p tcp ! -y -s 0/0 25  -d ip_of_mailserver 1024:65535 -j ACCEPT

should it be.

0
 

Author Comment

by:barthalamu
ID: 7073478
Well, that didn't work...but it got me going on the right track.  I ended up making both of my SMPT bidirectional, (with the -b parameter) and that worked.  Thanks a lot for your help.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

rdate is a Linux command and the network time protocol for immediate date and time setup from another machine. The clocks are synchronized by entering rdate with the -s switch (command without switch just checks the time but does not set anything). …
I am a long time windows user and for me it is normal to have spaces in directory and file names. Changing to Linux I found myself frustrated when I moved my windows data over to my new Linux computer. The problem occurs when at the command line.…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Suggested Courses

632 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question