Solved

Just-In-Time Debugging under WindowsXP

Posted on 2002-06-12
10
310 Views
Last Modified: 2010-04-02
Hi,

I have a problem with the Microsoft IDE under Windows XP. The just-in-time Debugging works nicely under older OSes, like 98. Under XP it offers me the possibility to debug, even fires up the debugger, but then forces me to close my app.

Details:
- First I get the message that something bad happened, "ok" to close, "cancel" to debug. I select cancel, the debugger starts (but with the thread still running). Another message appears, saying the same as before, but this time it offers only to close the program.
- Yes, JIT-Debugging is enabled in the IDE's options...
- The current user is the admin.

Any suggestions?
0
Comment
Question by:ThomasHolz
  • 3
  • 3
  • 2
  • +2
10 Comments
 
LVL 86

Expert Comment

by:jkr
ID: 7073792
Does this also happen when you place an EXCEPTION_BREAKPOINT in your code, e.g.

__asm { int 3};

?
0
 

Author Comment

by:ThomasHolz
ID: 7073938
Good idea. Yes, if I use an int 3 exactly the same happens. No debugging possible. Perhaps it has something to do with XP? Do I have to enable JIT somewhere in the OS???
0
 
LVL 86

Expert Comment

by:jkr
ID: 7074101
Hmm - I know that this works in W2k...

What kind of application are we talking about?
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 

Author Comment

by:ThomasHolz
ID: 7074731
It's just a normal MFC app I develop...
0
 
LVL 3

Expert Comment

by:Crius
ID: 7075882
This is a known problem, I have it, and I know several others have had it. There was quite a thread going on about this in the newsgroups not so long ago.

The last post mentioned a possible fix, though I haven't tested it myself. I'll give it a go tonight and let you know if you don't respond.. The post is quoted as follows:

"Ctrl+F5 means you're not running under debugger. Does it work when you do F5? If yes, then I suspect what happens is that the breakpoint exception (which is raised when you press Cancel) is handled by XP error reporting system. You have to disable it (I think it's somewhere in My Computer properties). May be just setting the Auto value under HKLM\Software\MS\ WinNT\CurrentVersion\AEDebug key to 0 will be enough, though I'm not sure if it's still used in XP and how it's related to error reporting."

Anyway, I hope it helps you, and turns out to be alright. As far as I've heard, there is no solution that has been reported to work, but then, maybe the silence and discontinued request for help after that post indicates success...
0
 

Author Comment

by:ThomasHolz
ID: 7077516
Hi Crius,

I didn't find any options there that helped... The Auto value in the registry is already set to 0...
0
 
LVL 3

Expert Comment

by:Crius
ID: 7078525
This is unfortunate. I will keep a watch out for people who discover how to get around this XP problem, though my searches thus far are mostly fruitless.

At least this seems to be a common problem...
0
 
LVL 11

Expert Comment

by:griessh
ID: 7262270
Dear ThomasHolz

I think you forgot this question. I will ask Community Support to close it unless you finalize it within 7 days. You can always request to keep this question open. But remember, experts can only help you if you provide feedback to their questions.
Unless there is objection or further activity,  I will suggest to

     "refund the points and PAQ at 0 points"

since nobody had a satisfying answer for you.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!
======
Werner
0
 
LVL 3

Expert Comment

by:Crius
ID: 7262305
Yeah, I've been watching the newsgroups, and there's more and more people having problems with XP and debugging as more and more people switch to it. No one has a solution yet, except give feedback to Microsoft.

It looks like a lot of different debugging issues have come up too, that only have problems on XP.

It's looking to me like XP is a bad move for developers to make at the moment.

Good luck, I suggest use F5 (debug) for now, and forget about the JIT debugger.
0
 
LVL 6

Accepted Solution

by:
Mindphaser earned 0 total points
ID: 7332932
Points refunded and moved to PAQ

** Mindphaser - Community Support Moderator **
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

  Included as part of the C++ Standard Template Library (STL) is a collection of generic containers. Each of these containers serves a different purpose and has different pros and cons. It is often difficult to decide which container to use and …
IntroductionThis article is the second in a three part article series on the Visual Studio 2008 Debugger.  It provides tips in setting and using breakpoints. If not familiar with this debugger, you can find a basic introduction in the EE article loc…
The viewer will learn how to user default arguments when defining functions. This method of defining functions will be contrasted with the non-default-argument of defining functions.
The viewer will be introduced to the technique of using vectors in C++. The video will cover how to define a vector, store values in the vector and retrieve data from the values stored in the vector.

829 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question