• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 292
  • Last Modified:

Unable to connect thru telnet

                   netstat -na | grep :23 does not give any output.
                    That means my xinetd is not listening ?
                    How do I make it listen ?

                    I have installed telnet
                    And my /etc/xinetd.d/telnet file looks like

                    service telnet
                    {
                           flags           = REUSE
                           socket_type     = stream
                           wait            = no
                           user            = root
                           server          = /usr/sbin/in.telnetd
                           log_on_failure  += USERID
                           disable         = no
                    }

Also note,  ps -ef | grep xinetd  gives nothing.
Does it mean xinet is not running ?
I did do xinet restart and it says xinetd started succesfully.
0
chazhs
Asked:
chazhs
1 Solution
 
MFCRichCommented:
Can you telnet to the machine from itself?

>> telnet localhost

If you can then it may be that you have some firewall rules in place on the machine (or its gateway). It could also be that you have some access restrictions in '/etc/xinet.conf'
0
 
chazhsAuthor Commented:
telnet localhost also  gives connection refused error. (same error as above)
0
 
cincin77Commented:
have you installed telnet server which is not installed by default?
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

 
chazhsAuthor Commented:
Yes, I did. rpm -q telnet-server says telnet installed.Thanks!
0
 
cincin77Commented:
the script that deals with xinetd should be under /etc/init.d

go to that directory and issue;
./xinetd status
if it says that it does not work, issue
./xinetd start

hope this helps...
0
 
bryanjonesCommented:
The reason for unable to telnet - is that telnet is turned off - what you need to do is to run the following command /sbin/chkconfig telnet on - this will turn on telnet - to see what else you want on or off you run /sbin/chkconfig --list this will show all the run levels and what is turned on/off per run level.
0
 
chazhsAuthor Commented:
Thankyou Sir! That was the problem.
Telnet was off.
Turned it on now, and everything looks great :)
Thanks for yours and everyones help!!!
0
 
chazhsAuthor Commented:
Thankyou Sir! That was the problem.
Telnet was off.
Turned it on now, and everything looks great :)
Thanks for yours and everyones help!!!
0
 
chazhsAuthor Commented:
Thankyou Sir! That was the problem.
Telnet was off.
Turned it on now, and everything looks great :)
Thanks for yours and everyones help!!!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now