Solved

samba &  windows 2000 server

Posted on 2002-06-13
9
199 Views
Last Modified: 2013-12-16
I have a net work with a domain using win 2000 server
I have installed samba in another machine and configured it, I can see the linux machine from the server but :
- I can not open it...
- can I browes the other windows machines from the linux mashine and HOW....???



0
Comment
Question by:mombino
9 Comments
 

Expert Comment

by:indyna
ID: 7075411
first I don't know your samba configure.
maybe u can post your configure or mail me (smb.conf)

anywhere use samba server must to add samba users
my way like this to add samba users:

1./usr/sbin/adduser test          (add linux user)
2./usr/bin/smbadduser  test:test  (samba user)
3./usr/bin/smbpasswd -a test      (set your password)

in smb.conf confiure:

[global]
   workgroup = Group
   netbios name = samba_server
   server string = samba Server %v
   log file = /var/log/samba/%m-%I-%a.log
   hosts allow = 192.168.0.0/255.255.255.0
   max log size = 1000
   encrypt passwords = yes
   local master = yes
   os level = 33
   domain master = yes
   preferred master = yes
#  wins support = yes
   client code page = 950
   security = user
   guest account = wa
   shared mem size = 2048576
#  domain logons = yes
#  logon script = %m.bat
#======= Share Definitions =================
[samba_root]
   comment = root Directories
   path = /samba
   valid users = test
   guest ok = yes    
   writable = yes
   share modes = yes
   create mode = 0775
   directory mode = 0775

[test]
   comment = test Directories
   path = /samba/test
   writable = no
   guest ok = yes
   public = yes
   share modes = yes
========================================

if samba directories was in /samba

u must to change /samba  mod and woner.
like thost command :

chmod -R 755 /samba
chown -R test:test /samba

ok ~ to restart your samba server . u must see samba server
and working well .

 



0
 

Author Comment

by:mombino
ID: 7075539
Indyna

although I donot think that there is somthing wrong with my configration...but I Past copy the configratin you send.

actually I get the message (can not find path) when I try to open my linux machin in windows.
and I get the message access deenied always when I tried to open windows machin from linux machien....that's the whole thing.....what do you think
0
 

Expert Comment

by:indyna
ID: 7076046
sorry My post smb.conf have one error .

guest account = wa  <--- set samba guest users
guest account = test

well windows2000 or 98 login name must be "test"  
or other u set users.
login name must on list of samba users .

and what's version that u use ?
samba 2.2.4 is nice for use , faster than win2000.


0
 

Expert Comment

by:indyna
ID: 7076054
and set your ip address range .

hosts allow = 192.168.0.0/255.255.255.0  <--this line

0
Free Gift Card with Acronis Backup Purchase!

Backup any data in any location: local and remote systems, physical and virtual servers, private and public clouds, Macs and PCs, tablets and mobile devices, & more! For limited time only, buy any Acronis backup products and get a FREE Amazon/Best Buy gift card worth up to $200!

 

Author Comment

by:mombino
ID: 7080436
don't I have to jion the domain some how...???
0
 

Expert Comment

by:indyna
ID: 7080612
in this case , u don't need to joion domain.
just use right login name to into samba server.
0
 

Expert Comment

by:fost0127
ID: 7144586
My 2 cents...
     I had what sounds like the same problem.  The problem is actually with the Win2k Server.  When you 'promoted' it as the PDC you had to relax the authentication for pre-windows 2000 server-trusts.  Otherwise there will be problems authenticating between the two boxes resulting in path not found.  The domain or workgroup would also show up as unknown for the linux box when viewed from the win2k box.
0
 

Expert Comment

by:odewitt
ID: 7232914
Did you enable these in the registry.

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MRxSmb\Parameters]
"EnablePlainTextPassword"=dword:00000001

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanworkstation\parameters]
"enableplaintextpassword"=dword:00000001
0
 

Accepted Solution

by:
SpideyMod earned 0 total points
ID: 8276369
All,
I am unlocking this question in preparation for cleanup.  I will return in 7 days to finalize this question.  Please leave any recommendations for the final state of this question, I will take all recommendations into consideration.  Failing any feedback, I may decide in 7 days to delete or PAQ this question with no refund.  Thanks.

SpideyMod
Community Support Moderator @Experts Exchange
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

SSH (Secure Shell) - Tips and Tricks As you all know SSH(Secure Shell) is a network protocol, which we use to access/transfer files securely between two networked devices. SSH was actually designed as a replacement for insecure protocols that sen…
Linux users are sometimes dumbfounded by the severe lack of documentation on a topic. Sometimes, the documentation is copious, but other times, you end up with some obscure "it varies depending on your distribution" over and over when searching for …
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now