Solved

installing ftp server on linux

Posted on 2002-06-14
12
434 Views
Last Modified: 2013-12-16
how do i install ftp server on linux
i tried installing wu-ftpd***.rpm on linux using the command
rpm -ivh wu-ftpd***.rpm
and modified the file /etc/xinetd.d/wu-ftpd  and restarted the xinetd serviceusing the following command
/etc/rc.d/init.d/xinetd restart to enable the service
but i am still unable to log in to the server from a remote client

Kindly help
0
Comment
Question by:kamal3965
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 5
12 Comments
 

Author Comment

by:kamal3965
ID: 7077660
will be thankful for a prompt reply
0
 
LVL 1

Expert Comment

by:BigJoe1008
ID: 7078267
type in:
netstat -a

Look for a reference to :ftp or :21 in the list. On the other side of the : it will show what it will allow for connections if it is 0.0.0.0 the service is setup correctly and you would want to look at either your user accounts that you are trying to access it with or you would need to check if there is a firewall blocking port 21.

--Joe
0
 

Author Comment

by:kamal3965
ID: 7080060
did as per ur suggestion
did not find 0.0.0.0 on the other side of :ftp.
kindly let us know what has to be done to get 0.0.0.0
0
Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

 
LVL 1

Expert Comment

by:BigJoe1008
ID: 7080154
what does your /etc/xinetd.d/wu-ftp and your /etc/ftpaccess files look like?
0
 
LVL 1

Expert Comment

by:BigJoe1008
ID: 7080155
if it looks like *:ftp it will work also.

0
 
LVL 7

Expert Comment

by:waynezhu
ID: 7080166
I experienced similar thing as you've described during
my recent RedHat 7.3 installation. After install and re-install serveral times without make FTP working, [to make myself life easy], finally I went to the SERVER type installation (previously WORKSTATION or CUSTOM type
installation) with no firewall option [Be noted also I made anonymous FTP server checkbox checked.]

After the software installed, vi-ed the telnet and wu-ftpd files to make the DISABLE=no, and restarted the
/etc/rc.d/init.d/xinetd. Finnally it worked.

Anyway, good luck.
0
 
LVL 1

Expert Comment

by:BigJoe1008
ID: 7080175
Yeah, I should have remembered that because you have ipchains on by default up through 7.3 you either have to shut off the rules or set all high level ports to allow access back.  Because it connects initially on port 21 then it jumps to a high level port.  With IPTables there is a fix to help with FTP bouncing around.  

So what you can do is shut down the ipchains rules by running:
service ipchains stop

Then try and connect.
0
 

Author Comment

by:kamal3965
ID: 7081173
yeah, i did a custom install,and i think(i will check it out)the ipchains service is enabled. I will disable the ipchains service and check ftp service

thanks BigJoe1008 and waynezhu for ur suggestions

kamal
0
 

Author Comment

by:kamal3965
ID: 7081174
yeah, i did a custom install,and i think(i will check it out)the ipchains service is enabled. I will disable the ipchains service and check ftp service

thanks BigJoe1008 and waynezhu for ur suggestions

kamal
0
 

Author Comment

by:kamal3965
ID: 7083325
Thanks BigJoe1008, disabled ipchains as suggested and restarted xinetd service

ftp is working perfectly

thanks

kamal
0
 
LVL 1

Expert Comment

by:BigJoe1008
ID: 7083731
I am going to reword that to an answer.
0
 
LVL 1

Accepted Solution

by:
BigJoe1008 earned 100 total points
ID: 7083743
After running:

netstat -a

you see ftp you will need to run:

service ipchains stop

You should upgrade to iptables because it has support for ftp.  Because FTP is a monster, you create the connetion to port 21 then it throughs the entire connection to another port.  Otherwise on ipchains you will need to open all high level ports (1024-65k).

--Joe
0

Featured Post

NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Apache module 5 86
SSH setup on ASA 5505 17 121
Linux recover lost file deleted by mv 1 31
cmake and message 1 21
Little introduction about CP: CP is a command on linux that use to copy files and folder from one location to another location. Example usage of CP as follow: cp /myfoder /pathto/destination/folder/ cp abc.tar.gz /pathto/destination/folder/ab…
Fine Tune your automatic Updates for Ubuntu / Debian
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:

732 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question