Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 248
  • Last Modified:

SAMBA and Win2k revisited

I'm having issues with SAMBA on a RedHat 7.2 and my win 2k machine.  I have the shares setup so that browsing works from the 2k machine, and I can read and copy everything from the SAMBA share to the windows box.  But when I copy a file from the wndows machine to the share I get this error on the windows box:

Sharing violation. File may be in use.

Or something like that.  I made that sure I'm not using the file on the windows machine and I can copy the file elswhere.  Also I checked the conf file for SAMBA and I made sure that read only is no, etc . . .  
0
spcmnspff
Asked:
spcmnspff
1 Solution
 
spcmnspffAuthor Commented:
Oops! Double Post please ignore . . .
0
 
81ncpappyCommented:
This may be overly simplified but have you checked the UNIX permissions on the directory from which you are sharing via SAMBA?  What I mean is to check the permissions from the UNIX perspective (not the Windows perspective).  I have had that error message come up on Windows when my UNIX permissions didn't allow access to anyone, much less SAMBA.

Hope this helps.

Nick
0
 
81ncpappyCommented:
In addition, it seems that the directories which are shared via SAMBA have the read and execute bits set on the UNIX end...  In other words.

chmod -R 555 /dir/shared/via/samba

or whatever your directory is called...

:-)
0
Build your data science skills into a career

Are you ready to take your data science career to the next step, or break into data science? With Springboard’s Data Science Career Track, you’ll master data science topics, have personalized career guidance, weekly calls with a data science expert, and a job guarantee.

 
spcmnspffAuthor Commented:
The only way I seem to get SAMBA working is to
chmod 777 /home/shared in samba.conf, I set up share mode access and I allow a guest user to read and write to the share.  Basically a wide open share.  This isn't a big deal on my home lan behind an ipchains firewall.  But still, I would like to be able to learn how to make things more secure. I've tried user mode with mappings from windows users to unix users and domain mode pointing to my NT4 PDC while adding the SAMBA pc to my domain.  Nothing has worked.  I even tried switching encryption on and off in SAMBA to no avail.  It seems that SAMBA authentication issues can be really frustrating.

0
 
81ncpappyCommented:
I suppose I would have to see your smb.conf file to give more feedback.  

Nick
0
 
spcmnspffAuthor Commented:
Thanks, I'm not home at the moment. I'll send it to you tonight.
0
 
ReliframCommented:
I don't know if this question was ever answered for spcmnsspff, however I was having similar problems. I was working with mp3's, and quite often when I tried to copy or rename (from my w2k box) a file/directory on the samba share I would get sharing violations.

Tthe fix: Turn off "enable web content in folders" in the Tools/Folder Options menu. My best guess is that windows was trying to load some portion of the file in the background to display a thumbnail of it and thus I was getting the sharing violations.

0
 
CleanupPingCommented:
spcmnspff:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0
 
drewberCommented:
This question has been classified abandoned. I will make a recommendation to the moderators on its resolution in a week or two. I appreciate any comments that would help me to make a recommendation.
 

Unless it is clear to me that the question has been answered I will recommend delete. It is possible that a Grade less than A will be given if no expert makes a case for an A grade. It is assumed that any participant not responding to this request is no longer interested in its final disposition.

 
If the user does not know how to close the question, the options are here:
http://www.experts-exchange.com/help/closing.jsp
 
drewber
0
 
paullamhkgCommented:
No comment has been added lately, so it's time to clean up this TA.
I will leave the following recommendation for this question in the Cleanup topic area:

PAQ - no points refunded

Please leave any comments here within the next four days.
PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

paullamhkg
EE Cleanup Volunteer
0
 
Computer101Commented:
PAQed - no points refunded (of 100)

Computer101
E-E Admin
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now