Solved

Stimon.Exe/Twain probs for Photoshop 5.5 ,6 & 7

Posted on 2002-06-17
4
867 Views
Last Modified: 2013-12-11
Maybe you can help me...
the following is the duscussion of my problem and things i have done to fix it...
at the bottom is the TWAIN error log that appears in my temp dir along with 1-3 .mtx files...
PLEASE i hope you can help...no one else can!
------------------------------------------------------------------------------
Hi...ever since installation of a new scanner (CanoScan N650u with twain drivers) ALL of my PS [rograms
freeze on intializing...PS7 even yeilds a twain re-install recommendation error.
Please reply if you have hyad this problem or have an idea..
But do know that i have
1. deleted and re-installed PS with and without the scanner and drivers...(using registry crawler to
clean out any traces0
2. have re- named all the twin twinker files.
Have re-installed Windows OS OVER the old version.
3. have spoken to Canoscan tech support ot make certain I have no remaining dlls or anything...
4. have scoured Adobe for twain/thunker window problems and they only refer to probs IMPORTING images
into PS
from a twin scanner (I assume PS can initialize for this).
5. I have removed all prOGRAMS associated with the scanner (omnipro and photoscan) both of which work
FINE with the scanned images...although PS was an option to import scanned stuff into it never worked..It
froze.
Last bit of info I have is each time I try to run PS
4 files are thrown into the Win temp dir.. 3 .mtx twain files and a twain log that basically says it
cann't find the twunker window??!!
I had a TWAIN_32 folder in Windows that only have one version of the twain driver...did i mention that
I tried the latest canon driver als well...? and the Canoscan exe
stuff.
I tried to install the latest Driver from canon with no change either...
That folder is now deleted, (It was recommended by canon) as it will recreate when another twain scnner
or camera is installed.
I don't know what else to do aside from re-installing to another os ALTOGETHER or putting PS on another
'pter altogether...oh, yeah I don't HAVE another computer...:0D.
I am using Me right now...and tho it has a bad rep I don't mind it. I don't want to have to burn 20
gb of info to disc so i can reinstall the os.
O yeah, one last thing... ALL versions of PS: 5.5-7 worked FINE before the scanner was installed...and
there have been no other software installations or hardware installed that it could be.
The scanner NEVR had a problem functioning except if I chose Photoshop to import the image..which then
froze.
Help!!
INeed Photoshop!!!
Michele

followup:
well, guys..I sooooo appreciate the help...
I have tried everything mentioned including re-installing PS wothout any trace of TWAIn or the Scanner
software.
(including image programs installed with it).
I also did dare :-) to clean the registry of any and everything scanner, twain, twunk AND photoshop
related rebooted and re-installed everything.
As far as Quarterdeck Clean sweep...I do run Norton clean sweep and have read that rec. on the Adobe
site, so I disabled that too as a test: No change.
The error log that gets thrown into the temp dir (along with 2 0r 3 .mtx files) reads as follows:

TWAIN_32.DLL - MESSAGE - CTwunk ::AppInitialize - Reset Log

TWAIN_32.DLL - MESSAGE - CTwunk ::OpenServer - Starting Thunker

TWAIN_32.DLL - MESSAGE - CTwunk ::CloseServer - Why Can't We Find The Thunker Window?

TWAIN_32.DLL - MESSAGE - DSM --DsmEntryDiagExit (RC = 0, CC = 0)

TWAIN_32.DLL - MESSAGE - CTWTRACE--Adobe Photoshop(49) to NULL:

TWAIN_32.DLL - MESSAGE - CTWTRACE--CONTROL, IDENTITY, GETFIRST


the only thing i ahve not tried...is the re-insatll of PF only the EXE files as Caligula's Adobe rec
states.
It seems whether the scanner is on or not PS is messed up now.
I spoke to Canon tech support who referred me BACK to ADOBE...??!!
So, I'm still trying.
I also have noticed that STIMON.EXE is (not responding) as well when PS freezes during initializing...so
I KNOW the prob has something to do with the scanner...
even tho it's off!
Michele

TWAIN files in C:\WINDOWS
TWAIN.dll  version 1.7.0.0
TWAIN_32.dll  version 1.7.1.0
TWAIN_G.ini  no version
TWUNK_16.EXE  version 1.7.0.0
TWUNK_32.EXE  version 1.7.0.0
0
Comment
Question by:scuba22
  • 2
4 Comments
 
LVL 59

Accepted Solution

by:
LeeTutor earned 50 total points
ID: 7084747
If it was fairly recent, then the next thing to try is restore a previous good registry (Windows ME keeps 5 previous backups of the registry, like Window 98): boot to DOS mode, type in the command scanreg /restore and choose a date prior to the problem happening.  The command scanreg /fix might also work in this case.  And if that doesn't work, then you can try the new feature of Win ME, System Restore, which will restore previous versions of important system files: go to Start, Programs, Accessories, System Tools, System Restore. You will be given the option of create a new Restore point, or Restore my computer to an earlier time. Choose the second option, you will be presented with a calendar, from which you need to choose an earlier date.  Note that this System Restore will not uninstall programs; it will only restore earlier versions of system files.
0
 
LVL 7

Expert Comment

by:WiZaRd
ID: 7084859
http://www.adobe.com/support/techdocs/342a.htm

some troubleshooting from adobe (you've probably tried some or most of this but take a look anyway)

0
 

Author Comment

by:scuba22
ID: 7084875
i fixed the prob by deselecting stimon.exe from the msconfig startup menu..i can now run Phooshop but it still freezes at times and i haven't tried to re-install the scanner....
M
I will try to restore but i have had that shut off..when i tried restore for the system it was n't available to a point before all this!
0
 
LVL 7

Expert Comment

by:WiZaRd
ID: 7084917
http://support.microsoft.com/default.aspx?scid=KB;EN-US;q257815
from above link:
"Still Image Monitor (Stimon.exe) is a program that is installed by Windows Millennium Edition (Me) and Windows 98 when a Universal Serial Bus (USB) scanning device is successfully enumerated. "

http://support.microsoft.com/default.aspx?scid=KB;EN-US;q306393

above link how to re-install stimon.exe

may or may not fix the problem but worth a try.



0

Featured Post

What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
In this article, I will show you HOW TO: Install VMware Tools for Windows on a VMware Windows virtual machine on a VMware vSphere Hypervisor 6.5 (ESXi 6.5) Host Server, using the VMware Host Client. The virtual machine has Windows Server 2016 instal…
This Micro Tutorial will give you a basic overview of Windows DVD Burner through its features and interface. This will be demonstrated using Windows 7 operating system.
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now