• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 365
  • Last Modified:

FTP only transfers about 8K

RH7.3 / Minimal install - I can only ftp files that are small, ie. <8K. This is from and to the linux box.
0
victorus
Asked:
victorus
  • 7
  • 4
1 Solution
 
victorusAuthor Commented:
FTP stalls at about 8K and does not do anything. HASH gets to about 8 #'s. Where do I start?
0
 
victorusAuthor Commented:
More Info....

When logged into this box I can FTP send to another without a problem. I cannot receive on this box from another and I can not send to this box from another.
0
 
ZookCommented:
Hi,

what is your connection between the two machines? LAN? Modem? ...?

What ftpd are you using? (check /etc/inetd)

Are you using anonymous or user login?

0
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

 
victorusAuthor Commented:
Hi Zook,

Connection is LAN. DNS is hosted by ISP. Connection to Internet is basically a hub connected to DSL. I am using standard FTP client on Linux and wu-ftpd when I try to FTP to the linux box. I am using a user login that has full access when trying to FTP to the box and root login when using FTP client to pick up from other machines.

The wu-ftpd is actually started using the /etc/xinetd.d , the new version of inetd.

My other RH7.0 server works perfectly in this environment and I thought was set up identically!

Thanks,
Vic
0
 
ZookCommented:
What machine does the PPPoE, that is the connection to the DSL Modem?

Is the ftp target in your LAN our in the Internet (read: behind DSL)?

If so the problem might be a wrongly configured firewall on the other side.

As a workaround you have to lower the MTU of your client machine.

e.g. /sbin/ifconfig eth0 mtu 1400

more info for this problem on
http://sdb.suse.de/en/sdb/html/cg_pmtu2.html
0
 
victorusAuthor Commented:
There is no PPPoE. The hub is connected directly to the DSL IAD and there is only a very minimal firewall in the IAD. The IAD is connected to a T-1. The FTP is in the target LAN (ie. behind the IAD / DSL) There is no firewall between the machines that I am using FTP with and I disabled the firewall on the linux box due to other problems.

No change when setting MTU to 1400. eth0 network interface works fine when uploading to another machine. It is when downloading that it hangs. Also tried promisc option w/o change.

Checked out the www site listed but it applies to going through a firewall, where mine is all in-house LAN.

????
0
 
ZookCommented:
OK, you said there is a firewall in between!? The "IAD" is a firewall, isn't it? (minimal or not)

"classic" FTP requires that the server builds a 2nd connection back to the client, which is normally forbidden by any firewall.

Have you tried setting your FTP to "passive"?
Do you have any log output from the firewall?
Do other tcp protocols work, like ssh, telnet or whatever?

Are you also root for the target machine?

I am a bit confused about your usage of the word "LAN" as you said the connection is via DSL. Do you actually mean Intranet?

Let me reflect:
You have two inhouse LANs (call the your-LAN and target-LAN) which are connected via a leased DSL line. Routers are IADs on both sides. There is a firewall software on the IADs (is it active?).
You have another RH machine in your target-LAN and with this machine everything works!?
The target-machine is a linux box. You have root on all machines!?

Is that correct? Please clear up the question marks.

cu
Zook
0
 
victorusAuthor Commented:
My FTP is set to passive. I have no firewall between the two machines and no firewall enabled on the two machines. Telnet works but have not tried ssh. Httpd works fine. I am root on all of the machines. I have tried setting eth0 to promisc and MTU to 1400. And I can upload from this machine via FTP very well, just can't download! I tried setting to a different IP address.

We have only one LAN that connects about 7 computers and a few printers and a fax together in a small office. All of these devices are connected to the network hub / switch and communicate in-house through that hub. All other machines work fine in this environment.

To be connected to the Internet, we have a DSL line (coming from the IAD) into the hub. Of course the DSL is listed as our gateway and has it's own IP. All "outside" traffic comes through the DSL. I am not trying to FTP through the DSL. I just want to ftp from in-house machines to in-house machines to keep up web pages and files for downloading from the web.

I have a RH7.0 machine that works perfectly with FTP and WU-FTP. Last night I installed RH7.0 on the machine that I am having problems with and it too worked properly. It's just when I install RH7.3 that it does not work.

I am begenning to believe that there must be some hardware incompatibilty with RH7.3. (RH support will not touch it.) I think that I might have to try my RH7.3 on a newer machine to test this theory. But I really wanted to use these P2-133 machines that I have as small www servers. Can it be that these machines only have 32MB RAM? I have plenty of HD space and I am not loading the X-Windows interface.

I am also considering trying a different OS supplier like SuSe. Maybe they provide better support?

I don't think that there is an answer to this question, at least until I try some of my suggestions listed above. It seems that no one else has had this problem and all of the support paths that I have tried have come to a dead end.

This problem sounded simple but I don't think it is. So, if you can give me your insights and / or suggestions I would be glad to award you the points for sticking with me for so long.

Thanks for your help,
Vic
0
 
ZookCommented:
I think 32MB for Linux without X11 is fine!

As I assume you checked the /var/log/messages, the permissions of the concerning files/directories and the configuration of WU-FTPD many times I am afraid I don't have much of a clue!?

As telnet works, the connection seems ok!?

In your shoes I would now just return to try standard stuff:
- Are the network cables ok?
- Does maybe the autonegotition (speed) between the Hub/Switch and the network card fail? Fix the speed on either side!?
- Try another ftpd daemon!?
- Try scp ans/or sftp to see if it is a network or ftp problem.
- Google the net for know problems with the network card


... sorry, that's it from my side. I don't have any other idea for now...

... maybe someone else has!?

Good Luck
Zook
0
 
victorusAuthor Commented:
I will let this question stay up for a week or so if someone has any other ideas, but these points are for you. I will close out and give you the points in a few days.

Much thanks Zook,
Vic
0
 
victorusAuthor Commented:
The REAL correct answer has to be "throw up your hands and say 'I give up!'" Ok, Zook gave me lots of places to look and check out. Bottom line, it appears to be a wierd hardware / memory thing with RH7.3 on this particular box. Other versions and different OS's work fine!

Red Hat provided almost no support since it was not and installation problem.

Zook gave me the most to work with and so, Zook gets the points.

Thanks Zook,
Vic
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 7
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now