Solved

40GB drive formats to only 31GB?

Posted on 2002-06-20
9
1,104 Views
Last Modified: 2008-03-06
I recently got a new Samsung 40GB hard drive and installed it as a slave drive.

My BIOS correctly identified the make and model number of the drive, and can support hard drives up to 136GB according to the documentation.

However, when I partition and format the drive, all I get and up with is 31GB.  What's the deal here?

prompt> fdisk /dev/hdb

[ make single partition /dev/hdb1 using all available sectors ]

prompt> mke2fs /dev/hdb1
prompt> mount /dev/hdb1 /mnt/samsung
prompt> df
/dev/hdb1              31G  718M   29G   2% /mnt/samsung

[this is after moving some data to the drive]

I was expecting 40G (or at least closer to it) when I df'ed.  Is the 31G to be expected?

-Jim
0
Comment
Question by:truittj
  • 4
  • 2
  • 2
  • +1
9 Comments
 
LVL 51

Expert Comment

by:ahoffmann
Comment Utility
this is probably 'cause mke2fs used to much inodes by default.
You can check with
  sfdisk -s /dev/hdb1
and
  df -i /dev/hdb1

If you have too much inodes, make your filesystem like this:
   mke2fs -i 1024 /dev/hdb1
0
 
LVL 3

Expert Comment

by:DVB
Comment Utility
How big does the bios report your drive as? Some drives need special jumper settings to show full 40 GB.
0
 

Author Comment

by:truittj
Comment Utility
Here's what I see:

prompt# df -i /dev/hdb1
Filesystem        Inodes   IUsed   IFree IUse% Mounted on
/dev/hdb1        4128768   10168 4118600    0% /home

prompt# sfdisk -s /dev/hdb1
33021576

How do I know how many inodes are too many?  What is considered an acceptable block size or bytes/inode ratio?

-Jim
0
 

Author Comment

by:truittj
Comment Utility
Here's a it more info on the formatted drive:

prompt# tune2fs -l /dev/hdb1
tune2fs 1.18, 11-Nov-1999 for EXT2 FS 0.5b, 95/08/09
Filesystem volume name:   <none>
Last mounted on:          <not available>
Filesystem UUID:          dc5a4c99-6b68-4366-98de-6cfef71b171d
Filesystem magic number:  0xEF53
Filesystem revision #:    1 (dynamic)
Filesystem features:      filetype sparse_super
Filesystem state:         not clean
Errors behavior:          Continue
Filesystem OS type:       Linux
Inode count:              4128768
Block count:              8255394
Reserved block count:     412769
Free blocks:              7941957
Free inodes:              4118601
First block:              0
Block size:               4096
Fragment size:            4096
Blocks per group:         32768
Fragments per group:      32768
Inodes per group:         16384
Inode blocks per group:   512
Last mount time:          Thu Jun 20 14:06:41 2002
Last write time:          Fri Jun 21 13:25:23 2002
Mount count:              4
Maximum mount count:      20
Last checked:             Wed Jun 19 10:10:17 2002
Check interval:           15552000 (6 months)
Next check after:         Mon Dec 16 09:10:17 2002
Reserved blocks uid:      0 (user root)
Reserved blocks gid:      0 (group root)
First inode:              11
Inode size:               128

-Jim

P.S. DVB - I have not yet rebooted to poke through the BIOS and see how large it reports the drive.  I'll let you know as soon as I look.

0
Complete Microsoft Windows PC® & Mac Backup

Backup and recovery solutions to protect all your PCs & Mac– on-premises or in remote locations. Acronis backs up entire PC or Mac with patented reliable disk imaging technology and you will be able to restore workstations to a new, dissimilar hardware in minutes.

 

Author Comment

by:truittj
Comment Utility
OK - BIOS report on the drive:

Samsung SV4002H  [this is the correct model number]

CHS Format

Cylinders: 16383
Heads: 16
Sectors: 63
Maximum capacity: 8455 MB

LBA Format

Total sectors: 66055248
Maximum capacity: 33820 MB
Multi-Sector Transfers: 16 Sectors
LBA Mode Control: Enabled
Transfer Mode: FPIO4 & Bus Mastering
Ultra DMA: Mode 2

So it looks as if it is indeed a BIOS issue.  Unfortunately, I don't have the motherboard manual - all I have is the online documentation at:

http://support.gateway.com/support/techdocs/references/motherboard/4a4ll0x0/4a4ll0x02.shtml#hd

and that seems to give the impression that there aren't any jumper settings I need to worry about.  I'll check and see if there's a BIOS update I should install, and will take a look at the motherboard and try to see if there are any jumper candidates labeled.

-Jim
0
 
LVL 3

Accepted Solution

by:
DVB earned 200 total points
Comment Utility
Ok, my drive has *two* jumpers, instead of one. Remove the HDD and see what the jumper settings have to be to keep the disk at 40G (thats will reports as 38.some GB since the marketing literature has 1GB = 1000 MB). The jumper settings are given on the HDD case itself.
0
 
LVL 3

Expert Comment

by:ITsheresomewhere
Comment Utility
Well you probably resolved this by now but,

Your bios is ok for this size of drive as it has the extension necessary for up to 136 GB (the next barrier)

As DVB indicated the problem is most likely the 32/33 GB "clip".  The large drives now have a jumper that "clip" the size reporting to less than 40 GB to enable use on older systems that have a bios problem and where the bios cannot be updated, not your case.

Recheck the drive and remove the limiter clip.

You will have to redo the drive to get full value.

If you have trouble locating it the samsung tech site is www.samsungusa.com.

Good Luck
ITsy

0
 
LVL 51

Expert Comment

by:ahoffmann
Comment Utility
> Inode count:              4128768
> Block count:              8255394
That's your problem, excatly as I assumed in my comment.
I don't have much experiance about the amount of inodes per amount of blocks, but it is roughly 5%, usually. For lage disks it could be less.
Make a new filesystem with less inodes. See the Large_Disk howtos.
0
 

Author Comment

by:truittj
Comment Utility
Jumper setting on the drive itself it was - many thanks to DVB and ITsheresomewhere.  For reference, I was using the "lower 32GB" jumper setting for a slave drive, and had to change it to the "upper 32GB" jumper setting.  I'm not entirely sure what "lower" and "upper" refer to, but the "lower" setting will result in only 32GB being recognized, whereas the "upper" setting allows the BIOS to see the whole drive.

Thanks for the help!

-Jim
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

Daily system administration tasks often require administrators to connect remote systems. But allowing these remote systems to accept passwords makes these systems vulnerable to the risk of brute-force password guessing attacks. Furthermore there ar…
Introduction We as admins face situation where we need to redirect websites to another. This may be required as a part of an upgrade keeping the old URL but website should be served from new URL. This document would brief you on different ways ca…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now