Solved

Applet doesnt load..............URGENT

Posted on 2002-06-23
7
327 Views
Last Modified: 2010-03-31
Hi,

My applet works fine on Windows NT machine but it doesnt work on IE or Netscape on Solaris Machines. It gives me this error on the applet in Solarison the bottom of the applet.


Start:applet not initialised
when I click restart in the applet , it gives:Start:applet not initialised


When I click Reload, it give Dispose:applet not destroyed.


SOmeone please help....this is urgent

the URL for the site is:
http://www.cse.sc.edu/~group8/beta8/ 

and the java file is
http://www.cse.sc.edu/~group8/beta8/SurveyApp.java


Will greatly appreciate a help

Thanks

0
Comment
Question by:Alfred_here1
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
7 Comments
 
LVL 92

Expert Comment

by:objects
ID: 7102253
What's the error in the Java console?
0
 

Author Comment

by:Alfred_here1
ID: 7102385
Can someone please check if this applet works in a netscape version of 95,98,NT and UNix....I dont have access to netscape here....


http://www.cse.sc.edu/~group8/beta8/

Thanks
0
 
LVL 2

Accepted Solution

by:
deviprasadmp earned 40 total points
ID: 7102570
sounds like you have compiled your classes in a higher version of JDK but your browser doesnt support that version. quick fix would be to download JDK1.4 and configure the browser plugin so that its the default JVM for both netscape and IE.  i tried running my applet on my windows machine (windows 2000, IE & Netscape, JDK1.4 plugin) and it runs without any problems. another fix would be to compile your project on a lower version of JDK (something like 1.1.8).  you may also consider upgrading your browsers ;-).
that apart, your applet is cool man!!! great job :-)
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:Alfred_here1
ID: 7102721
thanks devi prasad...But this project is for school..I dont have rights to install....and its web application so..I am looking for compatibility on most browsers.
0
 
LVL 2

Assisted Solution

by:triso
triso earned 40 total points
ID: 7109165
Hi,

If you need cmpatibility use the "-target" option of javac to create versions for older VMs.  These will execute correctly without having to change plugins.

"-target 1.2" should do for you.

I hope this helps.
0
 
LVL 35

Expert Comment

by:girionis
ID: 8860664
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this
question is:

- split points between deviprasadmp and  triso

Please leave any comments here within the
next seven days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER !

girionis
Cleanup Volunteer
0

Featured Post

Creating Instructional Tutorials  

For Any Use & On Any Platform

Contextual Guidance at the moment of need helps your employees/users adopt software o& achieve even the most complex tasks instantly. Boost knowledge retention, software adoption & employee engagement with easy solution.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

By the end of 1980s, object oriented programming using languages like C++, Simula69 and ObjectPascal gained momentum. It looked like programmers finally found the perfect language. C++ successfully combined the object oriented principles of Simula w…
Introduction This article is the second of three articles that explain why and how the Experts Exchange QA Team does test automation for our web site. This article covers the basic installation and configuration of the test automation tools used by…
This video teaches viewers about errors in exception handling.
Viewers will learn how to properly install Eclipse with the necessary JDK, and will take a look at an introductory Java program. Download Eclipse installation zip file: Extract files from zip file: Download and install JDK 8: Open Eclipse and …
Suggested Courses

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question