Cpu "runaways"

Since changing from SCO-UNIX to Linux, we noticed that it is easier to produce cpu "runaways". For example, if you start a telnet session to the server, then start the shell utility "top", then ungracefully exit top (by killing the telnet session)...the "top" process continues to run but in what appears to be a race condition (uses all available cpu). I can do this (runaway) also with our propietary app, but some apps/tools do not do this , like netconfig... The "runaways" appear to be pleasent ones, just consiming cpu as it is available (look nasty, but dont seem to load down the system).
medentAsked:
Who is Participating?
 
ahoffmannCommented:
does root use bash?
do you do a  su root  or  su - root ?
0
 
ahoffmannCommented:
> .. look nasty, but dont seem to load down the system
And what is the question?

Probably your shell is configured to hangup background processes, see:
  bash: huponexit
  csh:  hup, nohup
  ksh:  nohup
  sh:   N/A :-)
  zsh:  NO_HUP
0
 
medentAuthor Commented:
That sure sounds like the answer, but it did not work.  I tried adding shopt -s huponexit to /etc/bashrc, and verified it was really on before starting the test app (netconfig). Perhaps huponexit is broke in bash?
Additional Info:
This problem I am having does not effect the root user, regardless of the shopt settings, only regular users and when I su to root (from a regular user).
0
 
medentAuthor Commented:
The problem was caused by having "trap" statement in the .bash_profile. The trap was part of a fu-fu to get an extra password to appear when a user was detected as a dialup modem. I will seek an alternative, and post a seperate question. I learned some valuable info from your input, Thank You .
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.