Korean language support for text or memo


I'm trying to build an application that supports English and Korean language input fields.  I'm trying to use the Win2000 IME to do the switch at this time.  Unfortunately, although Korean characters are displayed, they are not correct (i.e. full syllable blocks instead of individual characters) and they turn to question marks when I move to the next character.

Any idea how to get this working?

Thanks,

Scott
sfbAsked:
Who is Participating?
 
Mohammed NasmanConnect With a Mentor Software DeveloperCommented:
Hello

  These feature only include with Delphi Enterprise editoin, not with the Pro

  if you want to see the text in memo or textbox, try using the unicode components
http://www.delphi-unicode.net
0
 
VENKATConnect With a Mentor Commented:
Go to your Delphi Menu Click on Project, so u can follow below steps to add ur Korean language ...
1. Save and build your project.
2. With your project open in the IDE, choose Project|Languages|Add. When you open the Resource DLL wizard this way, it displays only languages that are not yet included in your project.
3. Select your project from the list that appears in the dialog. (That is, make sure a check mark appears in the box to the left of each project you want to process.) At this point, you can also set the root directory for the DLL projects and change the base-language setting (for Repository queries). Then click Next.

4. Select the languages you want to include in your project by checking the boxes next to them.

Select only languages which are translation targets. You don't need to create a resource DLL for the primary (base) language in which you are developing your application, but you can do so if you wish.

You can change the DLL extension for any language by clicking in the Extension column.

Click Next.

5. Set the directory path for each language’s resource DLL by clicking and typing in the Path column. The directories you specify must fall under the root directory selected in Step 3 above.

Click Next.

6. The languages you’ve selected appear in the next dialog. For each language,

 If a resource DLL already exists for the language (in the directory you have specified), click in the Update Mode column to select Update or Overwrite. Choose Update to keep and modify the existing DLL project; choose Overwrite to create a new, empty DLL project. If you choose Overwrite, the wizard will delete the old DLL project and any translations it contains.

 If no resource DLL exists, “Create New” appears in the Update Mode column. There are no further options to select.

Click Next.

7. Click Finish to create or update resource DLLs for the languages you’ve selected and include them in your project.

If the wizard asks to generate a DRC file, click Yes. Any project that uses its own resource strings (instead of previously compiled RC files) needs a DRC file.
     If you are sure that no new DRC files are needed (because your project doesn't introduce any resource strings of its own), you can select the "Skip DRC files that are not found" check box in the final dialog. This prevents the wizard from generating, or asking to generate, DRC files.
0
 
sfbAuthor Commented:

These options do not appear to be in my Delphi.  I'm using Delphi 6 Pro.

Scott
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
VENKATCommented:
The above my options are from Delphi 5. Sorry no idea on Delphi 6. You try for the same..
0
 
sfbAuthor Commented:

I checked my Delphi 5 and it also did not have the language feature.  Are you using Pro or Enterprise?

Thanks,

Scott
0
 
Mohammed NasmanSoftware DeveloperCommented:
I'm using Enterprise edition
the Pro edition doesn't has it
0
 
CleanupPingCommented:
sfb:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0
 
Lukasz LachCommented:
sfb,
No comment has been added lately (17 days), so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area for this question:

RECOMMENDATION: Award points to mnasman http:#7113620

Please leave any comments here within 7 days.

-- Please DO NOT accept this comment as an answer ! --

Thanks,

anAKiN
EE Cleanup Volunteer
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.