[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 178
  • Last Modified:

Win2K server, Active Directory, and DNS issues

I have two Win2k servers.  The primary domain controller has been up and running for quite some time (I'd guess maybe a year)  I have a new server that I had join the domain.  Both are running Active Directory and DNS.  Everything seems to be working fine except that the PDC has created an A record in DNS for itself for the secondary's IP address.  If I delete it it keeps coming back.  Well, this is causing all kinds of problems with DNS lookup.
0
boyntont
Asked:
boyntont
1 Solution
 
SysExpertCommented:
Have you checked the event logs for any warnings, errors ?

I would say that somewhere your DNS is not quite setup right !

One of these may be helpful

http://www.microsoft.com/windows2000/techinfo/planning/walkthroughs/default.asp

http://www.microsoft.com/technet/treeview/default.asp?url=/technet/itsolutions/howto/default.asp
How to information for IT people IT solutions

 http://www.microsoft.com/windows2000/library/howitworks/security/sectech.asp
0
 
AlirezaiamCommented:
What is the type of the second DNS? Is it Active Directory-integrated or standard primary or else?
0
 
mikecrCommented:
Uncheck the box on the TCP/IP settings for that nic under DNS to register itself automatically in DNS then delete the record.
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
boyntontAuthor Commented:
Sysexpert - No, no errors in event logs

Alirezaiam -- The second DNS is Active Directory integrated.

mikecr -- Which server - primary or secondary?
0
 
boyntontAuthor Commented:
mikecr -- Primary already had that box unchecked.  I did uncheck it on the secondary and deleted the record.  I just have to see if it comes back.
0
 
grberkCommented:
I think I know what this problem is. Try this and see...

I had this problem also. You want to keep the secondary DNS servers from adding their A record to the zone root. Here is the fix....

Create a text file and call it DNS Fix.reg

Copy and paste this text in it:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters]
"DnsAvoidregisterRecords"=hex(7):4c,00,64,00,61,00,70,00,49,00,70,00,41,00,64,\
  00,64,00,72,00,65,00,73,00,73,00,00,00,00,00

Merge it with your registry on the server you don't want showing up in DNS.

This will keep the server from updating the LDAP address to the zone in active directory.

There are lots of records that active directory automatically puts in DNS, and there are ways to use this reg hack to keep different records from automatically showing up.

This is all outlined in Microsoft's Branch Office Planning Guide. The section you need is here:
http://www.microsoft.com/technet/treeview/default.asp?url=/technet/prodtechnol/ad/windows2000/deploy/adguide/adplan/adpch02.asp

I spent three weeks and talking with lots of Microsoft techs to find this one, on my own I might add.

Hope this helps.

0
 
boyntontAuthor Commented:
That did the trick.  Thanks
0
 
mikecrCommented:
I'm glad that fixed your problem. Good luck!
0

Featured Post

2018 Annual Membership Survey

Here at Experts Exchange, we strive to give members the best experience. Help us improve the site by taking this survey today! (Bonus: Be entered to win a great tech prize for participating!)

Tackle projects and never again get stuck behind a technical roadblock.
Join Now