Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Weird 25 % CPU Usage on IBM Netfinity 5500 M20

Posted on 2002-06-28
8
Medium Priority
?
273 Views
Last Modified: 2011-04-14
I have a IBM Netfinity 5500 M20 with 3 CPU's. Since installing Windows 2000 the server gets about 60000 interrupts/second (20000/CPU). I've read that this can be related to ACPI. But when I check the BIOS for the motherboard it says that it's fixed ACPI support for Windows 2000 in version 1.05. My server has version 1.06.

I found the answer elsewhere. I had to disable my printer port. Very strange. But then all interrupts went away.
0
Comment
Question by:Partybanan
8 Comments
 
LVL 16

Expert Comment

by:Kyle Schroeder
ID: 7116681
Have you installed ServicePack 2 and other WindowsUpdate patches?  Assuming you are running 2000 Server or Advanced server and not Professional...

Check this link:
http://www.pc.ibm.com/qtechinfo/MIGR-4PAU4F.html?lang=en_US
There are some notes about installing a certified RAID driver before the ServicePack.
Or this one regarding Advanced Server:
http://www.pc.ibm.com/qtechinfo/MIGR-4FJPZ7.html?lang=en_US

Back with more soon...

-dog*
0
 
LVL 13

Expert Comment

by:magarity
ID: 7117206
Use the task manager's ability to list CPU use per thread to see what program/process is using this time.  Get task-man going, hit 'view' and then 'select columns' (or similiar, sorry I'm on a Win98 machine at the library right now and can't check the exact sequence).  In the select views is an option for 'entire process tree' or somesuch...  it will show daughter processes that aren't always listed in the default task-man view.
0
Eye-catchers on the conference table

Challenge: The i-unit group was not satisfied with the audio quality during remote meetings. They were looking for a portable solution with excellent audio quality for use in their conference room but also at their client’s offices.

 

Author Comment

by:Partybanan
ID: 7118421
Wow!

Thanks for all comments.

Unfortunately I've already looked into these things. There is no process that is taking up the CPU time. It's interrupts that take all the CPU time.

I've installed SP2 for Windows and all other updates. The motherboard BIOS is version 1.06 (latest version) and the ServeRAID (with all components) is version 4.84 (latest version). Updated ServeRAID after installing SP2 so they haven't been overwritten. I haven't set interrupts manually though, but there are no conflicts reported.  

Still looking for more ideas...

I'll try to set IRQ manually and see if it helps.

Thank you all!
0
 
LVL 16

Accepted Solution

by:
Kyle Schroeder earned 240 total points
ID: 7122274
See this MSKB article (I would provide a direct microsoft.com link but I can't get there at the moment for some reason): Q252867

There is a tool called the Interrupt-Affinity Filter.  Here's the summary from the article:

SUMMARY
=======
 
Binding of device interrupts to particular processors on multiprocessor
computers is a useful technique to maximize performance, scaling, and
partitioning of large computers. Interrupt-Affinity Filter (IntFiltr) is an
interrupt-binding tool that permits you to establish affinity for device
processors on multiprocessor computers. IntFiltr uses Plug and Play features of
Windows 2000 and provides a Graphical User Interface (GUI) to permit interrupt
binding. This article describes how to install and use IntFiltr to permit a user
to change the Central Processing Unit (CPU) on a single computer.
---------------------------
Perhaps this will help you???

-dog*
0
 
LVL 1

Expert Comment

by:Piri
ID: 9265951
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is:
Accept dogztar comment as asnwer
Please leave any comments here within the next seven days.
 
PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!
 
Piri
EE Cleanup Volunteer
0
 

Author Comment

by:Partybanan
ID: 9287600
I found the solution to my problem some time ago.
The solution was to disable the LPT port in Windows 2000. I have no idea why it helped but probably it was issuing interrupts like mad.
Possibly dogztar's solution would have helped if I hadn't already solved it myself so I accept that as answer.
There should really be someway to withdraw a question if you solve it yourself.

Thanks everybody for all ideas!
0
 
LVL 16

Expert Comment

by:Kyle Schroeder
ID: 9288611
Partybanan:
Glad you were able to resolve your problem.  And just FYI, you can "withdraw" a question by posting a request in Community Support to have your points refunded.  The content of the question will be left intact in case someone else has the same problem in the future.

-dog*
0

Featured Post

Sign your company up to try the MB 660 headset now

Take control and stay focused in noisy open office environments with the MB 660. By reducing background noise, you can revitalize your office and improve concentration.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Moving your enterprise fax infrastructure from in-house fax machines and servers to the cloud makes sense — from both an efficiency and productivity standpoint. But does migrating to a cloud fax solution mean you will no longer be able to send or re…
This article shows how to use a free utility called 'Parkdale' to easily test the performance and benchmark any Hard Drive(s) installed in your computer. We also look at RAM Disks and their speed comparisons.
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an anti-spam), the admin…
Loops Section Overview
Suggested Courses

773 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question