• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2011
  • Last Modified:

All Users\Desktop Not Accessible!

I get an "Access is Denied" message every time I try to access the All Users\Desktop folder. This used to be the case whenever I tried to access the Shared Documents folder.  I don't know what happened, but now the problem has switched to another folder.

Normally, I would care less for needing these folders, but an installation program is trying to make a desktop icon to that folder and is stubborn enough to not continue on without putting its stupid icon there.  It's one of those *.msi installation files.

What's going on with my system?  Is there some way to bypass that file from being installed?  I would prefer being able to allow access to this folder, though.
0
ccolon
Asked:
ccolon
  • 2
1 Solution
 
Crash2100Commented:
try going into the folder "C:\Documents and settings\All Users" and open the properties for the desktop folder.  In the properties window, click the security tab and make sure "Everyone" is the only thing listed under "groups or usernames".  Then click "everyone" and be sure nothing is denied in "Permissions for everyone".

If that doesn't help you could try logging on as administrator and try your install again.  To logon as administrator, go to start menu->log off.  And choose logoff, when the logon screen appears, press CTRL+ALT+DEL twice.  Then type Administrator in the username box and say ok.  Now try your install again.  While you're in here check the permissions for the "All users" folder again.
0
 
ccolonAuthor Commented:
Thanks a lot!  It didn't work the way it was supposed to, but I got where I needed to go.  What happened is that there were no security settings I could make.  And when I logged off and did your little Admin trick, it wouldn't log me on because of some restriction.  BUT when I logged back on as my own, a whole bunch of old desktop shortcuts showed up and I was able to install my program.

Lord knows what's up with Microsoft ...
But thanks for helping out an NT-kernel newbie
0
 
Crash2100Commented:
that's really weird, it sounds like your security policies are screwed up somewhere.  You might want to look through your "Local security policy" and the settings in "Computer management" to see if there are any settings you think might be effecting this.  You can access these settings under Start Menu->All programs->Administrative Tools, or by running these commands.  Good luck, and thanks for the points!

compmgmt.msc
secpol.msc
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now