Solved

how to install proftpd

Posted on 2002-07-02
11
757 Views
Last Modified: 2013-12-15
I am trying to install proftpd into a RedHat Linux 6.2 box to replace wu-ftpd.
I downloaded proftpd-1.2.5rc1-1.i386.rpm from ftp.proftpd.net and run "rpm -i proftpd-1.2.5rc1-1.i386.rpm" but got the following error:
error: failed dependencies:
       libc.so.6 (GLIBC_2.2) is needed by proftpd-1.2.5rc1
       libc.so.6 (GLIBC_2.2.3) is needed by proftpd-1.2.5rc1
I tried to search for GLIBC_2.2 but just could not get the right version. I am wondering what caused the problem exactly, since the Linux is a normal installation, do I need to run any updates to install proftpd.
BTW, I didn't find any package under ftp.proftpd.net/distrib/packages/RPMS, so had to download all .rpm from the historics folder, are they the right things to download.
In brief, I need help in getting and installing proftpd into a RedHat Linux 6.2 to replace wu-ftp. Any detailed instructions are highly appreciated...
0
Comment
Question by:asp168
  • 6
  • 5
11 Comments
 
LVL 40

Expert Comment

by:jlevie
ID: 7125790
I don't think you'd want to use a version pf ProFTP that old and I doubt that you'll find a pre-built rpm image for a version of RedHat that old. Why not get the sources from proftpd.net and build your own copy? It's pretty easy, especially if your 6.2 system is up to date w/respect to the 6.2 errata.
0
 

Author Comment

by:asp168
ID: 7126810
can you give me a link to the download and instructions of installation? thanks!
0
 
LVL 40

Expert Comment

by:jlevie
ID: 7126914
Get the 1.2.5 release code from ftp://ftp.proftpd.org/distrib/source/ and unpack it somewhere. You can build it with an unadorneed "./configure", but I like my copies to be installed similar to where wu-ftp lives and use:

./configure  --prefix=/usr --localstatedir=/var --sysconfdir=/etc

which places the executables in /usr/sbin. the conf stuff in /etc and the dynamic data in /var.
0
Migrating Your Company's PCs

To keep pace with competitors, businesses must keep employees productive, and that means providing them with the latest technology. This document provides the tips and tricks you need to help you migrate an outdated PC fleet to new desktops, laptops, and tablets.

 

Author Comment

by:asp168
ID: 7127461
I installed it and just made the following changes in the /etc/proftpd.conf:

User root
Group root

Then I tried to start it up by running ./proftpd in the folder of /usr/sbin, I didn't see any error message after that.
But I can't ftp to the server. Please advise if the above procedures are right and how to verify the proftpd is running?

thanks
0
 

Author Comment

by:asp168
ID: 7127543
I tried to start it by running "./proftpd -n -d2 -c /etc/proftpd.conf" and got the following error:

Domainname - Failed binding to 0.0.0.0, port 21: Address already in use
Domainname - Check the ServerType directive to ensure you are configured correctly.

Please advise what caused the error, thanks!!
0
 
LVL 40

Expert Comment

by:jlevie
ID: 7127730
Typically that means just what it says, namely that something else already is bound to port 21. My guess is that wu-ftp is probably installed and that inetd is listening on port 21 for wu-ftp. I always remove any other ftp servers before installing ProFTP, but you can simply edit /etc/inetd.conf and comment out the "ftp" line and tell inetd to re-read the config with 'killall -HUP inetd".  A quick check for port 21 being in use is to execute 'lsof | grep ftp'. If there is something bound to port 21 that command will tell you what it is.
0
 

Author Comment

by:asp168
ID: 7127752
yes it was because the proftpd is already, now how to restart the proftpd with new settings in the /etc/proftpd.conf without restarting the whole linux server?
0
 
LVL 40

Expert Comment

by:jlevie
ID: 7127798
Oh, that's easy. Issue a 'killall proftpd' and then run the executable again.
0
 

Author Comment

by:asp168
ID: 7128373
The following was fixed with a Linux 7.2 box with a restarting, but I got the same problem with a Redhat Linux 6.2 and just can't fix it out, I tried restarting the server, killall proftpd, and it said  no process killed. I ran "ps" and could not see the proftpd process at all. Seems that the proftpd was not start up. What exactly is the problem of the following...

I tried to start it by running "./proftpd -n -d2 -c /etc/proftpd.conf" and got the following error:

Domainname - Failed binding to 0.0.0.0, port 21: Address already in use
Domainname - Check the ServerType directive to ensure you are configured correctly.

Please advise what caused the error, thanks!!
0
 

Author Comment

by:asp168
ID: 7128444
I guessed the problem is because the ftp was enabled in the inetd.conf, so I # the ftp line.
Now a quick question is how to active the new inetd.conf without restarting the server, since my server can't be shutdown for reboot...
0
 
LVL 40

Accepted Solution

by:
jlevie earned 50 total points
ID: 7128575
That's in an earlier comment, but to get inetd to re-read its config file and stop listening on port 21 issue the command 'killall -HUP inetd'
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

SSH (Secure Shell) - Tips and Tricks As you all know SSH(Secure Shell) is a network protocol, which we use to access/transfer files securely between two networked devices. SSH was actually designed as a replacement for insecure protocols that sen…
Linux users are sometimes dumbfounded by the severe lack of documentation on a topic. Sometimes, the documentation is copious, but other times, you end up with some obscure "it varies depending on your distribution" over and over when searching for …
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

820 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question