?
Solved

How to star IMAP/POP under RedHat Linux 6.2

Posted on 2002-07-05
5
Medium Priority
?
524 Views
Last Modified: 2013-12-15
I have installed IMAP-4.7-5 in a Redhat Linux 6.2 box, and started it up already. For some reason I restart the whole server and now the IMAP and POP are not running!
I ran "rpm -q imap" and get "iamp-4.7-5", and in /etc/inetd I have
"pop-2 stream tcp no wait root /usr/sbin/tcpd ipop2d
pop-3 stream tcp no wait root /usr/sbin/tcpd ipop3d
imap stream tcp no wait root /usr/sbin/tcpd imapd"
unmarked. I tried to run "killall HUP inetd" and it said no process killed. But I just cannot telnet into POP/IMAP ports 110/143.
The sendmail is running and I can see mails in users mailbox, but they just can't get mails from IMAP/POP.
Any quick help in starting IMAP/POP is highly appreciated!
0
Comment
Question by:exchangesmith
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
5 Comments
 
LVL 40

Expert Comment

by:jlevie
ID: 7133153
Check /etc/hosts.allow & /etc/hosts.deny. If those files aren't empty you could be inadvertantly blocking access to the IMAP and POP ports. Also make sure that inetd is running, like: 'ps -ef | grep inetd | grep -v grep'. you can check to see that inetd is enabled at boot with 'chkconfig --list inetd'. Typically you want inet enabled for run levels 3 and above. If it isn't enabled at boot you may need to enable it  with a linuxconf or with 'chkconfig inetd on', then double check to make sure it is enabled for run level 3.

FYI: The command to bet inetd to re-read the config file is 'kill -HUP inetd', note the '-'.
0
 

Author Comment

by:exchangesmith
ID: 7137741
Thanks jlevie.
I got the answer from another source, pasted below for your reference...

Sendmail seems to be working fine, but when users try to connect to the mailhost to get their mail, they can't connect. What's wrong?


Most likely this really is not a sendmail issue. Chances are the POP3 daemon is not installed. With Red Hat Linux, its part if the IMAP RPM. To see if the package is installed, type the following at a root command prompt:
rpm -q imap
If you get a no response, the IMAP RPM is not installed and you will need to install it to get things working right. Just mount your installation CD-ROM (or second CD-ROM with Red Hat Linux 7.x) by typing:
mount /mnt/cdrom
Change to the /mnt/cdrom/RedHat/RPMS/ directory, then as root type:
rpm -Uvh imap*.rpm
Try connecting from your clients again.
Under 6.2 or before, if you still have a problem open up your /etc/inetd.conf file in a text editor.
Look for the line which ends with ipop3d and make sure it is not commented out or preceded with a pound sign. If it is, remove the pound sign and restart inetd by typing:
/sbin/service inet restart
Then try connecting again.
If your Red Hat Linux version is 7.0 or higher, the system uses xinetd rather than inetd. You will need to make sure that ipop3 is turned on in xinetd.
To see ipop3's current status, type this command as the root user:
chkconfig --list ipop3
If the response is off, type this command as root to turn on ipop3:
chkconfig --level 345 ipop3 on
If you need to turn on several POP and IMAP services at once, try using ntsysv. Type the following command as the root user:
ntsysv 345
Then, turn on several services for these runlevels by moving to the appropriate line, such as the ipop3 and ipop2 lines, and hitting the [Spacebar] to make your selections. Then, [Tab] to the OK button and press [Enter].
Finally, you have to restart xinetd to make your chkconfig or ntsysv changes take effect. Type this command as the root user:
/sbin/service xinetd restart
Then, try to connect using your POP email clients again.


0
 
LVL 1

Expert Comment

by:petereilering
ID: 7143030
Maybe you are using wrappers instead of a daemon.
try this

telnet localhost 110
If you get a welcome then your pop is working and the daemon
becomes active after a connection on the right port in case of pop3 it is port 110
0
 

Author Comment

by:exchangesmith
ID: 7143252
aaa
0
 

Accepted Solution

by:
asp168 earned 160 total points
ID: 7143259
exchangesmith's answer is correct
0

Featured Post

Will your db performance match your db growth?

In Percona’s white paper “Performance at Scale: Keeping Your Database on Its Toes,” we take a high-level approach to what you need to think about when planning for database scalability.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

rdate is a Linux command and the network time protocol for immediate date and time setup from another machine. The clocks are synchronized by entering rdate with the -s switch (command without switch just checks the time but does not set anything). …
Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
Suggested Courses

718 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question