Solved

Configuring frame relay on 2600  router

Posted on 2002-07-07
3
354 Views
Last Modified: 2012-05-04
Hi,

I want to configure frame relay on 2600 series router to connect to my ISP router i,e point to point.
Here right now i have configured the serial int as a subinterface that operates as point to point.As we are not using routing protocols I have used the fream-relay map cmd to statically map the PVC to the remote router IP.
Is it a good idea to break up the physical int into a subif and conf p-p.or is it a good idea conf directly through the serail int instead of braking into subif.
Key in your valuable inputs on this with the advantages
0
Comment
Question by:sunny6687
  • 2
3 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 7135227
I always setup subinterfaces for frame PVC's like this:

Interface Serial 0/0
 encapsulation frame-relay

Interface Serial 0/0.1 point-to-point
 description uplink to ISP Circuit# xxxyyyxyx
 ip address 192.168.111.2 255.255.255.252
 (or ip unnumbered)
 frame-relay interface-dlci 500


The reason is simple. If I lose a connection that I have built using a map IP command, the router will not send me a trap event or alert me if something is wrong. However, If I use a subinterface and the PVC drops, now I have an interface event that I can monitor easily.
I can also set my default gateway as an interface if I'm using ip unnumbered (many ISP's ask you to do that to save IP addresses):

ip route 0.0.0.0 0.0.0.0 serial 0/0.1

0
 

Accepted Solution

by:
slimjim100 earned 200 total points
ID: 7138758
Sunny6687,

You have to have a subinterface. You can't setup a point to point with fron on the serial itself. You also can set up a point to multi point frame if you like. You will need the DLIC # from you ISP and al other info. Here is a sample config:
hostname (CUSTOMER'S NAME)
enable password (password)
!
ip subnet-zero
ip routing
!
interface Serial0/0
no shutdown
encapsulation frame-relay
frame-relay lmi-type ansi
!
interface Serial0/0.1 point-to-point
no shutdown
description connected to Internet
ip address (CUSTOMER'S WAN IP) 255.255.255.252
frame-relay interface-dlci (CUSTOMER'S DLCI) ietf
!
ip route 0.0.0.0 0.0.0.0 Serial0/0.1
!
snmp-server community
ip classless
ip name-server 207.230.75.34
ip name-server 207.230.75.50
ip domain-lo
!
line vty 0 4
password (Telnet Password)
login

Good luck and if you need more help E-mail me @ slimjim100@hotmail.com if you like you can hook up a modem and I will set it up for you. I work for an ISP. Also go to Cisco's website and download config maker and it will set it up for you.

Brian
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 7138776
Slimjim100,
 Welcome to E-E! Its common courtesy to provide comments unless you know your answer is the only answer and is 300% correct and is what the questioner is looking for and will fix their problem. Please don’t take this personally, (others could let you know before I and not so diplomatically) I made the same mistake when I first arrived and someone was nice enough to point it out to me (It hurt my feelings, but I soon realized its teamwork that’s used here). This accomplishes a couple of things: First: it doesn't lock the question allowing more exposure to other experts allowing a faster fix (many problems require an interactive dialogue to troubleshoot them properly), Secondly: it gives the questioner the option to make an award based on the best comment that helped the most in fixing their problem and it is also is common courtesy to other experts.  Again welcome and look forward to working with you in the future, a lot of teamwork is used at this forum, as you will see! :>)  Quote shamelessly stolen from Dave, Thanks again Dave

Your answer may be correct, and I hope it is, after all the main goal here is to help the questioner, but when you propose an answer it removes the "accept comment as answer" button thereby robbing the questioner of the choice to choose which expert helped the most. If your comment is chosen by the questioner, you will be awarded the points.
Thank you  
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

While it is possible to put two routes in place with the secondary having a higher metric, this may not always work. In the event of a failure that does not bring down the physical interface on the router the primary route is not removed. There is a…
Problem Description:   Couple of months ago we upgraded the ADSL line at our branch office from Home to Business line. The purpose of transforming the service to have static public IP’s. We were in need for public IP’s to publish our web resour…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now