Samba and Explorer.

Running a pretty stock Debian 3.0 system and samba 2.2.3-a6. For some reason when i have a share open in the Windows explorer, the left tre pane doesnt update if i move files/directories on the samba server. The directories are still visible in the left pane, and shows as empty if i open them. How can i make things fall back into sync?
LVL 12
j2Asked:
Who is Participating?
 
SpideyModConnect With a Mentor Commented:
PAQ'd and points refunded.

SpideyMod
Community Support Moderator @Experts Exchange
0
 
lewisgCommented:
Have you tried pressing F5 on the windows machine? What version of Windows?
0
 
j2Author Commented:
Yes. F5, close the pane, disconnect and reconnect the share, closed explorer and reopened it. W2k Pro and W98SE
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
lewisgCommented:
Are you "move(ing) files/directories on the samba server" using explorer on one of the Windows machines?

If you are moving them using a logon with different rights on the server machine I can see where you might not be able to see them when they are moved.
0
 
j2Author Commented:
No. Moving with explorer works. But directly manipulating files on the unix server causes this. But it does not happen when using resources of our RedHat Samba Servers, and i cant find any real diff between the confgis.
0
 
jlevieCommented:
I've seen the same thing with a copy of Samba running on FreeBSD 4.4. Since I had built Samba from sources, it was easy enough to build Samba from the same sources for Solaris 2.7 and RedHat 7.1. Using the same config file I didn't have the problem with Solaris or with RedHat. So I figured it had to be something in the way Samba and the host OS got along.

I don't know if your problem is from the same cause and you'd  really want to use a copy built from source on Debian and RedHat to figure out if is directly related to the OS.
0
 
ahoffmannCommented:
did you check following setting in smb.conf:

  change notify timeout
0
 
j2Author Commented:
change notify was set to default (60 seconds). Reducing it makes no difference.

And also, as i said. The _right_ pane in windows explorer works correctly. But the left doesnt.
0
 
ahoffmannCommented:
Does following produce the correct listing?

   smbclient \\\\SERVER\\j2 -U j2 -W FUNNT -c dir

if so, the problem needs to be tracked down in the Explorer, not Samba.
0
 
j2Author Commented:
That produces the correct listing. Well, if it is an explorer problem, why doesnt it behave the same with a RedHat samba server?
0
 
ahoffmannCommented:
strange, indeed ...
Do you have the same smb.conf for RH-Samba and other-Samba?
0
 
j2Author Commented:
Yeap. same config. But i just realised that the Debian box is using XFS and the Redhat uses ext2. Ill set up a shre on the deb box on one of its ext3 (as close as ill get) and see.. But i dont think that should matter?
0
 
NickCommented:
As an aside, and totally irrelevant comment here, if you have a SMB share open in Windows Explorer on Win2000, right mouse click a file you only have read access to, got to the 'security tab' and change the properties to full access...  Windows Explorer crashes bigtime.

Nick :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.