Solved

asp.net doesn't work

Posted on 2002-07-08
9
415 Views
Last Modified: 2013-11-25
Hello experts,
in my environment
- Operating System: Windows 2000 Server
- Internet Information Service 5.0
- Visual Studio .Net
I cannot establish a connection to my IIS using asp.net.
-- IE 6.0 gives the following info:
The server application is not available.
The web application on this web server is currently not available. Please click on 'refresh' to repeat this action.
Administration hint: a more detailed info concerning the error exists in system event protocol of the web server.
-- here is the event protocol info:
aspnet_wp.exe couldn't be started, because the userid and/or the password defined in processModel section in the configuration file are invalid.
--
I checked the file machine.config and found the following related entries:
---
<section name="processModel" type="System.Web.Configuration.ProcessModelConfigurationHandler, System.Web, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" allowDefinition="MachineOnly"/>
---
<processModel enable="true" timeout="Infinite" idleTimeout="Infinite" shutdownTimeout="0:00:05" requestLimit="Infinite" requestQueueLimit="5000" restartQueueLimit="10" memoryLimit="60" webGarden="false" cpuMask="0xffffffff" userName="machine" password="AutoGenerate" logLevel="Errors" clientConnectedCheck="0:00:05" comAuthenticationLevel="Connect" comImpersonationLevel="Impersonate" responseRestartDeadlockInterval="00:09:00" responseDeadlockInterval="00:03:00" maxWorkerThreads="25" maxIoThreads="25"/>
---
I cannot see what's wrong.

The same application works in the following environment exactly as expected:
- Windows XP Professional
- IIS 5.1
- Visual Studio .Net

Does anyone know what could be wrong?

Thank you HStrix


0
Comment
Question by:HStrix
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
9 Comments
 
LVL 4

Expert Comment

by:kpkp
ID: 7137301
the userName="machine" password="AutoGenerate" in your machine.config mean that the ASP.NET application process will try and login using the user account ASPNET (aspnet_wp account).  Do you have this account defined on your machine?  

It should be created during the installation of .NET.  If it doesn't exist - or someone has changed the password, then the ASP.NET worker process can not start (at least not using the machine.config that you have).

you have a couple of options:

try removing and reinstalling .NET - this should (re)create the ASPNET account and machine.config

try changing the username and password settings in machine.config to an account that does work - or create a new account for the ASP.NET process and change machine.config to use this
0
 

Author Comment

by:HStrix
ID: 7137409
Thank you,
the user ASPNET did exist.
Nevertheless I created a new user
(for three groups: DebugUser, DomainUser, WebUser).
I changed userName and password to my settings.
But the system still tries to use ASPNET instead of my one.
Do I need to change anything in
--
<section name="processModel" type="System.Web.Configuration.ProcessModelConfigurationHandler, System.Web, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" allowDefinition="MachineOnly"/>
--
as well?
0
 
LVL 4

Expert Comment

by:kpkp
ID: 7137491
You should just need to change the userName="" password="" in <processModel>.  I just tried it on my machine, and had to reboot for the changes to take effect.  You could probably just restart some processes to get the same effect - but rebooting should do the trick
0
Raise the IQ of Your IT Alerts

From IT major incidents to manufacturing line slowdowns, every business process generates insights that need to reach the people required to take action. You need a platform that integrates with your business tools to create fully enabled DevOps toolchains.

You need xMatters.

 

Author Comment

by:HStrix
ID: 7137498
OK, I'll set both to empty string and will reboot.
But which user is used in that case?
0
 
LVL 4

Expert Comment

by:kpkp
ID: 7137525
No! When I said userName="" password="", I was just letting you know which attributes to change!

Put the correct userid and password in the quotes (i.e. the userid for the new user you created to run the ASP.NET worker process, and the password you specified for it)

- then reboot!  OK, so maybe userName="" password="" was a but misleading
0
 
LVL 4

Expert Comment

by:kpkp
ID: 7137579
Also, bear in mind that it's not a very good idea to store password info in any file.  Especially in clear text on a web server.  

Although the machine.config shouldn't be accessable to unautorised users, security holes have been found in the past that allow access to these kind of files.

If this is a production machine, if at all possible, try and get the ASPNET user working again. And put the machine.config back to it's default.  Try removing the account, and uninstalling .net - then reinstall .NET
0
 
LVL 23

Accepted Solution

by:
naveenkohli earned 100 total points
ID: 7137799
Incase of WIndows 2000 Server (Domain Controller), the <processModel> info in MAchine.config file needs to be changed. Change it to "SYSTEM" from "machine". This is a known issue for domain controllers.
Following link should give you more details on the process identity.

http://www.gotdotnet.com/team/upgrade/v1/aspnet_account_readme.doc

When you make changes to .config file, there is no need to reboot. You simply need to restart IIS. It will oad the changed .config file into process.

Incase of Windows XP, the process model does not need SYSTEM previlieges, therfore you don't have to make any changes to <processModel> and it works out of the box.

Naveen
0
 

Author Comment

by:HStrix
ID: 7137819
Thank you,
in the first instance my intension was to get it working under Windows 2000 too.
It is NOT a production environment, I'm using localhost.
But until now, I was not able to get working.
I checked also the permissions for the directories,
and - everything looks fine to me.
-----
In the meantime I looked a little bit around and found the following link:
---
http://support.microsoft.com/default.aspx?id=kb;en-us;Q315158
---
This sounds very familiar to me.
I'll give the information about the result.
0
 

Author Comment

by:HStrix
ID: 7137964
I've applied all of the information available in the above link.
And - I could make it working.
The problem is quite strange.
I'm looking forward to an appropriate patch from Microsoft.
The current solution is a workaround only.
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Did you know SD-WANs can improve network connectivity? Check out this webinar to learn how an SD-WAN simplified, one-click tool can help you migrate and manage data in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In my previous article (http://www.experts-exchange.com/Programming/Languages/.NET/.NET_Framework_3.x/A_4362-Serialization-in-NET-1.html) we saw the basics of serialization and how types/objects can be serialized to Binary format. In this blog we wi…
A long time ago (May 2011), I have written an article showing you how to create a DLL using Visual Studio 2005 to be hosted in SQL Server 2005. That was valid at that time and it is still valid if you are still using these versions. You can still re…
This is Part 3 in a 3-part series on Experts Exchange to discuss error handling in VBA code written for Excel. Part 1 of this series discussed basic error handling code using VBA. http://www.experts-exchange.com/videos/1478/Excel-Error-Handlin…
Michael from AdRem Software outlines event notifications and Automatic Corrective Actions in network monitoring. Automatic Corrective Actions are scripts, which can automatically run upon discovery of a certain undesirable condition in your network.…

695 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question