XTERM HELL

I have RH 7.3 installed on my server with X
I use XManager on my PC to allow me to connect to my RH box.

My question is how can I modify terminfo or termcap to allow the backspace key to work "properly" in xterm ?

Thanks

Phil
phil2_curtisAsked:
Who is Participating?
 
MFCRichConnect With a Mentor Commented:
Do not make the change to terminfo/termcap. Put lines like the following in your .Xdefaults file:


xterm*vt100.translations: #override <Key>Delete: string(0x7f)
xterm*vt100.translations: #override <Key>BackSpace: string(0x08)

0
 
ahoffmannConnect With a Mentor Commented:
stty erase '^H'

Keep in mind that you're struggling with sevaral dragons:
  1. stty
  2. termcap/terminfo
  3. shell (according to 2.)
  4. X-window (like xterm, dtterm, kterm, etc.)
  5. X-Server (like MIT's X, XFree86, etc.)
  6. class resourcefile /according 4. and 5.)
  7. private .Xdefaults (according 4. and 5. and 6.)
  8. method how resource files are activated (for example with: xrdb -merge ...)

oops, that are not dragons, but features ;-)
0
 
CleanupPingCommented:
phil2_curtis:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0
 
TheWeakestLinkCommented:
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is:
Split points between MFCRich and ahoffman
Please leave any comments here within the next seven days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

TheWeakestLink
EE Cleanup Volunteer
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.