Solved

crossover network with mind of it's own

Posted on 2002-07-08
12
498 Views
Last Modified: 2013-11-29
Hiya's .....I have two puters here one running 98se and one 95c.  The 98se is set up as a server running 'analogx' proxy prog so I can share my internet connection between both puters on a crossover cable.

Normally this runs fine and I"ve no prob with the proxy prog in fact its great.  Problem is.... Sometimes the 95c puter, which is the 'client' decides seemingly all of it's own accord to refuse to goto websites or to go online...when i clik a page it' says .....'connecting to 192.168.0.1' which is the Ip of the 'server'.  Now it' dont always do this in fact it only sometimes does it.  However when it does it I cant figure out why.  For example all evening it has been doing that and I've been fiddling around with the settings to try to sort it out.  Well it did it three mins ago ....but just now it decided to goto a website after all.  I have not between then and now changed anything.......

This is driving me slightly nutty.  The only thing that sometimes helps and I mean SOMETIMES is to goto internet properties/connections/ and change the settings under 'settings' and 'LAN settings' then without closing the properties box......change them back again......

As i say that sometimes helps and it fixes the problem but other times it does nothing to help......

Now why would the 'client' want to think it's supposed to connect to the ip of the 'server' not the ip of the website that I've asked for...

I've just tried a test........
pinged the ip of my isp......timed out...
pinged the url of my isp......Unknown host...
clik the internet icon on desktop with same isp home page .......go there......
type url (www.xtra.co.nz) into addy bar clik 'go' ...go there

remember that sometimes the puter will say 'connecting to 192.168.0.1 thats the server, my other puter...

any ideas .......?


0
Comment
Question by:drcspy
12 Comments
 
LVL 4

Author Comment

by:drcspy
ID: 7137314
LAN is running tcp/ip as 'default' protocol and with netbuei installed too so that the puters can access each other.......until I (re)installed netbuei the client could access all shared stuff on the server.....but the server couldn't access the client.....grrrrrr.... netbuei fixed that and now the server can access the shared drive on the client.......

the Ips are set to 192.168.0.1 - server
                   192.168.0.2 - client
subnet mask 255.255.255.0
default gateway on client set to 192.168.0.1
Internet options on client>> Internet Properties/connections/settings ..... 'Automatically detect settings'..
Properties/connections/LAN settings....'use a proxy server' wiht addy 192.168.0.1 (port is 6588 as required by the analogx proxy prog)
WINS - disabled....(on the tcp/ip properties for the nic)
DNS - disabled ... (ditto)
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 7137608
Uncheck the "Automatically detect settings" box. As long as you have the explicit address of your proxy, this setting will cause the behaviour you experience.
0
 
LVL 63

Expert Comment

by:SysExpert
ID: 7137950
ALso, get the latest NIC drivers for this machine and the win98 one also.

One last thing is to update the Winsock driver.
http://www3.bc.sympatico.ca/cs/dhcp/

I hope this helps !
0
 
LVL 16

Expert Comment

by:SteveJ
ID: 7138218
Try lrmoore's suggestion, deselect "Auto detect settings"

The reason your '95' machine attempts to contact your 'server' is because that's the function of a proxy server. AnalogX on your 98 machine 'proxies' the request for your '95' machine. You want to get to www.somedumbpage.com so your '95' machine tells your AnalogX 98 machine . . . which in turn request the page FOR your '95' machine. Your 95 machine never has a direct connection to www.somedumbpage.com.

If you can't ping www.somedumbpage.com, it USUALLY means that your name resolution (DNS) isn't working. When you access a web site such as www.somedumbpage.com (in your case) the analogx proxy first has to convert the URL into an IP address by doing a domain name service lookup. Sometimes web sites block ping for 'security' reasons.

So your ping timeout may be one of a couple of things: the pinging machine doesn't have a gateway to the IP address you are pinging, the PINGed site blocks (doesn't respond to) pings, or you have some obscure routing problem. The more likely reason may be that analogX doesn't proxy pings which means that your source IP address for the ping is 192.168.x.x which isn't routable on the internet . . . meaning the PINGed address can't/doesn't know how to get back to you.

The 'unknown host' response is saying that the PINGing machine cant resolve the URL into an IP address which means that for whatever reason it wasn't getting to a domain name server.

I'll be glad to put more verbiage into an answer to make it clear if you want me to.

Steve
0
 
LVL 3

Expert Comment

by:Comply
ID: 7138421
What are you using Dial-up, Cable, DSL. I assume it's dail-up cause I only see two NIC's and no router.
0
 
LVL 4

Author Comment

by:drcspy
ID: 7138860
thanks for your replys friends

irmoore......if I do that the all the client will do is try to 'goto' the server addy and never a page.....I've tried it.....

sysexpert....I have all the latest drivers the nics are very new and came with drivers...winsock version is updated too

Stevej......Pings well the client machine has the 'default gateway' set to the Ip of the server...and oddly even when it WILL play ball and goto a website I choose it still wont ping either Ip's or urls.......

wondering about host files ??????
0
Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

 
LVL 16

Expert Comment

by:SteveJ
ID: 7138893
If the source address of your PING is 192.168.anything then I'm not surprised that pings don't work. The 192.168 address is a private address block that by definition internet routers won't route traffic to or from to that address. Your analogx server has two addresses, a private address which your client pc is networked to, and a public address either on your dialup adapter or second ethernet adapter if you are using a cable or DSL connection. The analogx software uses the IP address on the "adapter" that actually connects to the internet.

When your client PC uses analogx to proxy a connection, the analogx server "uses" it's own public address to establish the connection to a web site. This is all "IP stuff" and has nothing to do with PING which uses a different protocol called ICMP, standing for International Commission on Missing Persons or internet control message protocol, I can never remember which.

Does the client fail consistenly under any circumstance? How about when the server is actively connected to the internet (has a web page displayed) . . . will the client fail then also? Or is it always a sort of hit or miss proposition? When the client fails, can the client ping the pubic address AND the private address of the server? Assuming that fiddling around with the settings has no effect either positive or negative . . . have you ruled out a physical problem such as a goofy cable or misbehaving hub or switch?

Steve
0
 
LVL 4

Author Comment

by:drcspy
ID: 7138959
I:m on dial up ........no hubs etc.......crossover only....two nics

SteveJ.....well i must check if it'll ping the 'public' addy of the server....hmmm.....checked just now....yes it pings nicely..both puters are online at the moment the server is only on IM not a page ......this puter...the client I am on now....obviously is on a page :-) ok checked ping for an url....no go ...

client failure is INCONSISTENT.....as the title of the question suggests.....(mind of it's own)

goofy hub ?...nope aint got one.....(crossover system)
goofy cable.....?.....nope I haev two and the system does this with either....

0
 
LVL 16

Expert Comment

by:SteveJ
ID: 7138979
OK. When the client is working, go to a DOS window and type winipcfg and when it's not working go to a DOS window and type winipcfg and compare the two . . . probably won't reveal anything but why not check. When you are making changes are you making them in the Control Panel/Internet or on the active browser window? Have you been to the analogx site and joined the listserver group? Do you have logging enabled? If yes . . . what's it say?

Steve
0
 
LVL 4

Author Comment

by:drcspy
ID: 7139020
ok......winipcfg on working client (now).....
ppp adaptor....adaptor addy shown ......Ip and subnet all 00 00 00 00 etc

making changes I jsut right clik the internet icon on desktop and goto properties/connections etc

havent joined listserver group but am considering it :-)

logging.....um.....enabled....and the log is HUGE lol.....doesn't seem to show any probs.......
0
 
LVL 16

Accepted Solution

by:
SteveJ earned 150 total points
ID: 7141056
How about winipcfg /all . . . actually you dont care about the ppp adapter, that's probably your modem. You want the info on your network interface card in the client machine  . . .

Wait a minute, you're just bored and you are making this all up . . . right?

Steve
0
 
LVL 4

Author Comment

by:drcspy
ID: 7245191
well problem is solved ......sorta........cause my other puter died so I dont haev a network now.....      :-(  Anyway.......giving the points to steve for trying hardest and thanks to all
0

Featured Post

Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

Join & Write a Comment

Suggested Solutions

This is an article about my experiences with remote access to my clients (so that I may serve them) and eventually to my home office system via Radmin Remote Control. I have been using remote access for over 10 years and have been improving my metho…
Don’t let your business fall victim to the coming apocalypse – use our Survival Guide for the Fax Apocalypse to identify the risks and signs of zombie fax activities at your business.
Viewers will learn how to properly install and use Secure Shell (SSH) to work on projects or homework remotely. Download Secure Shell: Follow basic installation instructions: Open Secure Shell and use "Quick Connect" to enter credentials includi…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now