IE as default browser

Is it some easy wah to set IE as default browser.. if I type run http://www.experts-exchange.com
it fires up netscape :-( In properties for IE I have set it to check if it is the default browser.... But I never  got any question about it.
LVL 2
wqclatreAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
guidwayConnect With a Mentor Commented:
wqclatre,

Has any of this information helped you?

guidway
0
 
guidwayCommented:
Try this:

Start Internet Explorer. (You don't have to be connected).


On the Tools menu, click Internet Options.


In the Internet Options dialog box, click the Programs tab.


Select the Internet Explorer should check to see whether it is the default browser check box, if it isn't already selected.


Click OK and close Internet Explorer.


Start Internet Explorer again. If you get a message asking if you want to set Internet Explorer as the default, click Yes.

Hope this helps,

guidway
0
 
wqclatreAuthor Commented:
as I wrote before in my first message:

In properties for IE I have set it to check if it is the default browser.... But I never  got any question about it.
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
Adam LeinssSenior Desktop EngineerCommented:
Shut down all running programs.  Then go to Start/Run and type in regedit and press OK.  At this point you need to BACKUP THE REGISTRY!!  The registry key that controls whether or not IE asks about being the default browser is
located at

HKEY_USERS\.Default\Software\Microsoft\Internet Explorer\Main

You want to edit the Check_Associations string in the right panel.  You want to change the string value to Yes.  To do this, right click on Check_Associations and select Modify.  In the Edit String window under Value data, delete "no" and then type "yes."  Click OK then close the registry. Reboot, then the next time you open IE it will ask if you want it to be the default browser.

0
 
Adam LeinssSenior Desktop EngineerCommented:
BTW, if the key doesn't exist, create it
0
 
wqclatreAuthor Commented:
it exist and is already set to yes.

I guess that the only way to go is to remove keys for .html and .htm or replace the CLSID in the key for this file with the CLSID for MSIE
(and remove the keys for http and https.
0
 
guidwayCommented:
Did you reboot your computer after trying to set is as your default browser? Sometimes the screen won't appear until it is restarted.

guidway
0
 
wqclatreAuthor Commented:
It has been rebooted about 30 times since the first time I checked this registry key and that checkbox so....
(it took some time for me to get so irritated on netscape so I had to ask the question here)
0
 
guidwayCommented:
sorry about the first post. I thought that was something else.

guidway
0
 
guidwayCommented:
I guess the only way left (I can see) is probably to do like you said before and change the html and htm file associations from netscape to IE. It sounds like you already know how to do this so I won't post the info.

guidway
0
 
guidwayCommented:
In case you don't know, the easiest way to do this is right click on a htm file and select open With and click the IE program icon.

guidway
0
 
shadyrudyCommented:
0
 
shadyrudyCommented:
Or, in the netscape Preferences(I dont know what version you're using) pick advanced.
Then, look under system and uncheck html in all the options.
0
 
jmiller47Commented:
shadyrudy, welcome to EE! Please be respectful of other experts and please do not propose an answer until you are absolutely sure that this will fix the users problem. I have personally already posted step by step instructions as to the creation of a mirror. Whilst you have proposed an answer you have also locked the question so that no other experts may comment. Please post comments and if the user sees that it will fix their problems then they can accept it as an answer.
0
 
stevenlewisCommented:
The browser that comes up as your system's default can be a source of frustration, especially if you've switched sides at some point during the browser wars. Clicking on an HTML file in Windows Explorer, or sometimes even from links on a page you're already looking at, can open a browser other than you expect. Both Microsoft and Netscape browsers can each check to see which is the default browser and offer itself as the default. Both can also turn off this check, which presents a problem: If you want to change the default later on, how do you reenable the check?

If you are using Netscape Communicator 4.x, make sure you exit Communicator and all its components. Go to your personal profile directory (typically, C:Program filesNetscape UsersProfilename). Open the file Prefs.js in Notepad and change user_pref("browser.wfe.ignore_def_check", true) from "true" to "false." Save the file and exit the editor. The next time you load Communicator or any of its components, you will once again be asked whether you want to make it the default browser. This is fairly simple in Internet Explorer.

In IE3 or IE4, open Internet Options or Options (depending on the version you're using), located under the View menu (in IE5, Internet Options is under the Tools menu). On the Programs tab, click on the checkbox that says "Internet Explorer should check to see if it is the default browser." Now if IE is not the default browser, the program will ask you if you want to make it so.

also see here
http://support.microsoft.com/default.aspx?scid=kb;EN-US;q284456
0
 
Computer101Commented:
Please read below.

Proposed answer rejected

Computer101
E-E Moderator

 Comments
Comments are intended to be used as a collaboration tool. Many Experts choose to post their solutions as comments only.

Answers
An answer is a specific solution to a question and should be submitted if it will solve the questioner's problem and doesn't duplicate a previous comment.

Comment Vs. Answer
If you are unsure of your solution, post it as a comment. Members can accept comments as solutions and award you Expert Points for them.

For more tips on comments and answers, click here.
0
 
wqclatreAuthor Commented:
Sorry for my late comment... Have been at vacation.

No nothing helped me out. So I uninstalled Netscape. Uninstalled (made a step backwards ) IE (so I got the default that comes with NT again and then updated to the latest... Now thing works fine.
0
 
jmiller47Commented:
Can you either close this question, delete it, or award points?

thanks
0
 
guidwayCommented:
If it didn't help you why award me points? Wouldn't it have been less costly for you to have a mod delete it?

guidway
0
 
guidwayCommented:
Clarification: not that I'm trying to sound ungrateful by my last comment. Thank you, but you don'thave to waste points on something that didn't work for you.

guidway
0
 
Computer101Commented:
Recommend points refunded and placed in PAQ

Computer101
E-E Moderator
0
 
guidwayCommented:
That sounds good to me Computer101

guidway
0
 
Computer101Commented:
Points refunded, grade changed for PAQ

Computer101
E-E Moderator
0
 
wqclatreAuthor Commented:
THe reason that I gave the points to you is that I like to thank you for spending your time on trying to help me. Unfortanly I could not split the point to all of you that tries to help me so I gave them t o that person I thought has spended most time trying to help me out.

This is a wounderfoul place with a lot of nice persons trying to help people out.

Thanks again all of you for trying to help me out.
/wqclatre
0
 
guidwayCommented:
no problem, wqclatre

For future reference you can split points. To do this you need to post a 0 point question in the topic Community Support - http://www.experts-exchange.com/commspt/ and tell who you want to split points between and provide the link (URL) for the question so the mod can take care of it.

Again, I appreciate the offer for the points, but considering my comment was just one of many experts who tried to help I don't feel I deserve them any more than anyone else. Thanks anyway though,

guidway
0
 
newfonCommented:
Is this thread closed ? or Do I get any points if I answer the above question?
0
 
jamieligonCommented:
I was having this same problem and was able to fix it finally (at least under Windows XP)!

Under "Add/Remove Programs", click on "Set Program Access and Defaults".  From there, click the down arrow by "Custom", and choose Internet Explorer under "Choose a default Web browser".

Hope this helps....
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.