Solved

Mount smb share with special characters in name

Posted on 2002-07-11
2
1,927 Views
Last Modified: 2012-05-04
I need to mount an NT smb network share from Linux that has special characters (ampersand & and spaces) in the name.  

//server/a & bc

I can do this from a shell with quotes, as

mount -t smbfs "//server/a & bc" /mnt/mountat

but fstab will not accept such an entry:

"//server/a & bc" /mnt/mountat smbfs noauto 0 0

and I get a "bad line in fstab" error.  The man page for fstab states that a space can be escaped with its octal ASCII code \040, but when leaving the ampersand or using its octal ASCII code \046, a browser pops up in KDE looking for navigation.realnames.com. ?? So neither of the following work in fstab:

//server/a\040&\040bc    /mnt/mountat smbfs noauto 0 0
//server/a\040\046\040bc /mnt/mountat smbfs noauto 0 0

What format must I use in fstab to mount this share??  Thanks!
0
Comment
Question by:porear
2 Comments
 
LVL 1

Accepted Solution

by:
Techno__Mage earned 150 total points
ID: 7153474

I was able to successfully work the situation using your second format :  

//server/a\040\046\040bc /mnt/mountat smbfs noauto 0 0

You may or may not need to adjust the options column to something like "noauto,user,username=somewindowsuser"
0
 
LVL 5

Author Comment

by:porear
ID: 7155672
Actually, I left the details off on the original message, but I am using a credentials file so the form is

//server/a\040\046\040bc /mnt/mountat smbfs noauto, credentials=/root/credfile 0 0

I just tried this method again, and for some reason a browser is still popping up in KDE and trying to navigate to http://navigation.realnames.com/resolver.dll.  

I am trying to mount using a KDE desktop shortcut created by right clicking on the desktop, choosing "Create New" - "Hard Disc" and choosing the net mount point from the drop down list in the Device tab.

HOWEVER:  although the desktop shortcut does not show to be successfully mounted, I looked at my mountat directory, and it really was mounted. ????  Upon checking, the same was true when not escaping the ampersand, as

//server/a\040&\040bc /mnt/mountat smbfs noauto, credentials=/root/credfile 0 0

So... I apparently have a problem with the KDE mount shortcut method and special characters.  Thanks for the reply, I was doing better than I thought! :)
0

Featured Post

Three Reasons Why Backup is Strategic

Backup is strategic to your business because your data is strategic to your business. Without backup, your business will fail. This white paper explains why it is vital for you to design and immediately execute a backup strategy to protect 100 percent of your data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

rdate is a Linux command and the network time protocol for immediate date and time setup from another machine. The clocks are synchronized by entering rdate with the -s switch (command without switch just checks the time but does not set anything). …
Introduction We as admins face situation where we need to redirect websites to another. This may be required as a part of an upgrade keeping the old URL but website should be served from new URL. This document would brief you on different ways ca…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…

790 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question