Solved

Error "Directory is busy"

Posted on 2002-07-12
6
2,700 Views
Last Modified: 2007-12-19
Hi,
I'm currently working with Borland Delphi 5 and a standard shared database (Paradox).

That application is used by different users. When we used a build version of the program everything works fine but if I use the run command of the development tool I have a "Directory is busy" error.

I've already tried to delete the pdoxusrs.net file, I'm using a TSession with private and net directories. I'm a bit lost...

Could U help me? Thx a lot!
0
Comment
Question by:usa4manu
  • 5
6 Comments
 
LVL 27

Expert Comment

by:kretzschmar
ID: 7148541
table is opened exclusive by another instance
or local share property in the bde-admin tool
did not have a proper value


if the problem is the .net file,
then a message like
directory is controlled by another .net file
coems up

but i guess you open the table exclusive in the ide,
so that the running insatnce started from within the ide
cannot open the table

meikl ;-)
0
 
LVL 27

Expert Comment

by:kretzschmar
ID: 7148545
appendix:

delete the .lck files,
if definivly nobody accesses the database-directory

meikl ;-)
0
 
LVL 27

Expert Comment

by:kretzschmar
ID: 7148550
and next point

private-dirs cannot shared by different sessions,
if local share is set to false

meikl ;-)
0
Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

 
LVL 27

Accepted Solution

by:
kretzschmar earned 500 total points
ID: 7148558
advice

keep the tables in the ide closed,
and open the tables at appstart
(in the formcreate-event of
the mainform for example)

then your problem should be gone

or
adjust the local share in
the bde-admin to the other value

hope this helps

meikl ;-)
0
 

Author Comment

by:usa4manu
ID: 7148573
In fact I've just put the TSession.active to false and add a "logging" button to put the session active once the form loaded and it's working... Very strange... Do U have an idea why?

I haven't found any lck file.

Thx for the quick answer and hit the points ;-)
0
 
LVL 27

Expert Comment

by:kretzschmar
ID: 7148579
thats sounds really a bit weird.

but i think its a problem of the private-dir,
which was just reserved by the open tsession in the ide.

thanks for the points :-)

meikl ;-)
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Send message from delphi to whatsapp, is it possible? 3 1,193
Comparing dates in Delphi. Greater than/ Less than 3 119
Correct Component for Shopping Cart. 2 96
Delphi 2 51
Creating an auto free TStringList The TStringList is a basic and frequently used object in Delphi. On many occasions, you may want to create a temporary list, process some items in the list and be done with the list. In such cases, you have to…
Introduction Raise your hands if you were as upset with FireMonkey as I was when I discovered that there was no TListview.  I use TListView in almost all of my applications I've written, and I was not going to compromise by resorting to TStringGrid…
This tutorial gives a high-level tour of the interface of Marketo (a marketing automation tool to help businesses track and engage prospective customers and drive them to purchase). You will see the main areas including Marketing Activities, Design …
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…

863 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

26 Experts available now in Live!

Get 1:1 Help Now