[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

Win2k Adv Service Pack

Posted on 2002-07-13
12
Medium Priority
?
167 Views
Last Modified: 2010-04-13
I installed Windows 2000 service pack 2 on my windows 2000 advanced server machine and restarted the computer after installation was complete and then all of a sudden my ASP pages does not work.

HTML and CGI are working so it can't be the execute permissions.

Need an answer ASAP.

Thanks
0
Comment
Question by:ahm11
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
  • 2
  • +2
12 Comments
 
LVL 6

Expert Comment

by:st_steve
ID: 7151997
Did you check whether there were any post-SP2 patches/fixes for IIS5?

Did you run Windows Update?

When you say your ASPs don't work, did the server stop parsing the ASP files and gives out the ASP codes to the browsers? or what happenned?
0
 

Author Comment

by:ahm11
ID: 7152150
I get Internal Server Error 500 when I try to view them.
0
 
LVL 6

Expert Comment

by:st_steve
ID: 7152170
Anything relating to II5 in the event logs?

Can you access the ASPs locally? I mean if you use the browser on the server and go to:

http://localhost

can you access the the files then?
0
Enroll in October's Free Course of the Month

Do you work with and analyze data? Enroll in October's Course of the Month for 7+ hours of SQL training, allowing you to quickly and efficiently store or retrieve data. It's free for Premium Members, Team Accounts, and Qualified Experts!

 

Author Comment

by:ahm11
ID: 7152179
Nope, nothing works, I tryed openning the pages from a netwrok computer but it still shows HTTP 500 internal server error.
0
 
LVL 3

Expert Comment

by:tfl
ID: 7152538
The obvious thing to try is to remove SP2 and see if the problem goes away.

Try that and see what happens.
0
 
LVL 7

Expert Comment

by:jatcan
ID: 7152567
This might help you:

INFO: Performance Enhancements in COM+ After Windows 2000 SP1 (Q269477)

--------------------------------------------------------------------------------
The information in this article applies to:


Microsoft Windows 2000 SP1 , Professional
Microsoft Windows 2000 SP1 , Server
Microsoft Windows 2000 SP1 , Advanced Server


SUMMARY
Several performance enhancements are implemented in COM+ following the release of Windows 2000 Service Pack 1. These enhancements reduce lock contention and optimize the COM+ single-threaded apartment thread pool. These improvements are most apparent with an Active Server Pages (ASP) and/or COM+ application that is running on a computer that has multiple CPUs. For additional information about the latest service pack for Windows 2000, click the article number below to view the article in the Microsoft Knowledge Base:

Q260910 How to Obtain the Latest Windows 2000 Service Pack



REFERENCES
Q268843 INFO: Post Windows 2000 Service Pack 1 COM+ Rollup Hotfix 1 Is Available

Go here to get the Hot fixes(individual downloads):mostly COM and ASP related:

http://support.microsoft.com/default.aspx?scid=kb;en-us;Q268843

Go here to download Windows Service Pak 2 Service Release 1 (Hot FIx's):

http://support.microsoft.com/default.aspx?scid=http://support.microsoft.com/support/ServicePacks/Windows/2000/Win2000_Post-SP2_Hotfixes.asp
0
 

Author Comment

by:ahm11
ID: 7154795
Nothing works still, If I remove "Show friendly errors from the web browsers options, I get the error: "The remote procedure call failed.".

I am not sure what could be causing it but that might help you guys to figure it out.
0
 
LVL 7

Expert Comment

by:jatcan
ID: 7154884
Did you download and install Service Pak 2 Service Release 1?

Cheers.
0
 

Expert Comment

by:AdamMcLaurin
ID: 7154912
I had this exact same problem with Windows 2000 Server .. I fought with it for weeks before finally fixing it .. The asp.dll (I think in /system32) got corrupted somehow .. Try removing it and replacing it with a copy you know is good .. Also try deleting the ASP mapping in IIS and re-adding it ..
0
 
LVL 7

Accepted Solution

by:
jatcan earned 200 total points
ID: 7154931
0
 

Author Comment

by:ahm11
ID: 7157520
Thanks, the links were great.

Thank you all for your help.

Thanks
0
 
LVL 7

Expert Comment

by:jatcan
ID: 7157574
Toldja! Glad you got your problem resolved.

Cheers.
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
With so many activities to perform, Exchange administrators are always busy in organizations. If everything, including Exchange Servers, Outlook clients, and Office 365 accounts work without any issues, they can sit and relax. But unfortunately, it…
In response to a need for security and privacy, and to continue fostering an environment members can turn to for support, solutions, and education, Experts Exchange has created anonymous question capabilities. This new feature is available to our Pr…
Please read the paragraph below before following the instructions in the video — there are important caveats in the paragraph that I did not mention in the video. If your PaperPort 12 or PaperPort 14 is failing to start, or crashing, or hanging, …
Suggested Courses

656 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question