Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection.

When I am using NT Security to conect to a sqlserver database from a vb.net form using asp I get the following error:

Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection.

How do I fix this?



 
kenmckAsked:
Who is Participating?
 
kpkpConnect With a Mentor Commented:
What type of connection do you _want_ to use?  If you want to specify and account to use in the connecition string, then (assuming this is a SQLServer) use:

Dim strConn As String = "data source=bkrenf;initial catalog=discovery;user id=sa;password=lob"


are you assigning the connecion string to the SqlConnection object?
0
 
CJ_SCommented:
Could you show your connectionstring?

All you need are some additional items.

CJ
0
 
kenmckAuthor Commented:
   <sessionState
            mode="InProc"
            stateConnectionString="tcpip=127.0.0.1:42424"
            sqlConnectionString="data source=127.0.0.1;user id=sa;password=lob"
            cookieless="false"
            timeout="20"
    />


Thanks,
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 
CJ_SCommented:
I do not suggest using the sa user for it. And you have not specified a database.

Change it to the following:

"data source=localhost;integrated security=sspi;database=yourdatabase"

Now the user account that is being used to access the database is the ASPNET user (remember you are using WinNT security).

So you will need to give that user access to the database within SQL Server.

You know how to do that?

CJ
0
 
CJ_SCommented:
Oh also:

"data source=localhost;integrated security=sspi;database=yourdatabase;Trusted_Connection=yes"

0
 
kenmckAuthor Commented:
I have set up my connection string to the following:

Dim strConn As String = "server=bkrenf;database=discovery;uid=sa;pwd=lob"

and I get connected.

When I use

Dim strConn As String = "server=bkrenf;integrated security=sspi;database=discovery;Trusted_Connection=yes"

I get an error message "Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection".

Any idea why?
0
 
kenmckAuthor Commented:
I have set up my connection string to the following:

Dim strConn As String = "server=bkrenf;database=discovery;uid=sa;pwd=lob"

and I get connected.

When I use

Dim strConn As String = "server=bkrenf;integrated security=sspi;database=discovery;Trusted_Connection=yes"

I get an error message "Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection".

Any idea why?
0
 
kenmckAuthor Commented:
I have set up my connection string to the following:

Dim strConn As String = "server=bkrenf;database=discovery;uid=sa;pwd=lob"

and I get connected.

When I use

Dim strConn As String = "server=bkrenf;integrated security=sspi;database=discovery;Trusted_Connection=yes"

I get an error message "Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection".

Any idea why?
0
 
CJ_SCommented:
I think because of the integrated security item.

The first error is because you have not provided a default database you want to connect to. I'd still say that the Trusted_Connection property should be in there since it is a trusted connection. And if it is you will encounter an error when you ommit that item.

I have no idea why your first sample works without the Trusted_Connection item. :-/

CJ
0
 
kenmckAuthor Commented:
Nope still cannot get this to work. How do I use a Trusted Connection or NT Security to connect?

Have you got any examples?
0
 
CJ_SCommented:
I used the following:

Provider=sqloledb;initial catalog=MYDATABASE;Trusted_Connection=yes;data source=(local);Connect Timeout=20


However, searching for the error you got you get to some pages that explain this error in more detail:

"Trusted_Connection=true;database=MYDATABASE;server=(local)"
0
 
naveenkohliCommented:
Try setting the impersonation to true in web.config file. By setting it to true, you will be connecting to SQL server under the context of windows login that is logged oonto clinet machine. Otherwise you are connecting as ASPNET account.

<identity impersonate="true">
0
 
kenmckAuthor Commented:
Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'

is now my error message.

Help!
0
 
kenmckAuthor Commented:
Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'

is now my error message.

Help!
0
 
kaytrimCommented:
Sorry to barge in on the experts here but here is a sample connection string that I use to asscess from ASP.NET

"server=servername; trusted_connection=false; uid=username; pwd=password; Database=databasename"

The key is that the trusted connection can only be true of the sql server and the app server are the same machine.

Micahel
0
All Courses

From novice to tech pro — start learning today.