Solved

Unable to contact your DHCP Server in Windows XP  Professional

Posted on 2002-07-15
20
1,388 Views
Last Modified: 2008-02-01
I run two laptops with Windows XP Professional on both.
They are connected by two 3 COM PMCMIA network cards 10-100 Mb/s.
The hardware part is OK.
The first laptop has IP address 169.254.101.94 with mask 255.255.0.0
The second laptop has IP address 169.254.5.217 with mask 255.255.0.0
The first three sets of digits in the IP addresses being different, I tried to renew the IP addresses.
Typing ipconfig /renew on either of the laptops brings a popup:
"An error occured while renewing interface Local Area Connection: unable to contact your DHCP server".
Thank you for your help,
dbessis
0
Comment
Question by:dbessis
  • 7
  • 5
  • 2
  • +3
20 Comments
 
LVL 2

Expert Comment

by:edmonds_robert
ID: 7155012
Don't take offense if this is a stupid question, but are you running the DHCP service anywhere?  Is this your home network, office network, any servers?  What is the network situation?
0
 
LVL 63

Expert Comment

by:SysExpert
ID: 7155039
169.254.x.x are IP addresses that MS uses when it can not find a DHCP server.

If you do not have one, use static addresses.

If you are trying to connect these two laptops together, use a CAT 5 CROSSOVer cable, and static IP's, with the same workgroup name.
For more info see:
    http://www.practicallynetworked.com/

http://www.practicallynetworked.com/howto/

http://www.la-cable.com/how_to_network_pcs.htm  - Just 2 computers for file transfers.

http://www.practicallynetworked.com/sharing/ics/ics.htm
http://www.practicallynetworked.com/sharing/specialapps.htm
Need to map the port, as you are using ICS (network address translation)
  http://www.practicallynetworked.com/sharing/ics/icsconfig_maps.htm
  port list
  http://www.practicallynetworked.com/sharing/app_port_list.htm
http://www.sohointer.net/howto/
http://www.sohointer.net/top/kwe-faq.htm
http://www.onecomputerguy.com/networking/peer.htm
http://www.dslreports.com/information/rated/PPPoE
http://www.microsoft.com/windowsME/using/homenetworking/articles/default.asp
 www.speedguide.net
http://www.cert.org/tech_tips/home_networks.html Firewall and security for home and offices
Test firewall ports  and port blocking http://grc.com/
http://www.nipc.gov/warnings/computertips.htm

I hope this helps !
0
 
LVL 2

Expert Comment

by:edmonds_robert
ID: 7155537
Sorry to do this here, but Sysexpert, are all these links you always give in your favorites folder?  If so, I would really like a copy of them.  Would that be possible?
0
 
LVL 63

Expert Comment

by:SysExpert
ID: 7155868
edmonds_robert : I do not use IE often, mostly Netscape, and I have about 5 MB of pure text files that I have collated over the past few years.
Sorry, this is not something I am willing to part with at this point.

0
 
LVL 8

Expert Comment

by:scraig84
ID: 7157150
There is also nothing wrong with using the auto-generated IP addresses that you already have - assuming you only want those two machines to talk to each other and everything else is in working order.

Can you give more info about your environment, what you are trying to do, and what your problem is?
0
 

Author Comment

by:dbessis
ID: 7157321
scraig84,
I read that it is mandatory that the first three sets of numbers in the IP address be the same. In my case only the first two sets are the same.
dbessis
0
 
LVL 8

Expert Comment

by:scraig84
ID: 7157332
That is completely dependant on your subnet mask.  What you read is completely false.  Because your mask reads 255.255.0.0, then only the first two octets needs to be alike.  Microsoft made this auto addressing scheme for small networks that have no DHCP server for a very simple auto-addressing tool.  It doesn't work well in all cases, such as those where other options need to be configured such as a default gateway or DNS servers, but in real simple small networks where these are not issues, it will work fine.
0
 

Author Comment

by:dbessis
ID: 7157593
SysExpert,
The info you gave me seems to refer only to Windows 98. In particular, I do not have anymore NetBEUI on XP.
I put static addresses on TC/IP to no avail. What DNS address should I use when connecting ONLY two computers for file and printer sharing?
It seems that the problem has to do with "permissions".
I get popups asking me to check that the permissions are set correctly.How do I set the permissions to give access to the computer in Windows XP?
Thank you for your help,
dbessis
0
 
LVL 24

Expert Comment

by:SunBow
ID: 7158316
> unable to contact your DHCP server

ditto edmonds_robert

> The first three sets of digits in the IP addresses being different, I tried to renew the IP addresses.

?
(ditto scraig84)

>  do not use IE often, mostly Netscape

I still use term "bookmark", and yearn to tell people to select a menu option available <ugh> but they only have IE <sigh>

> What DNS address

Irrelevant, to dhcp, to subnetting, to tcp, ... and all bets are that you have no DNS server either, and do not need one

> printer sharing?

we often assign it an IP address. you need not

> to check that the permissions are set correctly.

ah, the gist. You need to address security and authorization levels of the OS - mustn't let just anyone tamper with system

In my setups, I always have same ID and password on every system. That way, when I ask for access, I have less trouble getting authenticated.

My preference for files is to map them to drive letter from remote. With no internet, you could use windows explorer to add a new map of, say, drive letter 's' to a space on the other system. You should use the computername that you gave machine at install time. You need backslashes before and after, and an extra one to begin with, such as:

\\my-computer-name\c$

This gives access to whole drive, can make you feel insecure, so some people create file shares, then map to

\\my-computer-name\my_share_name

to only have a subdirectory of files for moving data between computers

don't neglect to check the box for saving the mapping(s) between powerup cycles and logins.

note that my-computer-name goes back to MS' LAN prior to tcp and internetworking, that is uses and needs netBios (not tcp) so it cares not about subnetting

For printing, you can usually click on the remote for the network to list machines, then  select printer share from machines found.

To be permitted access is the purview of the administrator of the PC. To review permissions, look at properties, this could be right click on the object, when displayed. Windows explorer has good drill down menus for that. Make sure you don't have a share that isn't shared, or allows no one access. What good would a share be that did that? I dunno. But with only two users, you might as well allow everyone access to do everything and be done with it. Skip anything special about requiring extra permissions, or domains or profiles, scripts, or anything. If that has not already been done.

(I believe that in XP you can now substitute the IP address for the computer-name, but why bother, since you have it designated as subject to change)

-
Ans> Map Drive!
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 63

Expert Comment

by:SysExpert
ID: 7158402
Sharing a drive drive share  NT shares  NT file sharing
Permissions are set in two seperate places in NT and win2k/XP.

   1) There is a set of permissions on the share it self for access outside the local computer.

  2) There are file/dir permissions on the hard drive for local and remote access.

                   right click on the drive/file, choose properties - security - permissions. Give the person/goup full
                   access.

3) delete all the *.pwl files in the \windows dir on win98. Your next login will recreate them. reboot
                   !!
OK, you need to add a new share rather than the default administrative share.
                   Add the new share -( there is a new share button at the bottom )  call it C-drv, set the permissions,
                   and that should solve the problem.
1) Add a new user on NT.
               2) Try loggin into a win98 station using this new user and password.

               See if you can access the NT machine.

               Please note that the default shares on NT are not accessible, you have to create NEW shares !
Other options is to enable the guest account, but this is a security breach usually.

                   I hope this helps !

From: stevenlewis     Date: 09/29/2001 06:49PM
              OK, the "access denied" gives us a clue.
              Log on to the 98 boxes using the client for M$ networks as the primary logon, this creates the access
              token that the w2k box needs. then on the share(s) you have to allow the guest account access to the
              share(s), in the permissions, allow everyone full control
              also enable the guest account on the w2k box
              Click on Start/Programs/Administrative Tools/Computer Management. Look for Local Users and Groups       under   System Tools (on the left side), and expand it to show the two folders, Users and Groups. Highlight       the Users folder, and then you'll see the Administrator and Guest account. Highlight the Guest account,               and click on Action. Go down to properties, and on the General Tab for Guest Properties, you'll see            the box checked for Account is Disabled. Uncheck it
-----------------------
0
 

Author Comment

by:dbessis
ID: 7159692
SysExpert,
I am using Windows XP on both computers. All your instructions seem to refer to Windows 98 and I have NO Windows 98 of any kind to play with.

Stevenlewis,
In XP going to the Guest account opens ONLY the following tabs: General, Member of and Profile. There is NO "Action" anywhere. This is different from Windows 2000.

More information.
1. I can see the LEDs on the hub to which the computers are connected flickering when I click on "Computers near me".
2. I get a popup: "workgroup  @home is not accessible. You might not have permission to use this network resource. Contact the administrator of this server. The list of servers for this workgroup is not available".

Thank you for your hrelp,
dbessis
0
 
LVL 63

Expert Comment

by:SysExpert
ID: 7161124
OK.
0) In the TCP/IP settings, use Static addresses in the
192.168.0.x range with a 255.255.255.o mask.
Do not use the automaticly obtain IP address !!

1) Create 2 identical accounts on each machine.

2) Login on both machines using the new accounts.

3) Make sure you have a shared directory available on each machine and set the permissions so that the user you created has full control. Right click on a directory and check the permissions Tab. Also make sure they are shared with a simple short name.

4) Try to access one machine using
Start- run
\\computername\sharename

This should give you access.
If not, please post the exact error messages.

I hope this helps !
0
 

Author Comment

by:dbessis
ID: 7167976
SysExpert
I have set TCP/IP as you told me on both computers. I can check it is OK by running ipconfig /all. Also I can see both computers in Network Neighborhood. I still cannot connect because I get "@home workgroup cannot be reached. You must set permissions."
I have no idea how to "create an account" on Windows XP.
For the moment, I have a common Workgroup for both computers called "@home".
Thank you for your help,
dbessis  
0
 
LVL 63

Expert Comment

by:SysExpert
ID: 7168095
I would check the Help option from the Start button.
look for help on
user accounts

I hope this helps !
0
 

Expert Comment

by:eliallen
ID: 7170241
By default WXP P use "simple file sharing”, to me that is giving permission. but if you want to change it, go to my computer ..tools..folder options..view.. scroll to bottom  and uncheck "use simple file sharing" Simple file sharing works for me. I  duplicated your error  message by unplugging  the network cable from my adsl modem. and when I connected back it worked OK. I would remove all network connections on both computers  and start all over.
0
 

Author Comment

by:dbessis
ID: 7183535
eliallen,
I think I start to understand what is going on.
Previously, I had a router connected to the cable and behind the router the two laptops belonging to a workgroup called "@home".
I moved overseas and I have no more cable connection. I am still trying to connect the two laptops through a hub. The computers ask for permission for the workgroup "@home" all the time.
Is it possible to change the accounts in such a way that they do not belong anymore to any workgroup? I tried to do it using the help, but it does not seem possible.
Thank you,
dbessis
0
 

Author Comment

by:dbessis
ID: 7198986
HOW do you change the workgroup to which belongs the administrator in Windows XP????
Thank you,
dbessis
0
 

Accepted Solution

by:
eliallen earned 100 total points
ID: 7201380
Control Panel, System, Computer Name, Click on Change.
0
 

Author Comment

by:dbessis
ID: 7395012
To all

Finally, I was able to solve this puzzle with the help of a Microsoft Expert engineer.

After one week of research and various trials, he told me to change the computers names and the workgroup name.
As soon as I did it, all problems evaporated.

Thank you for your help,

dbessis
0

Featured Post

Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Don’t let your business fall victim to the coming apocalypse – use our Survival Guide for the Fax Apocalypse to identify the risks and signs of zombie fax activities at your business.
If you're not part of the solution, you're part of the problem.   Tips on how to secure IoT devices, even the dumbest ones, so they can't be used as part of a DDoS botnet.  Use PRTG Network Monitor as one of the building blocks, to detect unusual…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now