Running *really" short on DMA buffers

Posted on 2002-07-15
Last Modified: 2010-04-20
This kernel message has begun to appear since updating from 2.4.18-4 to 2.4.18-5:
Warning - running *really* short on DMA buffers
I found this message in source file scsi_merge.c
Is this tunable type issue, or do I report a bug?
Question by:medent
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
LVL 40

Expert Comment

ID: 7155376
How much physical memory do you have in the system. It's possible that the problem could be a general memoryt shortage and not a kernel/driver problem.

Expert Comment

ID: 7156630
I hope you are not using any ISA device. ISA devices do not use the standard DMA channels.
run the command $rcidedma status to check if DMA is working or not.

Author Comment

ID: 7156899
rcidedma? I am running this part of a package?
amount of memory? On one server 512Megs, and 640Megs on the other server with this error (both 1Ghz IBM intel). The problem seems to happen during large file transfers (via rcp), with nothing else happening on the machine.
Learn how to optimize MySQL for your business need

With the increasing importance of apps & networks in both business & personal interconnections, perfor. has become one of the key metrics of successful communication. This ebook is a hands-on business-case-driven guide to understanding MySQL query parameter tuning & database perf

LVL 40

Accepted Solution

jlevie earned 250 total points
ID: 7158710
It seems rather obvious to me that the SCSI system in the 18-5 kernel is on the chatty side, compared to previous kernel versions. It may well be that nothing is wrong and that you are just seeing the increased verbosity of the driver.

The way I read the code it looks like this is more informative than an error. I think the message pops out when the SCSI subsystem is busy (lots of buffers in use) and it wants to coalese a scatter-gather IO into a single request. If that analysis is correct it just means that the SCSI subsystem is running pretty much full bore for the controllers and devices that it has.

Author Comment

ID: 7159247
Excellent point. I am seeing a considerable amount of annoying informational scsi messaging that I did not see before. I will try to report via bugzilla (redhat) for wahtever that is worth. PS- I've deselected scsi verbosity from the kernel options, but no diff. Any tips on where to find out if "bugs" like this are being worked on?
LVL 40

Expert Comment

ID: 7161145
I'll ask around and see if I can turn up anything.

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Over the last ten+ years I have seen Linux configuration tools come and go. In the early days there was the tried-and-true, all-powerful linuxconf that many thought would remain the one and only Linux configuration tool until the end of times. Well,…
The purpose of this article is to demonstrate how we can use conditional statements using Python.
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses

623 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question