NAT excruciatingly slow

I have a Windows2000 server attached to a cable modem on one NIC and another computer (via DLink switch) on another NIC.  NAT is configured and works, however it is so slow that the web browser on the client machine often times out.  This is from all web pages, not any one in particular.  Web from the server is the normal fast speed and the CPU load is almost non-existant while there is plenty of free physical RAM.

Any idea what setting(s) on the server or client can be twiggled to increase performance?
LVL 13
magarityAsked:
Who is Participating?
 
mikecrConnect With a Mentor Commented:
Here is some helpful information that will get you fixed up.

http://support.microsoft.com/search/preview.aspx?scid=kb;en-us;Q299801

http://support.microsoft.com/search/preview.aspx?scid=kb;en-us;Q310357

Also, make sure that you add a static route in RRAS on the server for the default route to the internet. Pick your external lan card from the drop down box and fill in the information.

Destination 0.0.0.0
network mask 0.0.0.0
gateway or next hop address "10.1.1.1"
metric 1
0
 
SysExpertCommented:
1) Check all your event logs on the server and client.

2) Check the DNS settings and gateways.

3) Check the NIC bindings on the server. remove any unused protocols etc.

I hope this helps !
0
 
SysExpertCommented:
Also check the proxy settings - remove /disable the auto option.

If you are using ICS, this can also slow things down.

Update the NIC drivers on the server also.

A cheap 4 port router with NAT  is only about $50 if you watch the sales.

I hope this helps !
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
magarityAuthor Commented:
"1) Check all your event logs on the server and client."

In the server's event log:

"Unable to add the interface Internal with the Router Manager for the IP protocol. The following error occurred: The parameter is incorrect."

I think this mught be the problem.  What the heck is it whining about here and any idea how to fix it?

"2) Check the DNS settings and gateways."

These are correct as far as I can tell.

"3) Check the NIC bindings on the server. remove any unused protocols etc."

Ah, already did that.  Only TCPIP is installed.  Client for Windows Networking is installed only on the two internal NICs so I can share files.

"If you are using ICS, this can also slow things down"

Nope, NAT instead of ICS.  ICS doesn't work because of the goofy way MSN DSL is set up.

"A cheap 4 port router with NAT  is only about $50 if you watch the sales."

I'm not going to use a cheap NAT router if someone gives it to me.  This project was assembled as part studying for MCSE, so some plug and play widget is less than useless.  Unfortunately, my study guides aren't covering this slowdown symptom.

Thanks so far, any ideas about that server log?
0
 
magarityAuthor Commented:
Ping from client to DSL modem (via server) returns a TTL of 254.  Ping from client to server returns a TTL of 128.  Where did the extra 126 hops come from?  Am I reading this correctly?
0
 
stevenlewisCommented:
no, TTL is time to live, not the # of hops
use tracert to check the # of hops
0
 
magarityAuthor Commented:
I'm pretty sure TTL refers to hops when ping uses it.

One other strange thing, nslookup on the client says there are no DNS servers.  But it resolves names anyway.
0
 
SysExpertCommented:
Are you running ISA ? If so then disable it for now, or set up the LAT tables if needed.

Try to check the event errors at eventid.com and the MS site.

I hope this helps !

0
 
Steve JenningsIT ManagerCommented:
The TTL on pings is set by the local device and can be configured. If a ping starts out with a TTL of 254 then it can make 254 hops before it dies. Some unix boxes use 128, some use 64, W2K uses 254 . . . the TTL gets decremented by 1 for each hop that it makes.

By the way, how do you know NAT is working? If you cant get a web page back . . . that sounds broken to me.

Not all DNSs are configured to respond to nslookup commands.

Steve
0
 
magarityAuthor Commented:
mikecr,
Thanks for those links, info there helped.  I hadn't know about the checkbox for name resolution in the NAT properties.  That seems to have helped.

I tried adding the static link but that caused it to stop working.  I take it the 10.1.1.1 IP was supposed to be the IP of the DSL modem, yes?  What about the 0.0.0.0 numbers?  Leave those as-is?  I left them and put in the DSL IP and the client didn't get anything.
0
 
mikecrCommented:
The DSL modem doesn't get an IP address, I'm just assuming, your machine gets an IP address. So look at the gateway that gets provided in your IP configuration and use it as your next hop or gateway when you configure your default route. The 10.1.1.1 would represent your next hop out which would be the gateway provided by the DHCP that your machine gets. This way all traffic hitting the box will be routed out onto the internet by default if it has no other specific route in the routing table for it.

0.0.0.0 0.0.0.0 10.1.1.1 will be your default route, where 10.1.1.1 is the gateway or next hop according to your IP configuration.
0
 
mikecrCommented:
Oh, if I'm repeating myself I apologize, just make sure that you use the servers internal IP address as the default gateway for any clients that you have on the network wishing to get to the internet.
0
 
magarityAuthor Commented:
Whups, just noticed this question still open...  I don't recall the fix anymore but since I left a note here that the links from mikecr were helpful, I'll award the answer to that comment.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.