Solved

DOS Screen When Compiling???

Posted on 2002-07-19
3
166 Views
Last Modified: 2013-11-20

I am not sure what I changed or installed recently, but now when I have Visual C++ open and try to compile a program, while compiling it goes into a blank DOS screen then when it totally finishes compiling all programs it returns back to the Windows screen showing any error messages ...etc when before it would stay in Windows and it would show the build process in the output panel of Visual C++.

I remember I had this once back in a long time, but can't remember what I did to resolve it.  I thought I would look for a solution before re-installing.  I am not sure if that will even resolve the problem.

I am running VC++ 6.0 on WinXP.

Many thanks for any help with this regard.
0
Comment
Question by:u1
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 9

Expert Comment

by:BeyondWu
ID: 7168466
Maybe the cl.exe has the full-screen property.
Try to run cl.exe in the RUN dialogbox,
type "cl /? |more" to pause the cl.exe to terminate.
then right click the button on the taskbar and try to change the property of this type dos-window. If the "display options" is full-screen then change it to windows for all window with the same title.

Hope this help you.
0
 
LVL 3

Accepted Solution

by:
tdaoud earned 200 total points
ID: 7168735
I had this problem once and it is because of the program vcspawn that VC++ runs in the background.

To solve the problem you need to set the properties of vcspawn.exe to window instead of full screen.  You can change the settings from the Registry or from the program itself.  I will show you the easier way unless you have a fast machine, then yo may have trouble doing it.

Open up a somehow big project and do a Re-Build All command so it will take time while compiling all files.  Once it starts and the screen goes blank, quickly press CTRL+ESC to go back to windows and you will find on the taskbar the button for vcspawn.  Quickly right click on it and change the screen option to window instead of full screen.  That should do it for you if your problem is with vcspawn as was my problem.  VCSpawn is used in the background and usually doesn't appear on the taskbar with the compiler, linker, and other VC++ commands.

Tarik
0
 

Author Comment

by:u1
ID: 7168770
Perfect.  This is exactly what my problem was and it solved it.

Many thanks.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article, I'll describe -- and show pictures of -- some of the significant additions that have been made available to programmers in the MFC Feature Pack for Visual C++ 2008.  These same feature are in the MFC libraries that come with Visual …
Introduction: The undo support, implementing a stack. Continuing from the eigth article about sudoku.   We need a mechanism to keep track of the digits entered so as to implement an undo mechanism.  This should be a ‘Last In First Out’ collec…
This video will show you how to get GIT to work in Eclipse.   It will walk you through how to install the EGit plugin in eclipse and how to checkout an existing repository.
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…

695 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question