Solved

Help me stopping interdev interfering with my javascript/asp/html

Posted on 2002-07-22
8
177 Views
Last Modified: 2013-12-24
Hello I have slight problem with interdev which cost me 30 works of hour already.

The problem is that I have an asp file which generates javascript for a cross-browsing application. In each browser the generated scripts are slightly different.
When I open this file with interdev it automatically changes my javascripts.

It replaces f.e. " to &quot;, < to &gt;
pieces of script like:
var foo;
for (foo, foo < 10, foo++) {
if (foo == 5) {
  alert("foo")
 }
}
is replaced in something like:
var foo;for (foo, foo &gt; 10, foo++) {if (foo ="=" "5") { alert &quot;foo&quot;) }}

Please help me stop this evil IDE from doing this!
0
Comment
Question by:rdno
8 Comments
 
LVL 12

Expert Comment

by:Wouter Boevink
ID: 7169003
I've never had this problem. Whcih version of interdev are you using?

Is the script between

<script language=javascipt>
</script>

tags?

Can you show me the page?
0
 

Author Comment

by:rdno
ID: 7169217
yes,

I have tried to change script in <%="<scr" & "ipt language=""javascript"">"%>

but even that did not work unfortunatly it didn't work!
0
 
LVL 20

Accepted Solution

by:
hes earned 100 total points
ID: 7170267
Change the default editor for those files to Source Code (Text) Editor, the HTML editor in Interdev treats the code it is converting as if it had been cut and pasted. In which case unless you click on Paste as HTML it automatically converts all reserved characters to what you see. To change the default editor open the file, right click on it in the Project Explorer, click on Open With then select Source Code and set as the default. Close the file(do not save) then re open it.
0
 

Expert Comment

by:merlinb
ID: 7437352
Its not VI doing this.  If you think its that evil then use notepad.
If you copy-paste text into VI, it will do this translation UNLESS you use the Edit/Paste-As-HTML menu option, in which case it is inserted unchanged.
0
 

Expert Comment

by:jumprooster
ID: 7518402
When you paste your JavaScript in VI, like from a web page or MSDN Help, right click the HTML Editor in VI and don't select the simple paste but go down a little furthur and select Paste-As-HTML.

This won't give you another type of code for characters, just the JavaScript as it's seen in an HTML page.

I've had this problem.
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

When setting up new project requests for our site, one of the most powerful tools our team has available to use is Axure (http://www.axure.com/). It’s a tool for creating software and web prototypes that can function and interact as if it were the a…
Introduction In this tutorial, I'll explain how to create an animated progress meter in a wireframe prototype developed using Axure RP 7.0 - a leading prototyping tool for designing web sites and software. (For more information about Axure and gett…
The purpose of this video is to demonstrate how to make a WordPress Site faster and smaller in size by cleaning up the database. This will be demonstrated using a Windows 8 PC. Plugin WP Optimize will be used. Go to your WordPress login page. T…
The purpose of this video is to demonstrate how to properly insert a Vimeo Video into a WordPress site or Blog. This will be demonstrated using a Windows 8 PC. Go to your WordPress login page. This will look like the following: mywebsite.com/wp…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now