Hubs to switch problems

Our company had several hubs, and recently got rid of the hubs and put a level 3 switch. We have about 100 computers that connects to a Windows NT 4.0(SQL Server 7.0) server. When we had hubs they were connecting fine. But after we put the switch they could't connect. An outside company installed the switch for us, so none of us know what they did. Since production was down for a while we tried putting lmhosts file on a machine and it worked. So we installed lmhosts file on every machine. But I don't see why you need lmhosts file on a LAN. The problem we have now is the PC's cannot be rebooted or shut down because it about 3 - 5 reboots to connect to the NT Server. On some machines thats about 30 minutes. Does anybody know what the problem is?

I am a programmer and know nothing about NT or switches. But I am directly affected by this change, and all my programs access the SQL Server.
shamifAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
edmonds_robertConnect With a Mentor Commented:
You'll need a little more information, but I think the problem is going to end up being something having to do with the network protocols that are being used on your LAN.  You need an LMHOSTS file on your LAN if you are not using any WINS servers to do NetBIOS name resolution.  WINS is a service that runs on the NT server that resolves NetBIOS names to IP addresses.  Do you have access to the NT server?  What IP addresses are you using on your LAN?  
What kind of layer 3 switch is it?  
Get as much info as you can, and we will get you working.
One piece of advice I will add, don't ask those same people back to do any more network consulting.  If they don't even test their installation to ensure it works, they're not worth you paid.  Although, I might call them back, tell them they're not finished, and have them see if they can fix this (at no additional charge, of course).
0
 
scraig84Commented:
I personally don't think quite all of that is needed even though I'm typically a stickler for getting details.  Sounds to me like they broke up the broadcast domain so machines can't broadcast for name resolution anymore.  It's my personal opinion (and also the opinion of almost every person that works with NT in any amount) that for rock solid name resolution, WINS should be used in every environment.  If you don't have it, get it installed and working.  Sure, you can get things to work without it, but you are always chancing things and wind up in situations like this.  If you try to avert the issue now, it will only pop up again.  Get WINS.
0
 
jgarrCommented:
Also I would make sure of the following.
1. All of the switchports should be not be allowed to sense the speed and duplex. All of the server ports should be set to not participate in spanning tree. (In Cisco switches, it is 'set port host')
2. Verify in the network configuration of the servers. Windows can load NetBEUI, IPX and IP. Make sure that you only have IP.
3. Fix WINS. What can you tell us about the WINS environment? Do you have a single domain? How many WINS servers? have you compacted the JET databases?

More specific data is required to get more specific answers.
Good Luck.
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
SteveOPACommented:
Check the setting on the L3 switch for an ip helper address.  If you don't see the line

ip helper-address XXX.XXX.XXX.XXX

the switch may not be passing the WINS requests along.
Put that line in with the IP address for the WINS server and let us know if that fixed it.

Steve Olson
0
 
jgarrCommented:
you shouldn't need an IP helper for WINS. You should configure the hosts either manually or with DHCP with the WINS information.
0
 
andyinet4Commented:
I agree with scraig.

spanning tree is probably set on your access ports on the switch, this needs to be changed to uplink fast. Basically the pc is booting up and broadcasting for domain controllers before the switch port is initialised, this will take around 60 secs. Seems like NT only does at bootup and fails to rebroadcast thereafter.

set spantree portfast mod/port (6/5-12),(6/14-48)enable

on an ios based switch go to the interface, ie

en
conf t
int fa0/1
uplink fast  
0
 
edmonds_robertCommented:
andyinet4,
uplinkfast is used for uplink ports, not access ports.
the last line in your config should read

spanning-tree portfast

if you want portfast enabled on an ios based switch.  
however, if it is a layer 3 switch, and cisco, it is most likely a cli based switch.  

anyway, what is the latest, shamif?  any improvement in your situation?
0
 
lrmooreCommented:
Have any of these comments been of any help to you? Do you need more information?
0
 
shamifAuthor Commented:
WINS fixed the problem. Thank you very much for your help.
0
All Courses

From novice to tech pro — start learning today.