Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Hard Drive Issues

Posted on 2002-07-24
16
Medium Priority
?
255 Views
Last Modified: 2010-04-26
Okay - this is really a two-part question.  I'll be surprised if part #2 is answered because it's mostly speculations, but ideas would be nice.  So here it goes.

#1 - I have an ABIT KT7-RAID system board with an AWARD 6.x BIOS which is cabable of supporting drives in excess of 100GB.  I have an 18GB IBM system drive.  I have 45 and 60GB data drives from IBM.  I have a 100GB Western Digital drive attached to my Highpoint RAID controller.
Problem:  My hard drives report as approx 32GB in size.  The 32GB clip is not on - nor should it need to be since my bios should support the drives.  I have tried the drives in other systems and those systems report the drives as 32GB as well.  I have also moved my 100GB drive from the RAID controller to the main controller the 45 and 60 GB drives were on and the system reports the size of the 100GB drive correctly.  This has actually been a problem for a while, but somehow I was able to format the 45 and 60GB drives to the appropriate size.  But even the IBM software reports the drives as the incorrect size.  I've run checks on them and the integrity of the drives seems to be intact, but the data is flaky to access and most disk utilities bomb out when I try to run them.  I even tried a zero-fill on one of the drives to try and wipe out any 'rouge' data that may have been there.  IBM tech support was unable to help me. Ideas?  Suggestions?

#2 Another drive problem.  This is the second time that #1 has happened to me.  Last time just one drive crapped out on me and this time it's both of the larger IBM drives.  The partition tables are corrupted on them.  I'd like to keep the data, but most of all I want to get them reporting the correct size to the BIOS.  Now this is where it gets strange...  I was working on the problem listed above and two days after it happened I decided to take out both the 45GB and 60GB drives to see if my system would boot without them (it wouldn't boot with them in).  Well - now my main 18GB system drive is corrupted!  It lost it's partition info as well.  I ran a demo software problem and it found all the partitions on my system drive but it couldn't fix them because it was a demo...  Why did this happen?  Virus?  Seems that way, but I have updated McAfee scanning for starters.  Also, why two drives and then 2 days later the other drive?  And why wouldn't my 100GB drive have been affected?  System board?  Could be, but that would be very strange.  Power surge/outage?  Maybe...  I'm out of ideas.  I need to get my system drive fixed - should be easy, just need to but a partition recovery tool.  Then I need to get my system to read the IBM drives correctly.  Then I need to figure out why this happened in the first place!

I'm looking for the most complete answer I can get.  Getting my drives size correct is priority#1 then figuring out why it happned is #2.  If you can answer both of those and I prove it to be correct - you will be the winner hands down!  Otherwise we'll see how close we can get...

Thanks,
-Tim



0
Comment
Question by:lucidus
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
16 Comments
 
LVL 63

Expert Comment

by:SysExpert
ID: 7175713
I would first delete the duplicate question or have community support do it for you.

1) I would suspect that you have motherboard problems, and/or Hard drive problems.

Using the IDE connections on the motherboard only.

I would recommend that you download a diagnostic disk from your harddrive manufacturer's url. This will tell you right off where you are at and if
   you can recover from it. It may be under warranty, the hard drives are usually covered for three years and you can make out the RMA on their site
                     also. Depending on the manufacturer of the hard drive, you can download diagnostic utilities from their sites to check the drives.
 www.seagate.com
  www.maxtor.com 

http://www.wdc.com/service/ftp/drives.html
    www.ibm.com 
http://www.storage.ibm.com/hdd/support/download.htm
    www.fujitsu.com 

2) Do a full RAM test.
  http://www.heise.de/ct/ftp/
               and download the file on the link:
               ctRAMtst - Hauptspeichertest, Version 5.1

               or download directly:
               ftp://ftp.heise.de/pub/ct/ctsi/ctramtst.zip
 http://www.simmtester.com/

3) Run any other hardware diagnostics.

4) Update your BIOS using the latest version

5) Get the correct IDE drivers for your motherboard.

I hope this helps !
0
 
LVL 13

Expert Comment

by:magarity
ID: 7175827
"moved my 100GB drive from the RAID controller to the main controller...reports the size of the 100GB drive correctly"

I think you've explained #1 yourself - the motherboard's BIOS supports this larger drive but the RAID controller's does not.  Since the RAID controller uses its own logic and controlling BIOS routines, this is a perfectly reasonable explaination.  An oversight on the part of the motherboard's manufacturer.

Not sure about #2, but re: "wipe out any 'rouge' data".  'Rouge' is a color or lipstick, 'rogue' is doing something it shouldn't.
0
 
LVL 17

Expert Comment

by:rayt333
ID: 7176190
Something else you can do to help the system keep reporting the correct size of the HD, go into the CMOS setup and change the selection from "auto" to user defined settings. Make sure the correct setting is entered into the CMOS and then leave them at user defined and save and exit.
Now when you boot up everytime it does not have to query the HD's and may even speed up your boot some.
This is not a recommended if you swap HD's out alot, because then of course you will need to go back into the CMOS and either enter the correct parameters or select "auto"
0
Take our survey for a chance to win!

As a valued customer of Targus, we’d like to ask you a few questions about us. As thanks, you will be automatically entered for a chance to win a $500 VISA gift card. To enter, just complete the survey by September 15, 2017.

 
LVL 7

Expert Comment

by:frache
ID: 7176999

About 1)
Agree with Magarity. Try to ugrade raid bios controller.

About 2):

Raid controller use specific method to write data on disk. You can't read data writed by a raid controller with an regular EIDE controller.  

When you realize your tests, if you swapped the disk to the EIDE controller to the Raid controller, it's possible to corrupt your data.


0
 

Author Comment

by:lucidus
ID: 7177174
Maybe I should clarify.  The RAID controller works fine.  It reports drive size correct.  I have the newest bios possible for my system board and RAID controller.  When I move my 100GB drive from the RAID contoller to the MAIN contoller it works fine and reports 100GB.  But my IBM drives on the main contoller only report 32GB.  When I move the IBM drives to another computer alltogether they also only report 32GB.  Something appears to be wrong with the IBM drives.  But both of them?  Strange...  How do I fix the drives?  As far as I can tell the drives really are the problem here.  Maybe something in my system corrupted them, but I REALLY need my 45 and 60GB drives to report the correct size!  And that won't do that on ANY machine that I plug them in to...  Does that help clarify?
Thanks,
-Tim
0
 
LVL 7

Expert Comment

by:frache
ID: 7177317
Ok ...
Some hardrives have a jumper to limit size ... it's a compatibility jumper for old bios ...
0
 

Author Comment

by:lucidus
ID: 7177343
Yes my hard drive has a 32GB clip to limit size to 32GB if the BIOS cannot handle it.  But my bios can, and the 32GB is not enabled on either hard drive...
0
 
LVL 7

Accepted Solution

by:
frache earned 600 total points
ID: 7177344
In my opinion your problem is a bad jumpers configuration ..
0
 
LVL 7

Expert Comment

by:frache
ID: 7177350
0
 
LVL 7

Expert Comment

by:frache
ID: 7177382
With IBM drives, pins for size limitation seems to be "D" and "B".
0
 

Author Comment

by:lucidus
ID: 7177425
On my master drive I have the pins on G/H and A/B which is for the 16 head configuration.  I'm positive it has 16 heads, but maybe I need to try the 15 head jumpers? G/H and C/A?
0
 
LVL 16

Expert Comment

by:Kyle Schroeder
ID: 7177455
Well, you may not have heard about it (and I'm positive IBM's support didn't tell you) but there is a class-action lawsuit that I believe is still active related to abnormally high failure rates of IBM 75GXP (and possibly 60GXP series) harddrives.  This is part of the reason IBM is getting out of the consumer harddrive business (they're selling to Hitachi or Fujitsu I believe).

What happens if you put only one of the drives on the cable (on the end connector of the IDE cable, btw you are using the 80-conductor cables that came with the drives right, not the 40 wire cables from ATA-33 drives?) and set it to master, does it report correctly?  After flashing your BIOS to the latest version, did you follow the directions exactly as described on Abit's webpage (using the /cx etc switches after the awdflash.exe command) and then go into BIOS setup and load Setup Defaults, then tweak the harddrive settings and memory timings (if you had done this previously).

Have you looked at Paul's Unofficial Abit KT7/A/-RAID FAQ?
http://www.viahardware.com/faq/kt7/kt7faq.htm
Specifically, the Disks section.  I'll bet you also have a Soundblaster Live! card in the system, right?  You'll also want to be sure to install the VIA 4in1 driver from www.viaarena.com

-dog*
0
 
LVL 7

Expert Comment

by:frache
ID: 7177466
Can you give us "exact" reference of your harddrives ?
0
 
LVL 7

Expert Comment

by:frache
ID: 7177508
Can you give us forme information about your problem ...
Because the O.S could be the problem :
Windows 2000 (and presumably Windows XP) cannot format a volume greater than 32GB in size using the FAT32 file system (although it can read and write to larger FAT32 partitions created on other machines). If you need to create a volume greater than 32GB in size you must use the NTFS file system instead. For more details see the Microsoft knowledge base articles Q184006 and Q93496 for further information.
0
 

Author Comment

by:lucidus
ID: 7178136
Thank you all for your answers and suggestions.  Although not a direct answer, frache's comment sent me along the right track.  As soon as I changed the jumpers to the 15 head mode the drives work great now!  Still not sure why my system drive crapped out, but I'm in the process of fixing that now.
Thanks again,
-Tim
0

Featured Post

Looking for the Wi-Fi vendor that's right for you?

We know how difficult it can be to evaluate Wi-Fi vendors, so we created this helpful Wi-Fi Buyer's Guide to help you find the Wi-Fi vendor that's right for your business! Download the guide and get started on our checklist today!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

pc, laptop  monitor connection configurations
In the modern office, employees tend to move around the workplace a lot more freely. Conferences, collaborative groups, flexible seating and working from home require a new level of mobility. Technology has not only changed the behavior and the expe…
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …
Suggested Courses

715 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question