Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 179
  • Last Modified:

Can't access Win98 from XP?

Hi all,

I have a windows 98 machine on our network which I want to access from my XP machine. I have enabled file and print on the 98 machine and shared the drive. I see the share in the XP network neighbourhood but when I try to access it it says to check the access rights and that the network share is no longer available.

I can however pull files off a share my XP machine to the 98 machine without any problems. Also it seems as though I can't put files to any share on any machine (nt4, xp) from the 98 machine. I also have a ftp server set up on the xp machine and I can't send files to that either (using cute ftp). It logs in ok and I get a list of directories but when I try to send a file it just timesout. Both machines are on a simple layer 2 network all on the same ip range, no firewalls or anything in between.

Can anybody help!!!

Thanks
0
erik_nodland
Asked:
erik_nodland
  • 3
  • 2
  • 2
  • +2
1 Solution
 
stevenlewisCommented:
0
 
erik_nodlandAuthor Commented:
Thanks for the info but I have already seen this document and I have everything set up as it recommends. Still no joy.
0
 
SysExpertCommented:
1) Get the newest NIC drivers for all machines invovled.
2) Remove any excess protocols. Leave TCP/IP and maybe NETBeui.
3) Try using a newly defined user and password.

4) Makse sure that all firewall software is disabled !!

I hope this helps !
0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
stevenlewisCommented:
On my home/office network, I used to be able to access files and subfolders that are in my XP machine, which is the server. Now, I get an error that doesn't make any sense: "you may not have permission to access this resource. Check with your network administrator." And in the same error box, a second note: "Not enough server storage to process this command" Turns out, it's a cure for the common anti-virus. When installing NAV and other antivirus programs, they alter a registry key that XP depends on for simple network tasks. Elusive, because MS lists the fix under NT. Of course, Windows XP networking is based on the NT kernel. SO HERE IS THE FIX that worked for me.

Quoting MS:

To resolve this behavior, increase the IRPStackSize value on the server: Click Start , and then click Run . Type regedt32 , and then click OK . Navigate to the following key:

HKEY LOCAL MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters

In the right pane, double-click the IRPStackSize value.

NOTE: If the IRPStackSize value does not already exist, use the following procedure to create it:

In the Parameters folder of the registry, right-click the right pane. Point to New, and then click DWord Value. Type IRPStackSize.

IMPORTANT: Type "IRPStackSize" exactly as it is displayed because the value name is case-sensitive.

Change the Base to decimal. In the Value Data box, type a value that is larger than the value that is listed. If you created the IRPStackSize value using the procedure described in step 4, the default value is 15. It is recommended that you increase the value by 3. Therefore, if the previous value was 11, type 14 , and then click OK. Close the Registry Editor. Restart the computer. If the problem persists after you complete the preceding procedure, try to increase the value of IRPStackSize even more. The maximum value for Windows 2000 is 50 (0x32 hex)"


0
 
erik_nodlandAuthor Commented:
Thanks for the replies. I have tried everything mentioned but still no good.
0
 
erik_nodlandAuthor Commented:
In desperation I got another network card and replaced it and everything works fine now. Very odd as the card is the same make with the same drivers. What I didn;t understand was that I could pull off data from other computers to the 98 machine but not the other way round so I didn;t think it would be a hardware problem?
Thanks for all your help anyway.
0
 
pjdietzCommented:
In order to access shared drives that are on your XP machine from you 98 machine, you will need to add a user onto the XP machine.  

In the Control Panel, go to "Administrative Tools", and then "Computer Management".  

Expand "Local Users and Groups"

Select "Users" and then select "New User..." from the "Action" menu.

Set the username and passwd to whatever you want to use on the win98 machine.  (Do not leave the password blank, XP needs the passwd to be set to something.)  Click create, then close when your are done.

Next, you'll need to assign the new user to a group.  Right-click the new user and select "properties"  Switch to the "Member of Tab"

Click "Advanced" and then "Find Now" to get a list of all Groups.  Select "Remote Desktop Users"  (this will keep then new profile from appearing on the login screen on win XP)

You will now be able to log into your XP machine from the 98 machine.  



 
0
 
SysExpertCommented:
I am glad you got this working.

Your card may have been flakey in some respects

or
simply replacing the hardware caused the system to re-install the drivers and other DLL's correctly.

Just my 2 cents...
0
 
Computer101Commented:
Hello all,
I am Computer101 from Experts-Exchange and also an expert within this topic area. This uestion has been open a long time.  What I am going to do is allow feedback from the questioner and xperts.  If it is not resolved, I will delete or accept an answer based on the info I have been given, Experts, feel free to offer input.  I will monitor these questions for a period of 5-7 days and come back and evaluate.  I will have another moderator (who is also an expert in this topic area) look at the question also to ensure we do the right thing for this question.

Thank you
Computer101
E-E Admin
0
 
Computer101Commented:
Question placed in PAQ

Computer101
E-E Admin
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 3
  • 2
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now