[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 310
  • Last Modified:

ipchains: Imcompatible with this kernel

In RedHat Linux 7.3 when I key in ipchains -L I got the error message ipchains: Imcompatible with this kernel. Any advices please!
0
exchangesmith
Asked:
exchangesmith
1 Solution
 
exchangesmithAuthor Commented:
login as: root
Sent username "root"
root@xxx.xxx.xxx.xxx's password:
Last login: Thu Jul 25 13:31:06 2002 from :0
[root@webserver root]# ipchains -L
ipchains: Incompatible with this kernel
0
 
ahoffmannCommented:
use iptables instead
0
 
MFCRichCommented:
If you already have iptables module loaded you will be unable to use ipchains (and visa versa)

> lsmod

will show you what modules are loaded.
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 
ahoffmannCommented:
MFSRich, are there real security admins who use modules for firewalls (except for testing)? I can't believe. :-O
0
 
bushmanntCommented:
i guess by default, ipchains is not enabled in newer redhats.  make you own kernel, skip out on iptables, turn on all the ipchains options, and it should be good  (that's assuming you're trying to use an old ipchains script, not trying to build a new firewall, in which case, just use iptables, search for IPTABLES HOWTO in this case)
0
 
BlackDiamondCommented:
Actually, the ipchains that you see on the newer kernel versions is just an emulator module that reads ipchains style rulesets and feeds them into iptables.  It only "looks" like ipchains :-> ....   If you want to use the iptables emulator, you will need to set it to startup at boot (chkconfig ipchains --level 345 on).  Then run "insmod ipchains" to get it started.
0
 
BlackDiamondCommented:
<replace>iptables emulator -> ipchains emulator </replace>
0
 
DVBCommented:
#insmod ipchains
would fix the original problem.
Moving the ruleset to iptables is an exercise for the reader.
(and <replace></replace> is better written as s/// ;)).
0
 
StotzmanCommented:
hello

you must compile your "noyau" (it's a french word i don't know what it mean in english)
For it download the new "noyau" for your linux
and recompile it; during that active IPchains

Stotz
0

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now