Solved

The same CID after "Ghost"

Posted on 2002-07-26
15
512 Views
Last Modified: 2008-01-09

I have 2 Win2000 Servers. One was a clean intall, the other is the ghosted image of the first. One machine is running IIS 5, and the other SQL Server 2000. The machines have the same CID.

Initial research indicates that since the machines have the same CID this is the reason that DTC always fails between the two machines.

Can anyone verify that this is the case, and is there an easy fix, or should I do a clean install on the second machine instead of using the Ghost? ...and if I may ask a follow-up question...Is there imaging software that assigns new CIDs during the ghosting process?
0
Comment
Question by:ppastor
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 4
  • 2
  • +3
15 Comments
 
LVL 3

Expert Comment

by:hendrik999
ID: 7180124
Please use the Microsoft sysprep software before you create a ghost image.

Download sysprep utility from Microsoft.
Create diretory c:\sysprep
Copy sysprep.exe and sysprep.inf to this directory.

Example sysprep.inf
=======================================
[Unattended]
    OemSkipEula=Yes
    OemPreinstall=Yes
    InstallFilesPath=C:\winnt\i386

[GuiUnattended]
    AdminPassword=
    TimeZone=110
    OemSkipWelcome=1
    OEMSkipRegional=1
     
[UserData]
    FullName=Ppastor
    OrgName=Ppastor
    ComputerName=

[RegionalSettings]
; e.g. 0409, English (United States)
;    LanguageGroup=1
;    SystemLocale=0409
;    UserLocale=0409
;    InputLocale=0409:00000409

[OEM_Ads]
    Background=setup.bmp

[Networking]
    InstallDefaultComponents=No
=======================================

Run c:\sysprep\sysprep.exe from a command prompt.
Shutdown the PC.
Create a ghost image.
0
 

Author Comment

by:ppastor
ID: 7180143
Thanks for the response Hendrik.

Do you know if this is indeed the reason that the DTC is failing between the two machines?
0
 
LVL 7

Expert Comment

by:jmiller47
ID: 7180188
Well if it is the SID (Security Identifier) you are talking about and not the CID, and you Ghost image did not use Sysprep, then this is precisely what happened.

You can use the instructions above or use Ghostwalker to change the SID.

hendrik999, Is Ghostwalker still available in Ghost? I haven't uesd it in a while... Maybe you know.
0
Optimize your web performance

What's in the eBook?
- Full list of reasons for poor performance
- Ultimate measures to speed things up
- Primary web monitoring types
- KPIs you should be monitoring in order to increase your ROI

 

Author Comment

by:ppastor
ID: 7180218
For jmiller...

I was using the DTCPing tool and it stated that the CID for both machines was the same, and that although the ping works, the DTC would fail.
0
 
LVL 7

Expert Comment

by:jmiller47
ID: 7180245
I'm not sure. That may be something different altogether. I'll look around for inforamtion on that...
0
 
LVL 3

Expert Comment

by:slang9
ID: 7180611
Ghostwalker is still a part of Ghost.
0
 
LVL 7

Expert Comment

by:jmiller47
ID: 7180624
In looking at the following article, I have come to the conclusion that the CID and the SID are one in the same. I have no idea why they call it a CID sometimes, but it seems they are the same thing....

I suggest using Sysprep or Ghostwalker in your situation.
0
 
LVL 7

Accepted Solution

by:
jmiller47 earned 100 total points
ID: 7180625
It would be a good idea to paste the link to the article also....

http://support.microsoft.com/default.aspx?scid=KB;EN-US;q266149&
0
 

Author Comment

by:ppastor
ID: 7180730
Thanks for your help.

I created another ghost after running sysprep, reinstalled SQL Server, and like magic...everything started working the way it's supposed to!

0
 
LVL 7

Expert Comment

by:jmiller47
ID: 7180790
ppastor, I am happy that everything worked but since Sysprep did the trick, I really can't take credit for it and take the points. Hendrik999 really deserves them...
0
 

Author Comment

by:ppastor
ID: 7180796
OK, I'm a newbie here...now what do I do? Initially I wanted to share them between you, but that did not seem to be an option.
0
 
LVL 7

Expert Comment

by:jmiller47
ID: 7180844
Maybe someone else can help. I think you would normally lower the points, then post another question with the additional points with a subject like "points for jmiller47" then that person can accept the additional points.

Since you already accepted, I would go to community Support and ask them to fix for you. Post a 0 point question there. They will fix right away.
0
 
LVL 3

Expert Comment

by:hendrik999
ID: 7182110
Thanks for your fairness jmiller47.
0
 

Expert Comment

by:ComTech
ID: 7182290
Thanks to both for the proffesionalism to handle in such a mannor.

hendrik999 I have left our points in Question Number http://www.experts-exchange.com/jsp/qManageQuestion.jsp?ta=win2k&qid=20328921

jmiller47, we avoid removing points from Experts even if mis-awarded, as long as we have the intended Expert here and is posted.  It is one of our rules, and only in certian circumstances.  This question contains that crieteria, and the award will come from EE rather than the User.


Cheers all,

ComTech
Community Support Administrator  
Experts-Exchange  
0
 

Expert Comment

by:jtonra
ID: 7793443
Just wanted to point something out here for future reference.  I ran into a similar problem and happened upon this forum via Google.  After having done considerable follow-up research on this, I've come to the conclusion that the CID and SID are, in fact, *not* one and the same as posted by jmiller47 earlier.  The CID is (apparently) an identifier used by the distributed transaction coordinator.  I cannot find this documented anywhere.  Cloning the machine also clones this CID which is bad since doing so causes problems for DTC based apps.  Changing the *SID* does not correct the problem because it does not change the CID.  

The solution is (as noted above) to use sysprep prior to cloning.  The reason this works though is because this causes a new CID to be generated as well as a new SID.  

Hopefully this information helps someone else down the line.
0

Featured Post

Optimize your web performance

What's in the eBook?
- Full list of reasons for poor performance
- Ultimate measures to speed things up
- Primary web monitoring types
- KPIs you should be monitoring in order to increase your ROI

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
Ever wonder what it's like to get hit by ransomware? "Tom" gives you all the dirty details first-hand – and conveys the hard lessons his company learned in the aftermath.
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…
In this video, viewers are given an introduction to using the Windows 10 Snipping Tool, how to quickly locate it when it's needed and also how make it always available with a single click of a mouse button, by pinning it to the Desktop Task Bar. Int…

626 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question