Keeps asking people to change there Network password.

Hi guys,
I have a few Win2k workstations in the office on the LAN, thing is when people go to log in it is always asking them to change there password.
Any one know why, Win NT Server and Win 2k workstations.
Password set to never expire, I have setup up many of these before but never had this problem.

Cheers.
pnorris98Asked:
Who is Participating?
 
jmiller47Connect With a Mentor Commented:
Can you try changing the user properties in User Manager for Domains for the user to:
Password Never Expires
User cannot change password.

See if that helps.
0
 
jmiller47Commented:
They are logging on to the Domain and not the local workstation right?
0
 
pnorris98Author Commented:
Yeah they are loggin into the domain.
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
pnorris98Author Commented:
I will try that cheers, but have you any idea as to why it is asking to change the password.

Many Thanx
0
 
jmiller47Commented:
No, as long as the Never Expires attribute is set in their user record in User Manager for Domains and they are logging in to the Domain and not locally, it should work correctly. Are you using the newest Service packs on the Server and the Workstations?
0
 
jhanceCommented:
There are TWO settings here:

1) The password never expires.
2) User must change password at logon.

If #1 is set then perhaps #2 is the problem.  You may have setup to force users to change their password the first time they logon.
0
 
SunBowCommented:
(listening)
0
 
AndySBCommented:
A few things to look at

You havn't by any chance got the user accounts running services on the machines or servers ?  Check the security event logs and see if you can find out when it is happening, might give you some indication as to what is happening.  After you have changed the password, synchronise the domain to ensure that all BDC's have got the latest copy of the DB
0
 
GUEENCommented:
On the 2K workstations disable PW caching:
http://www.winguides.com/registry/display.php/124/
0
 
jmiller47Commented:
Shekerra, I don't know, so that's why I'm asking. Isn't his for Windows 9x only? So that the local PWL file doesn't get out of sync with the network password?

0
 
GUEENCommented:
Guess what jmiller I really do not know for sure.  I was thinking that since they had to authenticate to an NT 4 domain that perhaps there was some caching going on in w2K - I think it is worth a shot to make a registry change to test it...
0
 
jmiller47Commented:
Yes, it is then. I would however make sure to turn this back on if it does not do the trick.

Password caching is a very good thing in Windows 2000, especially for laptops. If the network is down and a user has already logged into the workstation once, his password is cached in the local SAM and that user can log on to the domain even if the domain is unavailable later...

But, if it solves the problem... :-)
0
 
pnorris98Author Commented:
Hi there, Sorry abou the late response,
Setting the password did fix the problem as a patch if you like.
The problem lay in the fact that I had ghosted the hard drives from one of the other PC's here, (they are all identical) I have now rebuilt them all from scratch using install disk rarther than an image from one of the other PC's. And they are ok, just to test I did try using the image and when loggin in it repeatedly asked for the users password to be change, could this have been something to do with a security identifier having the same identifier as the other machines. ??? thats one for another day I think.

Thanks Again,
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.