Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 267
  • Last Modified:

DNS problems in Apache for NT

Every so often I get this error when trying to follow a link on one of my Apache NT sites:  Cannot find server or DNS Error.  I'm using a combination of Adobe Acroforms and PHP to generate my pages.  SQL Server 2000 is the backend, however the database doesn't have anything to do with the link's I'm trying to follow.  I've checked out the PHP code that is generating the HTML and the server variables are correct.  HTTP_HOST points to the right ip address and HTTP_DOCS points to the right folder, so why is it saying that it can't find the server?  If I go back and click the link again it finds the server.  By the way, I'm using Apache 1.3.26 for NT/2000 on a Windows 2000 Server box.
0
bsimmons
Asked:
bsimmons
  • 3
  • 2
1 Solution
 
samriCommented:
bsimmons,

I would have suspected that it is *really* a DNS problem.  This is based on my understanding that when you clicked on certain link on your webpage, the web browser will try to connect to the respective server.  How was the load on the webserver machine?  

try doing a standard ping, and try to play around with the timeout (-w) and packet size (-l).  This is assuming you are on Win2K client machine.

have you considered checking how healthy is your dns server?  Did you use a local DNS server, or remote?  If possible, try doing a simple "nslookup yourapachehostname.domain.tld".  use the actual setting instead of dummy info.

Another option that you might want to try is; Use different browser (From the error, I would have guessed that you are using IE).  Maybe try using Netscape (or other browser), they tend to give a better error messages (personal opinion), rather than just "Cannot Find server or DNS error".

0
 
bsimmonsAuthor Commented:
Here's the thing, the web server has no name associated with it in DNS.  The web application is accessed through IP and port 9040.  Also, this problem is replicated throughout all of our applications that use Apache for NT.  I'm guessing 5 servers at 5 different client sites as well as our corporate office.  Perhaps it is a browser problem, but I still think that Apache is barfing every once in a while.  I mean, the links work about 95% of the time.  It's just that extra 5% that's killing me.
I will try to upgrade from IE 5.5 sp2 to 6 and also install the latest version of Netscape to see if anything is different.  This problem occurs with IE 5.0 and 5.01 as well, so I really don't think it's the browser.

Please keep thinking, you're saving my butt here!!!

Bryan
0
 
samriCommented:
Bryan,

Perhaps could you do a simple test.  Maybe you could try to access the server via IP instead of it's DNS name.  Try doing this at times where you normally encounter the problem.  


We are trying to isolate the DNS problem.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
bsimmonsAuthor Commented:
Actually, the site is never accessed through DNS.  It is always through IP and port.  That is why I was so willing to blame Apache for the mistakes.  By the way, I'm working with Apache 1.3.17 for NT.  I realize that I should upgrade to at least 1.3.26 if not 2.0, but our code base may not work with those upgrades.

Is there anything you can think of that is inherent to Apache 1.3.17 for NT and Internet Explorer that would cause the connection to the server to be lost at sporadic times?
0
 
samriCommented:
Bryan,

Have you consider turning on the apache internal status module (mod_status) and monitor server activity.

Look in httpd.conf for the following directives and uncomment them.

LoadModule status_module modules/ApacheModuleStatus.dll
ExtendedStatus On
<Location /server-status>
    SetHandler server-status
    Order deny,allow
    Deny from all
    Allow from 192.168.0 127.0.0
</Location>

next, use your browser to browse to http://localhost/server-status

Another thing that you could try is to

- Check the request timeout.
#
# Timeout: The number of seconds before receives and sends time out.
#
Timeout 300

Another is to tweak the KeepAlive figure, and maximum request/threads per child.

#
# Number of concurrent threads (i.e., requests) the server will allow.
# Set this value according to the responsiveness of the server (more
# requests active at once means they're all handled more slowly) and
# the amount of system resources you'll allow the server to consume.
#
ThreadsPerChild 30

It all depends on how loaded your apache is.  Remember that each client might be multiple connection (depending on browser type) for each visited page, and might be hogging the server.

Other that, you might consider to upgrade the Apache (or even the OS).  How about the machine itself, does it has sufficient CPU power and/or memory.  Check your NT task maanger for some indication.

Other than that... hmm... we will see what the outcome of these options.

cheers.
0
 
periwinkleCommented:
No comment has been added lately, so it's time to clean up this TA.

I will leave a recommendation in the Cleanup topic area with the following recommendation for this question:

Answered by samri

Please leave any comments here within the next seven days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

periwinkle
EE Cleanup Volunteer
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now