Solved

Opening .JPG files from Explorer doesn't work

Posted on 2002-07-29
17
481 Views
Last Modified: 2010-04-03
When I double-click any .JPG file in Expolrer or Outlook, Photoshop 5.0 opens, but fails to open the file.  I then have to browse to it and open it from within Photoshop.  It then opens just fine.
Windows 2000 obviously associated the .JPG extension correctly, because Photoshop fires up, but it stops short of actually opening the file once it's up.

Any ideas?
0
Comment
Question by:DavidWare
  • 7
  • 2
  • 2
  • +6
17 Comments
 
LVL 2

Expert Comment

by:zombeen
ID: 7197686
shd have explkorer as your default viewer for jpegs , photosho takes a long time to load

zombeen
0
 

Author Comment

by:DavidWare
ID: 7201046

zombeen,
this is the Photoshop TA.  it's for answers using Photoshop.
i don't want to set Explorer as the default .jpg viewer.  that's not a solution, but thanks for the input.


0
 
LVL 16

Expert Comment

by:Sohel Rana
ID: 7202004
Select any picture (.jpg) by cursor and then right click the mouse > choose the option properties > then click the option change > Select the internet explorer or any program in which you want to open those type of picture > then > select the option - Always use this program to open this files.

Next time whenever you open any .JPG pictures it will open according to your selected program.

Hope it will works.

Rana
0
 

Author Comment

by:DavidWare
ID: 7204395
rsdn,
I don't think you read the question, or my last post.

As I said in my question, Photoshop is already associated with the extension, and Photoshop opens when I double click a .JPG file, but Photoshop then just sits there without opening the file itself.

And as I said in my last post, I don't want to use Internet Explorer to open the .JPG file.  This is the Photoshop TA.  That means I am asking for a solution that uses Photoshop.

I suspect that no one will be able to offer assistance in this question.  In fact, I suspect no one is going to read the question.
David
0
 

Author Comment

by:DavidWare
ID: 7204408
This question has been submitted for deletion.  I can not accept the input from the posters as valid for awarding the points.
I would not delete a question that has been addressed legitimately, but I do not feel that the 2 posts have done so.
David
0
 
LVL 20

Accepted Solution

by:
hes earned 100 total points
ID: 7204461
If you are comfortable with regedit check that the entry for opening jpg's has not lost the %1 at the end.
In the registry
HKEY_CLASSES_ROOT
.jpg
The default should be jpegfile
Now in the entry for jpegfile
shell
open
command
Here should be the "full path to photoshop"%1""
if the %1 is missing then when you click on a .jpg photoshop will open but the filename will not have been passed to the program. If it is not edit and add back the %1
0
 
LVL 20

Expert Comment

by:hes
ID: 7204523
I should say look under the .jpg entry and then go to whatever is listed there
0
 
LVL 1

Expert Comment

by:Computer101
ID: 7204560
A request has been made to have this question deleted.  I will acomplish this if no one objects.

Computer101
E-E Moderator
0
What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

 

Author Comment

by:DavidWare
ID: 7206254
Computer101,
Thanks for posting in the Question.
I see that, after I notified the experts that I have asked for it to be deleted, hes has offered a legitimate attempt at a solution that I will persue.
And that is all that I was hoping for.
Even if the comment that hes offered doesn't work, I will not want to delete the Question.
All I wanted was for somebody to read the question.
So please disregard the request to delete.
Thanks,
David
0
 

Author Comment

by:DavidWare
ID: 7206278
hes,
Thanks for your assistance.
Under HKEY_CLASSES_ROOT
.jpg
The default is jpegfile
But in the entry for jpegfile, there isn't a record called shell.
There is only a record called ShellNew, and the default isn't set.
So, I can create Key records called shell, then (under shell) open, then (under open) command, but I'm not sure if that would be correct.
So could you please give me some more details of the structure? (I don't want to do 'trial & error' in the Registry)

Will the new Keys' Default records be set?
Will the 'command' key have the "full path to photoshop"%1" as it's default?
Thanks,
David



0
 

Expert Comment

by:banderss
ID: 7329550
If you are still awaiting an answer on this issue the better place to check this, rather than the registry, is to open explorer, select folder options from the tools menu, and click the file types tab.  Scroll down in the list of registered file types until you find the .jpg entry.  Select it and click the advanced button.  Select the open option and click the edit button.  In the "Application used to perform action" field make sure that the entry specifies the full path to your photoshop exe and at the very end it includes, as mentioned above, the "%1" to pass the file name to the application,
Example:  e:\Adobe\Photoshop 6.0\Photoshp.exe "%1"

Hope this fixes your problem.
0
 

Author Comment

by:DavidWare
ID: 7356133
Hello and thank you, banderss,
I have C:\Program Files\Adobe\Photoshop 5.5\Photoshp.exe "%1" in my "File Type" associations.  It doesn't work.
I am keeping this question open for two reasons.  First, because I'm hoping for a reply from hes because he has already posted a very promising proposal, and second, because I am hoping others may see it and offer their experiences. So I am thankful for your help, but ask you to not lock the question so it will remain in view of other Experts.
0
 

Author Comment

by:DavidWare
ID: 7520696
Well, I can't figure this out, but I thank you for the assistance!
0
 

Expert Comment

by:CygnusX33
ID: 7909443
Hi David,

I have this happen once in a while when a new program is installed that is agressive with its registration.

First open windows explorer,  choose tools, folder options and then the tab for file types.

Scroll to jpg and jpeg file types, select each and delete.

Now choose  NEW  and type  jpg  in the file extension window,
choose advanced, and scroll in the associated file type window to Adobe Photoshop Image click  ok

do the same for jpeg

You may need to do the same for psd files too.

Look over your list in the folder options window and click on jpg, look below the new and delete buttons to see if a default button is displayed, if it is click it. Check any other file types you re-registered.  The presence of a default button means the file associations have been altered.

Once you have done this you should see your icons in windows explorer return to what you are accustomed to.
0
 

Expert Comment

by:CygnusX33
ID: 7909464
Hi all,
Same question asked differently shows up on the photoshop list under the following title:

Title: Photoshop file extensions problem
0
 

Expert Comment

by:llamazrkool
ID: 8220935
This should do it:

Copy the text below, paste it into a new Notepad file, and save it to your desktop with the name, PHOTO6.REG  (Be sure to change the "Save as Type" option to "All Files" from the default "Text Documents".)  Go to your desktop, and double-click the PHOTO6.REG file you just created to add the information to your registry.  If asked if it's okay to import the file into the registry, choose yes.

----------Start copying below this line----------

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\Applications\Photoshp.exe\shell\open\command]
@="\"C:\\Program Files\\Adobe\\Photoshop 6.0\\Photoshp.exe\" \"%1\""

----------Stop copying above this line----------
0
 

Expert Comment

by:Kickhead
ID: 8608026
I had the same problem.  I'm running PS7 and Win2K.  The following fix took care of it.
From Adobe's KB.......
----------------------------------------------
 Topic
Double-Clicking JPG's doesn't work in PS7
LenHewitt - 03:54pm May 6, 2002 Pacific


Q. When I double click some image files in Explorer, or select Open With, Photoshop starts but instead of loading the file presents a New Image d/box.

A. XP/Win2k has put in a bad registry key used for opening that kind of file. If you feel *comfortable* editing the registry, you can find the bad key at

HKEY_CLASSES_ROOT\Applications\Photoshop.exe\shell\open\command\(Default)

For some reason, sometimes Windows XP creates this key the first time without "%1" at the end. Delete the (Default) entry, go to Windows Explorer, select a file type you want to open in Photoshop, right click, go to Open With, select Choose Program, click Browse (Photoshop won't be in the list after deleting the registry key), select your Photoshop executable, and make sure "Always use..." is checked.

If you do not feel comfortable editing the registry DO NOT DO THIS.

You can work around it by dragging the image onto the Photoshop main window background after Photoshop is opened.

 

 
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

HOW TO CREATE A WEB 2.0 IMAGE WITH A REFLECTION I would like to start by saying I know Web 2.0 isn't a style. It is actually the practice of information sharing or  collaboration on the Web. It is also associated with the technology that is used …
In this article, I'll explain how to change the color of a selection in Photoshop. I'm sure there are a couple different ways to do this in photoshop, but this is my preferred method in Photoshop. I am using Photoshop CS6 and I will be adjusting the…
This video will demonstrate how to find the puppet warp tool from the edit menu and where to put the points to edit.
In this tutorial viewers will learn how to increase their history states in Photoshop To undo more than one history state, use Ctrl + Alt + Z, not just Ctrl + Z: View the History window by going to Window > History: The default number of history sta…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now