troubleshooting Question

Unable to run cgi when root is pointed to a directory

Avatar of ehchn1
ehchn1 asked on
Scripting Languages
3 Comments1 Solution259 ViewsLast Modified:
Hi Experts,

I downloaded some perl/cgi codes from the net to add the functionality to my site. The module reside on E:/perl-cgi directory on my server. I set the cgi prefix to cgi-bin.

To access the perl/cgi module, I can just do it by accessing http://mysite/cgi-bin/aFile.pl. That is fine. The problem arises when I have my root pointing to a directory, done by the web server. Meaning, http://mysite actually point to http://mysite/aDirectory though aDirectory is not printed.

Now, when I try to access the perl file, the server would always redirect me to http://mysite/aDirectory/cgi-bin/aFile.pl instead. Therefore, in my cgi mapping, I used the prefix aDirectory/cgi-bin instead.

This method don't work as the server doesn't seemed to be able to detect aDirectory/cgi-bin prefix and treat it as cgi executable.

Any solutions to this problem? I'm stuck with this for days. Please help.

Thanks in advance.


P/S: Btw, I am using Iplanet Web Server, but I don't  
     think it matters.
ASKER CERTIFIED SOLUTION
samri

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Join our community to see this answer!
Unlock 1 Answer and 3 Comments.
Start Free Trial
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 3 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros