troubleshooting Question

"not a winsocket error" is raised during connect (twsocket)

Avatar of olmy
olmy asked on
Delphi
3 Comments1 Solution382 ViewsLast Modified:
I have a client-server software that uses TWSocket 4.15 and it's written with delphi 1.x.

Problem is that in some computers (not always) I get an error message when I try to connect to the server at the first time. When I try to connect again (without restarting the program) it works perfectly. In some computers first two weeks it works perfectly, but then the problem appears.

The error message is sometimes different:
  "Error 0 in function Connect. No Error"
  "Error 87 in function Connect. Not a WinSock error"
  "Error 127 in function Connect. Not a WinSock error"

One annoying thing is that the error never appears when program is started from delphi...

Any ideas?
ASKER CERTIFIED SOLUTION
DragonSlayer

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Join our community to see this answer!
Unlock 1 Answer and 3 Comments.
Start Free Trial
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 3 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros